LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-22-2006, 08:08 PM   #1
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Rep: Reputation: 32
glxgears: Error: couldn't get an RGB, Double-buffered visual.


Hi

I had Slack 10.0 for a long time, then I decided to download the new 10.2 version.

I've downloaded and installed it. But I'm facing a problem. This is the output of glxgears that I am getting :
Code:
koodoo@knapsacker:~$ glxgears
glxgears: Error: couldn't get an RGB, Double-buffered visual.
koodoo@knapsacker:~$
And here's the output of glxinfo :
Code:
koodoo@knapsacker:~$ glxinfo | grep OpenGL
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 845G 20040331 x86/MMX/SSE2
OpenGL version string: 1.2 Mesa 6.1
OpenGL extensions:
koodoo@knapsacker:~$
Actually I was trying to run quake, and it wouldn't, then I checked the output of glxgears and that was what I got. I was easily able to run quake on Slack 10.0
Also I've enabled hardware acceleration.

Thanks in anticipation!
 
Old 03-22-2006, 08:56 PM   #2
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
What video card/chipset? You said you've enabled hardware acceleration, but you didn't post full glxinfo....

You may also want to check my post in the Slackware forum about 3d acceleration here
 
Old 03-22-2006, 09:11 PM   #3
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Thanks for the reply

I've an Intel 845 onboard Graphics device.
Yes I've enabled hardware acceleration. Here's the full output of glxinfo :

Code:
koodoo@knapsacker:~$ glxinfo
name of display: :0.0
display: :0  screen: 0

direct rendering: Yes

server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_visual_select_group
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_SGIS_multisample
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 845G 20040331 x86/MMX/SSE2
OpenGL version string: 1.2 Mesa 6.1
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_filter_anisotropic, GL_IBM_texture_mirrored_repeat,
    GL_MESA_ycbcr_texture, GL_MESA_window_pos, GL_NV_texgen_reflection,
    GL_SGIS_generate_mipmap
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x22 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
koodoo@knapsacker:~$
It was working fine in Slack 10.0. One thing that I've done here is that I've taken a shortcut. I didn't use xorgconfig to setup my xorg.conf, I just copied over my xorg.conf from the previous Slack 10.0 installation. So maybe that's causing the problem.
Anyways I'll post my xorg.conf if required.
Thanks again.
 
Old 03-22-2006, 09:19 PM   #4
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Thumbs up

Ah.... got it!
So stupid of me

The Video Ram option in xorg.conf was commented out. I uncommented it and everything works fine now!

Thanks for the help though
 
Old 03-23-2006, 07:05 AM   #5
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Thumbs down

Ok, Sorry looks like I didn't get it lol

This is what I've found. If the Video Ram option in xorg.conf is commented this is what glxinfo has to say :

Code:
koodoo@knapsacker:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: Yes
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_visual_select_group
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_SGIS_multisample
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 845G 20040331 x86/MMX/SSE2
OpenGL version string: 1.2 Mesa 6.1
OpenGL extensions:
    GL_ARB_multitexture, GL_ARB_texture_border_clamp,
    GL_ARB_texture_compression, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3,
    GL_ARB_texture_mirrored_repeat, GL_ARB_transpose_matrix,
    GL_ARB_vertex_buffer_object, GL_ARB_vertex_program, GL_ARB_window_pos,
    GL_EXT_abgr, GL_EXT_bgra, GL_EXT_blend_color, GL_EXT_blend_func_separate,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_compiled_vertex_array, GL_EXT_draw_range_elements,
    GL_EXT_fog_coord, GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_stencil_wrap,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_filter_anisotropic, GL_IBM_texture_mirrored_repeat,
    GL_MESA_ycbcr_texture, GL_MESA_window_pos, GL_NV_texgen_reflection,
    GL_SGIS_generate_mipmap
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x22 24 tc  0 32  0 r  y  .  8  8  8  8  0  0  0  0  0  0  0  0 0 None
koodoo@knapsacker:~$
Here I have hardware acceleration and direct rendering but glxgears gives the previously mentioned error.

If ,however, I uncomment the Video Ram option in xorg.conf this is what glxinfo says :

Code:
koodoo@knapsacker:~$ glxinfo
name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_visual_select_group
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
    GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_polygon_offset,
    GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_texture_mirror_once, GL_ATI_texture_env_combine3,
    GL_IBM_texture_mirrored_repeat, GL_MESA_pack_invert,
    GL_MESA_ycbcr_texture, GL_NV_blend_square, GL_NV_point_sprite,
    GL_NV_texgen_reflection, GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
    GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
    GL_SGIX_shadow_ambient
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x22 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x24 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x25 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
koodoo@knapsacker:~$
Now I do not have any hardware acceleration!
Help needed!

Sorry for all the confusion that I have caused

Last edited by koodoo; 03-23-2006 at 07:07 AM.
 
Old 03-23-2006, 08:24 AM   #6
cwwilson721
Senior Member
 
Registered: Dec 2004
Location: In my house.
Distribution: Ubuntu 10.10 64bit, Slackware 13.1 64-bit
Posts: 2,649
Blog Entries: 1

Rep: Reputation: 66
No confusion. The VideoRam option sometimes needs to be commented out (It is also commented out on mine)

Were you running glxgears as user or root?

Also, save a copy of your current xorg.conf, and try 'xorgsetup'(shorter, automatic) It may give you a better xorg.conf

Last edited by cwwilson721; 03-23-2006 at 08:28 AM.
 
Old 03-23-2006, 02:55 PM   #7
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
I tried running glxgears as a normal user (root didn't have access to the user's display) Then I even logged in as root and ran glxgears but got the same error message.

I'm not at my Linux box rite now. I'll try setting up a new xorg.conf file using xorgsetup as soon as possible.

Thanks again
 
Old 04-03-2006, 07:04 PM   #8
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
First of all, I would like to apologize for such a late reply. We had exams all this time so didn't get time.

I tried setting up xorg.conf using xorgsetup but got identical results. Here's what happened. I set up xorg.conf using xorgsetup, started X and ran glxgears, I got :
Code:
koodoo@knapsacker:~$ glxgears
libGL error: failed to open DRM: Operation not permitted
libGL error: reverting to (slow) indirect rendering
glxgears: Error: couldn't get an RGB, Double-buffered visual.
koodoo@knapsacker:~$
I looked up xorg.conf and found that this was missing :
Code:
Section "DRI"
        Group		0
        Mode		0666
EndSection
After adding this section and restarting X glxgears gave me the same old error message :
Code:
koodoo@knapsacker:~$ glxgears
glxgears: Error: couldn't get an RGB, Double-buffered visual.
koodoo@knapsacker:~$
xorgconfig gave identical results!

One thing that I would like to mention again is that, If video ram option is commented in the xorg.conf file, the output of glxinfo is :
Code:
-----------------------

direct rendering: Yes

-----------------------
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) 845G 20040331 x86/MMX/SSE2
OpenGL version string: 1.2 Mesa 6.1
-----------------------
-----------------------
koodoo@knapsacker:~$
and now if I uncomment the video ram option and restart X the output of glxinfo is :
Code:
-----------------------

direct rendering: No 
-----------------------
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1) 
-----------------------
-----------------------
koodoo@knapsacker:~$
I'll post my xorg.conf file if required
Thanks
 
Old 04-08-2006, 11:59 AM   #9
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
still no luck
 
Old 08-02-2008, 01:56 AM   #10
octavarium
LQ Newbie
 
Registered: May 2008
Location: Trapped inside this octavarium
Distribution: Gentoo
Posts: 2

Rep: Reputation: 0
Check your drivers

I realize this is a very old post, but as it has no solution (I get upset when i see a 2 year old post left unsolved) I would like to share my solution to this "Double-buffered visual" error.
I had a similar problem with my nvidia geforce2 mx and found that it was just a driver issue for me. I had followed a guide that was slightly misleading, and after checking the nvidia list of supported video cards found i had installed the wrong drivers.
Code:
# lspci | grep nVidia
this is a link to the list:
http://us.download.nvidia.com/XFree8...ppendix-a.html

enable support for module loading, mtrr, System V IPC, and ensure that you have selected the correct chipset for agpgart; also make sure you have disabled framebuffer support as it conflicts with the nvidia drivers.

for my system the upgrade from nvidia-drivers 1.0-71xx to 1.0-96xx solved this problem.
Code:
# emerge --unmerge nvidia-drivers
# modprobe -r nvidia
# echo ">=x11-drivers/nvidia-drivers-97.00" >> /etc/portage/package.mask
# emerge --ask --verbose nvidia-drivers
# modprobe nvidia
# eselect opengl set nvidia
$ startx
You may also need to comment out a few modules in your xorg.conf
Code:
Section "Module"
#	Load  "GLcore"
	Load  "dbe"
#	Load  "dri"
	Load  "extmod"
	Load  "glx"
	Load  "record"
	Load  "xtrap"
	Load  "freetype"
	Load  "type1"
EndSection
hope this helps

Last edited by octavarium; 08-03-2008 at 06:56 PM.
 
Old 08-15-2008, 11:06 PM   #11
koodoo
Member
 
Registered: Aug 2004
Location: a small village faraway in the mountains
Distribution: Fedora Core 1, Slackware 10.0 | 2.4.26 | custom 2.6.14.2, Slackware 10.2 | 11.0, Slackware64-13
Posts: 345

Original Poster
Rep: Reputation: 32
Hey, it was nice to see a reply
I've forgotten what I did to solve that problem. I think after some time, and due to other priorities I gave up trying to fix that issue. But this I know, that I had installed the correct driver for my Intel chipset.
Maybe some other fine tuning was required.

Anyways, I'm now upgrading to Slack-12.1 and I'd love to play Quake with it!
I'm hoping I can get it to work this time.

Cheers.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
glxgears error joelescoulie Slackware 3 06-05-2005 02:41 AM
Error with glxgears manikantha Linux - Software 1 03-02-2005 01:28 PM
glxgears gets an rgb error ldin Slackware 5 03-17-2004 09:38 AM
glxgears libGL error BmxFace Linux - General 0 01-26-2004 01:54 AM
KDE 3.1.2 Install Error (With Konstruct) and Visual Desktop Error KneeLess Linux - Software 0 06-04-2003 04:41 PM


All times are GMT -5. The time now is 03:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration