LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-11-2004, 05:23 PM   #1
wrat
Member
 
Registered: May 2004
Posts: 245

Rep: Reputation: 30
giving myself access??


ok I finally created a user for myself instead of running as root and now I cant access my windows drive I dont see anything about a device user in kuser and I attempted to right click and change permissions while root but it said that no change was possible..so how do I give myself access??
 
Old 05-11-2004, 05:55 PM   #2
MasterC
LQ Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Good afternoon

It's normally taken care of when the drive is mounted. The file that will need to be changed is /etc/fstab This is the file that defines where and how everything is mounted. In the options section for the device in question you'll want to add the option "users" to the list of options you have given. In addtion you may also want to give the option "umask=000" for full and open options to every person on your machine.

Cool
 
Old 05-11-2004, 06:10 PM   #3
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
already have done that and still no access although I used unmask=0222
/dev/hdb1 /mnt/windows ntfs ro,user, noauto,unmask=0222 0 0
 
Old 05-11-2004, 06:29 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
It's umask, not unmask
 
Old 05-11-2004, 06:35 PM   #5
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
damn typo ..but still no access after change..error is :Could not enter folder /mnt/windows...this as my user as root I have access
 
Old 05-11-2004, 06:41 PM   #6
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Please post the output of
mount
and
ls -l /mnt


Cheers,
Tink
 
Old 05-11-2004, 06:52 PM   #7
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
mount=
/dev/hda6 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hdb1 on /mnt/windows type ntfs (rw)

ls-l/mnt=
dr-x------ 1 root root 28672 May 11 13:31 windows
 
Old 05-11-2004, 07:37 PM   #8
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Guess there must be another typo in the
fstab, then :)
Copy & paste the thing?


Cheers,
Tink
 
Old 05-11-2004, 07:39 PM   #9
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
ok here it is:
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda5 none swap sw 0 0
/dev/hda6 / ext3 defaults,errors=remount-ro 0 1
/dev/hdc /media/cdrom iso9660 ro,user,noauto 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy auto rw,user,noauto 0 0
/dev/hdc /cdrom iso9660 ro,user,noauto 0 0
/dev/hdb1 /mnt/windows ntfs ro,user, auto,umask=0000 0 0
 
Old 05-11-2004, 07:58 PM   #10
marghorp
Senior Member
 
Registered: Jan 2004
Location: Slovenia
Distribution: Slackware 10.1, SLAX to the MAX :)
Posts: 1,040

Rep: Reputation: 45
/dev/hda1 /mnt/windows ntfs ro,umask=0222 0 0

This should give you access.

Just change the partitions and directories as you have them.
Otherwise see the http://linux-ntfs.sourceforge.net/info for more details on how to mount a ntfs partition

I think the suspicious word in your fstab line is user (I don't know what it does, or I don't want to know)
 
Old 05-11-2004, 08:28 PM   #11
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
still no good..deleted the user line still cant change permissions...still have access as root but not as my user.....wtf..why cant i change permissions?? error is:Could not change permissions for /mnt/windows
 
Old 05-11-2004, 11:29 PM   #12
JimBass
Senior Member
 
Registered: Oct 2003
Location: New York City
Distribution: Debian Sid 2.6.32
Posts: 2,100

Rep: Reputation: 49
I have a Fat32 drive on my machine at work, and I experience a similiar issue to the original poster. The /win2000/ mount on my box is always loaded, and I can browse through it as any user on my system, but only root can make changes to files, even .txt. Whenever I try to chmod or chown any files in the winblows partition, I get an error, something along the lines of "root cannot modify the attributes of these files". I have simply given up on modifying any of the windows files without first su'ing.

Peace,
JimBass
 
Old 05-12-2004, 02:34 AM   #13
Qucho
Member
 
Registered: Mar 2004
Location: Colorado, US
Distribution: Debian "Sarge"
Posts: 228

Rep: Reputation: 30
The 'user' part will allow ANY user mount and unmount such partition, but ONLY the user that mounted such partition has access to it. So, whom ever mounted the partition needs to unmount it for other user be able to use it.

The 'users' parameter would allow any user to mount/unmount regarding who mounted it in the first place.

And you have one more typo !!! in those parameters you are NOT supposed to have spaces in between.

Since you have it set to 'user' and 'auto' the first user to mount it is going to be root.

So if you want to use 'user' set it to 'noauto'
 
Old 05-12-2004, 03:24 AM   #14
lrt2003
Member
 
Registered: Mar 2004
Distribution: Fedora 10
Posts: 182

Rep: Reputation: 30
make sure you have created a folder /mnt/windows before trying to mount it
 
Old 05-12-2004, 07:50 AM   #15
wrat
Member
 
Registered: May 2004
Posts: 245

Original Poster
Rep: Reputation: 30
thanx Qucho that did it!!!
but im not sure what you ment by the spaces error??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
giving user access to 'shutdown -r now' or -h commands Lleb_KCir Linux - General 2 03-16-2005 12:50 PM
Slack is giving me problems and now I can't access anything Mr. Hill Linux - Newbie 4 02-12-2005 07:55 AM
Giving someone FTP-access grugli Fedora 1 12-25-2004 03:44 PM
Giving users access to the system... TCasp77 Slackware 5 02-28-2004 02:18 PM
About giving ppl root/wheel access unSpawn Linux - General 1 05-20-2001 06:52 PM


All times are GMT -5. The time now is 08:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration