LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 10-26-2009, 12:58 AM   #1
lhorace
Member
 
Registered: Aug 2009
Distribution: Fedora
Posts: 126

Rep: Reputation: 21
getting sambe to set the proper permissions on the client, help


I couldn't find sufficient resources on this subject. And I'm stuck and clueless to what and if I am doing anything wrong.

I issued this command in the terminal:
Code:
sudo mount.cifs //comp2.localnet.webwaredev.org/games /mnt/games-share -v -o uid=500 gid=networkshares file_mode=0775 dir_mode=0775
It should be any directories/files created should be assigned uid 500, gid=networkshares and permissions set to 0775.

I had set it to verbose mode and it outputed:
Code:
mount.cifs kernel mount options: unc=//comp2.localnet.webwaredev.org\games,user=root,ver=1,uid=500,ip=192.168.0.3,pass=********
If i'm reading this correctly, only uid was passed. When I 'ls /mnt/games-share', 500 root **** for each file/directory.

Am I doing this correctly? Am I missing a special switch?
 
Old 10-26-2009, 03:15 AM   #2
Tux-Slack
Member
 
Registered: Nov 2006
Location: Slovenia
Distribution: Slackware 13.37
Posts: 511

Rep: Reputation: 36
Tried "rw" option?(drop the quotes)

And I presume uid 500 actually exists?
 
Old 10-26-2009, 11:40 AM   #3
lhorace
Member
 
Registered: Aug 2009
Distribution: Fedora
Posts: 126

Original Poster
Rep: Reputation: 21
I'm still a novice at this, where should I be adding the 'rw' option?

Code:
sudo mount.cifs //comp2.localnet.webwaredev.org/games /mnt/games-share -v -o rw uid=500 gid=networkshares file_mode=0775 dir_mode=0775
Here's my problem, I can create directories but can't create files

Code:
[lhorace@netsrv games-share]$ cd test
[lhorace@netsrv test]$ mkdir test2
[lhorace@netsrv test]$ ls -l
total 0
drwxr-xr-x. 2 lhorace root 0 2009-10-26 12:28 test2
[lhorace@netsrv test]$ touch filetext.txt
touch: cannot touch `filetext.txt': Permission denied
[lhorace@netsrv test]$ cd test2
[lhorace@netsrv test2]$ touch filetest.txt
touch: cannot touch `filetest.txt': Permission denied
[lhorace@netsrv test2]$
Note: uid 500 is lhorace

Is there any sites I can visit to explain a little bit more about the differences between permissions on the server and the client?

Am I seeding the right 'file_mode=0775' in mount.cifs, or is different, '775', 'rwx', or a special mask just for samba?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set file permissions using SFTP client thesignchef Linux - Server 3 04-27-2009 12:00 PM
Proper permissions for a user? Urban Hermit Slackware - Installation 12 05-28-2007 02:39 PM
Using a Windows XP client to set permissions on a Samba share Wendellz Linux - Software 2 02-09-2007 08:01 AM
How do I set up proper drive permissions (fstab reamins static despite all mounts) Lechium Linux - Hardware 9 07-03-2004 09:33 AM
Proper use of permissions ? wmcase Linux - General 4 02-04-2004 03:41 PM


All times are GMT -5. The time now is 08:19 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration