LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices



Reply
 
Search this Thread
Old 06-02-2004, 07:33 PM   #1
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Rep: Reputation: 16
How do I set up proper drive permissions (fstab reamins static despite all mounts)


Hi!

I know similar quesion has been asked many times, and I even looked up these threads, however none of that works for me...

I am running KNOPPIX (Debian) insalled on my HD, rather than from a CD. I had managed to overcome most set up issues. I am total Linux newb, and got it on my machine as a learning experience. So far so good -- Linux is freedom, but freedom comes at a steep price, oh well.

I have an issue setting up permissions to the drives I mount, epsecially my ipod. I had mounted from sda2, and can access is freely as root, however as a user it is unaccessible. Morevover, when I copy folders form ipod into user accessible areas, these folders are restricted as well. I tried re-mounting it with "users" operator, which supposed to make disk aviabale to everyone, but it didnt work. I tried chwon it to the user profile, but it didnt work. Moreover, when I hover mouse in Konqueror, it syas that it is owned by user profile, and has same permissions as other drives (when it obviously isnt).

The problem is solidified by my fstab thinking it's a constant or somehting -- it has references to ipod beforre I mounted it properly, and these references did not change after I mounted it. My fstab entry for ipod looks something like this:

/dev/sda2 /ipod vfat noauto,users,exec,umask=000,uid=[my profile name],gid=[my profile name] 0 0

also when i vim fstab after i exit it i get following lines 3 times:

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Any ideas on what I should do?
Thank you,
Victor
 
Old 06-03-2004, 10:59 PM   #2
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
*bump*
heeeeelp? =)
 
Old 06-03-2004, 11:32 PM   #3
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
I think your error
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

comes from the fact that you are doing an su - then opening up a gui text editor. Try this before su -

xhost +localhost

Quote:
/dev/sda2 /ipod vfat noauto,users,exec,umask=000,uid=[my profile name],gid=[my profile name] 0 0
It should be "user" singular.
 
Old 06-04-2004, 01:35 AM   #4
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
thanks. Changing users to user didnt help, however. Is there any way, other thru editing fstab to set drive/mount permissions?
 
Old 06-04-2004, 01:52 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Could you post the output of the /etc/mtab file or the output of the 'mount' command. The mount command with no options will display how devices are mounted. I use the uid=<user name> and gid=<user name> successfully on usb drives and they work for me.
 
Old 06-04-2004, 06:22 AM   #6
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
alright:

mount command returns:

/dev/hda1 on / type ext3 (rw,errors=remount-ro)
proc on /proc type proc (rw)
/dev/pts on /dev/pts type devpts (rw)
/proc/bus/usb on /proc/bus/usb type usbdevfs (rw,devmode=0666)
automount(pid624) on /mnt/auto type autofs (rw,fd=4,pgrp=624,minproto=2,maxproto=4)
/dev/hdc1 on /mnt/hdc1 type reiserfs (rw,nosuid,nodev)
/dev/sda2 on /ipod type vfat (rw,nosuid,nodev)

/etc/mtab is:

dev/hda1 / ext3 rw,errors=remount-ro 0 0
proc /proc proc rw 0 0
/dev/pts /dev/pts devpts rw 0 0
/proc/bus/usb /proc/bus/usb usbdevfs rw,devmode=0666 0 0
automount(pid624) /mnt/auto autofs rw,fd=4,pgrp=624,minproto=2,maxproto=4 0 0
/dev/hdc1 /mnt/hdc1 reiserfs rw,nosuid,nodev 0 0
/dev/sda2 /ipod vfat rw,nosuid,nodev 0 0

guess I gotta re-cmount my hda1 heh... anyhow sda2(ipod) had "noexec" parameter, but I removed it and it dodnt make any difference... should I put it back in... all setting seem to be corrent, at least according to other websites... I'm so lost...
 
Old 06-05-2004, 05:12 PM   #7
Lechium
Member
 
Registered: Jun 2004
Distribution: Gentoo
Posts: 102

Original Poster
Rep: Reputation: 16
*Bump*
Sorry guys, but I cant find a solition to thsi problem no matter where I look... heeelp? =)
 
Old 06-09-2004, 03:10 AM   #8
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Two Ideas. Maybe the users option is mutually exclusive with the guid option. First try taking out the users from the /etc/fstab entry. If that doesn't work. Put the users option back in. Since the users option should allow you to unmount and remount the ipod yourself, put
umount /mnt/ipod
mount /mnt/ipod
in your .bashrc file.

If that doesn't help, one thing you have different from my usb entries is that you are mounting on the root directory. Try changing it to /mnt/ipod.

Good Luck.
 
Old 06-30-2004, 09:01 PM   #9
Tokabowla
LQ Newbie
 
Registered: Jun 2004
Location: St. Louis, MO
Distribution: SuSE Linux 9.1 PE
Posts: 3

Rep: Reputation: 0
Angry Me Too!

I have the same problem. Trying to allow all to read write to a 14G vfat partition. I've edited etc/fstab line for my partition (/dev/hda7)
"/dev/hda7 /mnt/media vfat rw,exec,users,umask=000"
the mount command outputs this:
"/dev/hda3 on / type reiserfs (rw,acl,user_xattr)
proc on /proc type proc (rw)
tmpfs on /dev/shm type tmpfs (rw)
devpts on /dev/pts type devpts (rw,mode=0620,gid=5)
/dev/hda1 on /windows/C type vfat (rw)
/dev/hdd on /media/cdrom type subfs (ro,nosuid,nodev,fs=cdfss,procuid,iocharset=utf8)
/dev/fd0 on /media/floppy type subfs (rw,nosuid,nodev,sync,fs=floppyfss,procuid)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/hda7 on /mnt/media type vfat (rw,uid=000,gid=000)"

So what's the deal?? It SHOULD allow read/writefor all, but no.

HELP!
 
Old 07-03-2004, 10:33 AM   #10
knoppix-3.4
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
(4 times I try to write this mess., enabled cookie ................ [ OK ] )

Now,

Hi,

I had the same pbm.

Just enter a user manager (kuser for kde, webmin ...)
Had the user to the ssh group ( the one you xant him to access to the other ( su ...),
or test with other groups
it's just because ur one don't have the rights...

It woked for me ( kernel-2.4.26 )

bien toi


Ben__________________________

a frenchy often on rtcwet ("free") as .pig.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard drive partitions not set up in fstab/mtab odyssey84 Linux - Newbie 6 10-18-2005 08:59 AM
Getting my fstab to give proper permissions Esmo2000 Linux - Newbie 3 11-10-2004 01:21 PM
Howto set permissions and automount for new drive? andymadigan Debian 4 08-02-2004 11:17 PM
Howto: set permissions on a ntfs drive. Coramoor Slackware 8 05-12-2003 11:51 PM
switching mounts in fstab elpresidente Linux - General 6 07-09-2002 08:54 PM


All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration