LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-01-2015, 11:05 PM   #1
kingston
Member
 
Registered: Mar 2008
Location: Bengaluru, India
Distribution: RHEL 5.5, Solaris 5.10
Posts: 215
Blog Entries: 1

Rep: Reputation: 21
Getting blurred background while accessing via VNC viewer


Hi Guru's

I have two servers running with CentOS 6.7 on ASUS hardware which has intel i-7 processor. VNC server is configured on these servers to provide GUI access over internet.

I am getting GUI sessions with low resolution. Could someone let me know how to get a better resolution. Please find the attached screenshot.

VNC Server configuration is as follows

Code:
VNCSERVERS="1:kingston"
VNCSERVERARGS[1]="-geometry 1000x800 -depth 24"
Xstartup file inside the user's .vnc directory is as follows
Code:
#!/bin/sh

[ -r /etc/sysconfig/i18n ] && . /etc/sysconfig/i18n
export LANG
export SYSFONT
vncconfig -iconic &
unset SESSION_MANAGER
unset DBUS_SESSION_BUS_ADDRESS
OS=`uname -s`
if [ $OS = 'Linux' ]; then
  case "$WINDOWMANAGER" in
    *gnome*)
      if [ -e /etc/SuSE-release ]; then
        PATH=$PATH:/opt/gnome/bin
        export PATH
      fi
      ;;
  esac
fi
if [ -x /etc/X11/xinit/xinitrc ]; then
  exec /etc/X11/xinit/xinitrc
fi
if [ -f /etc/X11/xinit/xinitrc ]; then
  exec sh /etc/X11/xinit/xinitrc
fi
[ -r $HOME/.Xresources ] && xrdb $HOME/.Xresources
xsetroot -solid grey
xterm -geometry 80x24+10+10 -depth 24 -ls -title "$VNCDESKTOP Desktop" &
#twm &
gnome-session &
Video driver and Video Adapter details are follows:
Code:
[root@host ~]# lsmod |grep -i video
video                  21654  1 i915
output                  2409  1 video
[root@host ~]# modinfo i915 |head
filename:       /lib/modules/2.6.32-573.3.1.el6.x86_64/kernel/drivers/gpu/drm/i915/i915.ko
license:        GPL and additional rights
description:    Intel Graphics
author:         Intel Corporation
author:         Tungsten Graphics, Inc.
srcversion:     E804836B245E1F772347E55
alias:          pci:v00008086d000022B3sv*sd*bc03sc*i*
alias:          pci:v00008086d000022B2sv*sd*bc03sc*i*
alias:          pci:v00008086d000022B1sv*sd*bc03sc*i*
alias:          pci:v00008086d000022B0sv*sd*bc03sc*i*
[root@host ~]# lspci -s 00:02.0 -v
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09) (prog-if 00 [VGA controller])
        Subsystem: ASUSTeK Computer Inc. Device 844d
        Flags: fast devsel, IRQ 16
        Memory at f7800000 (64-bit, non-prefetchable) [size=4M]
        Memory at e0000000 (64-bit, prefetchable) [size=256M]
        I/O ports at f000 [size=64]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
        Capabilities: [d0] Power Management version 2
        Capabilities: [a4] PCI Advanced Features
        Kernel modules: i915
Attached Thumbnails
Click image for larger version

Name:	Server_VNC_session.jpg
Views:	27
Size:	59.0 KB
ID:	19712  
 
Old 10-02-2015, 03:16 PM   #2
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 972

Rep: Reputation: 117Reputation: 117
Hi
Maybe the resolution is ok but the colors are c**p?

In any case you should check if it's not the vnc-client that reduces the colors to reduce the i/o therefore improving reactivity.
Therefore the next question is: which vnc server and client software do you use?
You could for example try to use "tigervnc" as vnc-client to get some live infos about compression, resolution and colors that the program decides to use during the remote session.
 
1 members found this post helpful.
Old 10-05-2015, 10:33 AM   #3
kingston
Member
 
Registered: Mar 2008
Location: Bengaluru, India
Distribution: RHEL 5.5, Solaris 5.10
Posts: 215
Blog Entries: 1

Original Poster
Rep: Reputation: 21
Hi Pearlseattle

Thanks a lot for your reply. Actually your suggestion worked partially. I could get a better resolution (1024X1080) once tigervnc-1.4.3 server/viewer is installed.
I could see the screen with the actual resolution and color depth still i move any window in my session (As soon as i started dragging, it started showing the low resolution in the area where that windows was). This is the same case if i open any GUI application/browser.

Do you have any suggestion?
 
Old 10-05-2015, 01:58 PM   #4
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 972

Rep: Reputation: 117Reputation: 117
Hi Kingston

That behaviour is normal if you have a slow connection, your target machine is slow, etc... .
The first priority of vnc will be to give you good reactivity, therefore if for some reason the connection and/or the system is slow it will reduce the used bandwidth by reducing the number of colors.

Read the docs my issuing "man vncviewer":
Quote:
The viewer normally starts in full-color mode, but switches to low-color mode if the bandwidth is
insufficient.
Again, look at "man vncviewer" to see options to force it to use a specific color depth and for other options:
Quote:
...
-QualityLevel level
JPEG quality level (default is 8).


-NoJPEG
Disable lossy JPEG compression in Tight encoding.


CompressLevel level
Use specified compression level (default is 2).


CustomCompressLevel level
Use custom compression level. Default is CompressLevel is specified.
...
-AutoSelect
Use automatic selection of encoding and pixel format (default is on). Normally the viewer
tests the speed of the connection to the server and chooses the encoding and pixel format
appropriately. Turn it off with -AutoSelect=0.
...
 
1 members found this post helpful.
Old 10-05-2015, 06:37 PM   #5
Doug G
Member
 
Registered: Jul 2013
Posts: 734

Rep: Reputation: Disabled
Also check you don't have some screen scaling enabled in your vnc client. Scaling can cause pretty cruddy video.
 
Old 10-20-2015, 01:21 AM   #6
kingston
Member
 
Registered: Mar 2008
Location: Bengaluru, India
Distribution: RHEL 5.5, Solaris 5.10
Posts: 215
Blog Entries: 1

Original Poster
Rep: Reputation: 21
Hi Pearlseattle,

Thanks again for your time and help. It started working as expected after removing the compression option "Auto Select"
Following are the default options i could see after removing the above one.

Quote:
Preferred encoding = Tight
Color Level = Full
Allow JPEG Compression = 8
Thanks again for your help.(Attached the screen shot, hope that helps someone else too)

Thank you Doug for your time. I couldn't find anything related to "Scaling" in the vnc viewer.
Attached Thumbnails
Click image for larger version

Name:	Server_VNC_session_1.jpg
Views:	32
Size:	39.4 KB
ID:	19824  
 
Old 10-23-2015, 05:13 PM   #7
Pearlseattle
Member
 
Registered: Aug 2007
Location: Zurich, Switzerland
Distribution: Gentoo
Posts: 972

Rep: Reputation: 117Reputation: 117
Great!!!
Thank you for posting the feedback & solution!

It could be that maybe in general the vnc handshake&monitoring algos are too aggressive, but as it's working fine for most, you might want to have a look at your own network.
Meaning:
if your target PC is in your same network + the target PC is physically near + the target nor the source PC have an i286 CPU, then you might have a more basic problem with your network that will affect all the other apps that you'll ever use.
(meaning: if your own network is supposed to be at least "normal" (meaning 10MB/s) then the bad resolution of vnc is most most moooooost probably only a symptom) => you might want to investigate this.

Thank you for having marked the thread as solved!!!
Cheeeeeeeeeeers!!!!!!!!!!!
 
Old 10-23-2015, 10:22 PM   #8
Doug G
Member
 
Registered: Jul 2013
Posts: 734

Rep: Reputation: Disabled
Glad you got things going.
Quote:
Thank you Doug for your time. I couldn't find anything related to "Scaling" in the vnc viewer.
All vnc clients may not support screen scaling, I usually use vinagre on linux and tightvnc on windows, and both of them have screen scaling options.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
VNC viewer showing black screen. unable to connect VNC server remotely on the server? cyberdome Linux - Server 1 08-01-2014 08:21 AM
VNC viewer vkmgeek Linux - Newbie 2 01-19-2009 06:13 AM
VNC connection to SUSE Linux 10 from a Windows XP VNC Viewer determin2excel Linux - Software 13 10-03-2007 09:38 AM
vnc viewer how to ? ashintoms Linux - Networking 2 07-25-2007 06:43 AM
VNC Viewer Magikx21 Linux - Networking 4 04-27-2005 11:51 PM


All times are GMT -5. The time now is 02:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration