LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 07-17-2005, 11:35 PM   #1
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Rep: Reputation: 15
Gentoo boots without internet? eth0 doesnt exist


I tried emerge --sync to update my list, it failed.

I tried other things that required internet, and it does not work!

I have tried looking in my /etc/conf.d/net, trying to fix it now.


On the startup, when everything loads, it says eth0 does not exist.

Now it's saying "netmount' error.

Last edited by D4ve G; 07-18-2005 at 11:18 AM.
 
Old 07-18-2005, 07:33 AM   #2
or1onas
Member
 
Registered: Mar 2004
Location: Athens,Greece
Distribution: Debian,Ubuntu
Posts: 181

Rep: Reputation: 31
In that case, you should check if your network card is properly installed..
Are you on a dual boot config? Maybe you could boot on another OS and see if it's working there..
 
Old 07-18-2005, 08:22 AM   #3
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Rep: Reputation: 30
post the output from lspci and lsmod

Last edited by 0pal_t0ad; 07-18-2005 at 08:24 AM.
 
Old 07-18-2005, 11:16 AM   #4
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Original Poster
Rep: Reputation: 15
it worked on the liveCD obviously.


lsmod doesnt output anything

Last edited by D4ve G; 07-18-2005 at 11:17 AM.
 
Old 07-18-2005, 11:23 AM   #5
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Rep: Reputation: 30
if you aren't logged in as root, you might need to precede the commands with /sbin/ls* or just su into root.
 
Old 07-18-2005, 11:38 AM   #6
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Original Poster
Rep: Reputation: 15
i mean, it doesnt list any modules, the command itself works.

at the moment im reinstalling gentoo. hopefully i will do something right this time
i think the problem might have been i didnt emerge hotplug or coldplug.

Last edited by D4ve G; 07-18-2005 at 01:14 PM.
 
Old 07-18-2005, 05:27 PM   #7
D4ve G
Member
 
Registered: Jun 2005
Location: Canada
Distribution: XP / Ubuntu
Posts: 55

Original Poster
Rep: Reputation: 15
got it working, coldplug did it
 
Old 07-19-2005, 10:27 AM   #8
0pal_t0ad
Member
 
Registered: Feb 2004
Location: Southampton, England
Distribution: Laptop:Gentoo-i686-2.6.9-r9 Desktop:Slackware10 2.4.26
Posts: 298

Rep: Reputation: 30
no modules at ALL?!?!?! did you compile EVERYTHING into kernel?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet in Gentoo mclinkor Linux - General 17 12-04-2005 03:39 PM
Can't connect to internet w/ Gentoo randcv Linux - Newbie 6 08-19-2005 12:03 PM
gentoo - problem with internet draye Linux - Wireless Networking 1 06-05-2005 08:17 AM
eth0 not found, internet connection 50% of the boots gattaca85 Linux - Software 4 10-18-2004 09:37 PM
dual boots................rather have rubber boots metal_monster Linux - Newbie 1 01-13-2004 12:24 PM


All times are GMT -5. The time now is 11:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration