LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2007, 02:21 PM   #16
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0

I'm having some problems with line 6 (/dev/sda2 / ext3 defaults,errors=remount-ro 0 1). How is it with the spaces in it please? (which ones are tabs, which are regular spaces, and is it always just one space ore more?)
 
Old 02-03-2007, 02:28 PM   #17
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Consider all spaces as tabs, type /dev/sda2 then a tab, then '/' and a tab, 'ext3' and a tab, 'defaults,error=remount-ro' and a tab,'0' and a tab and finally '1'.
 
Old 02-03-2007, 02:45 PM   #18
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
I did that, but I still get this at the startup screen in the recovery mode:

* Checking file systems...
fsck 1.39 (29-May-2006)
WARNING: bad format on line 6 of /etc/fstab

* Mounting local filesystems...
[17179585.100000] FAT: bogus number of reserved sectors
[17179585.160000] FAT: bogus logical sector size 65535
* Configuring network interfaces...
* Setting up console font and keymap...
root@jan-laptop:?#

When I then put in "init 3", gdm starts up. After mounting sda1 in /media/windows, I still can't access it...
 
Old 02-03-2007, 02:54 PM   #19
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Are the Windows partitions ntfs? Change line 6 so it reads
==> /dev/sda2 / ext3 defaults 0 0
 
Old 02-03-2007, 03:05 PM   #20
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Yes, the windows partition is ntfs.
I changed line 6 again, and the same thing came up on the startup screen, except that now the FAT numbers are [17179595.524000] and [17179595.520000]
 
Old 02-03-2007, 03:09 PM   #21
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Ok for the time being comment out line 6, by adding a '#' at the start of the line.

For the ntfs support, you need to install a package called ntfs-3g.
Method:
1) sudo apt-get install ntfs-3g
2) password: <-- enter your user password
3) reboot.
 
Old 02-03-2007, 03:23 PM   #22
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Oh and i forgot, replace 'vfat' in fstab with 'ntfs'.
 
Old 02-03-2007, 03:59 PM   #23
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
I replaced vfat with ntfs in the case of sda1 (windows) and with ext3 in the case of sda4 (documents) because the partitiner frpm the Ubuntu instalation CD indentified it as such (hope that it's supposed to be like that).

trying to install the ntfs-3g package, I got this:

Reading package lists... Done
Reading state information... Done
E: Couldn't find packag ntfs-3g

What should I do, please?
 
Old 02-03-2007, 04:08 PM   #24
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Ahem., you know its actually kinda late here 2:30am, i have to sleep *yawn*, so hopefully someone else will help you.

But i give you this link, enjoy
Howto: Ntfs on Ubuntu
 
Old 02-03-2007, 04:09 PM   #25
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Alright, have a good night and thanx a lot once more...
 
Old 02-06-2007, 05:15 PM   #26
johnsburn16
LQ Newbie
 
Registered: Feb 2007
Location: Montgomeryville PA
Distribution: Gentoo, Debian (and those derived from it)
Posts: 3

Rep: Reputation: 1
Exclamation Try Updating The UUID's

Ok If you Want to use UUIDs and it is having issues with UUIDs then you can generate new UUIDs

This Is An Example The Same Values Will not Work for you:

Ok So Issue the Command uuidgen /dev/? ("?" Being The Partiton With the uuid in question)

root@bluecart-18:~# uuidgen /dev/sda1
74fb76f0-b29d-4051-80ce-c2a224b87240

So Basically on Ubuntu Edgy do a "nano /etc/fstab"

You Have Two Options You can remove all the uuids from the file.

Or Replace the uuids with new ones

Before:
UUID=860c61aa-356a-4ec1-bea3-d3fd88812922 / ext3 defaults,errors=remount-ro 0 1


Do this: uuidgen /dev/sda1
Copy The output and Replace the uuid for the partition you are using as "/" In /etc/fstab.

After:

UUID=efbd7aaf-98b6-4847-9bac-8d6f62e74858 / ext3 defaults,errors=remount-ro 0 1


Thats it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GDM won't start. Pudduh Debian 14 06-14-2006 09:40 PM
gdm won't start doralsoral Linux - Software 0 10-23-2005 09:37 PM
GDM cannot start... shreks Linux - Software 1 10-23-2005 08:37 AM
GDM can't start Belghouth Fedora 2 01-11-2005 04:11 AM
Start kdm instead of gdm pgte3 Linux - Newbie 3 08-25-2004 03:01 PM


All times are GMT -5. The time now is 10:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration