LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 02-03-2007, 07:02 AM   #1
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Rep: Reputation: 0
GDM won't start


Hello,
I have 4 partitions on my HD (Linux system, swap, Windows, Documents).
I just reinstalled Ubuntu Edgy on my laptop (thus messing around only with the Linuw partition and swap), and since then, GDM doesn't start after boot. I have to start Ubuntu in recovery mode, which stops with the following lines:

* Mounting local filesystems...
* Configuring network interfaces...
* Setting up console font and keymap...
root@jan-laptop:#

I have to then start gdm manually. After i login, a window pops up saying:

Initial error
failed to initialize HAL!

Now I can't access my documents partition nor the Windows one, the system doesnt detect any USB devices, and I can't configure my wi-fi and network access.
When running Windows, I can access the Linux partition but not the one with all the documents.

Unfortunately, I'm a complete newbie and don't understand most of the lingo in the forums dealing with such problems.

Any suggestions please?

Thanks in advance

jd
 
Old 02-03-2007, 07:30 AM   #2
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
All right, lets finbd the source of the problem, did you format ANY partition during reinstall? Did you clean out your /home directory? (I'm not saying you should do it)
Quote:
GDM doesn't start after boot
Does it show an error? If yes, which one.
I'm not very ubuntu savvy, but when you get this : root@lan-laptop:~# ; try typing init 3 (or init 4 or init 5) and see if it does the same as a normal boot.
Else, try typing in "/etc/init.d/hald start" and then try starting gdm.

Good luck

PS : running GDM as root is a bad idea.
 
Old 02-03-2007, 07:49 AM   #3
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Ok, I formatted the linux system partition and swap, I didn't touch the Windows partition or the documents partition (at least I'm not aware of it). After all, I can still run Windows.

It doesn' show any error.

init 3 started gdm and it seems to have taken care of the HAL problem as well. However, I still can't access the partition with my documents and the Windows partition and I can't get wifi to work.
 
Old 02-03-2007, 07:52 AM   #4
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
You can't access those partitons because they aren't mounted. Post the output of these.
#fdisk -l or /sbin/fdisk -l
#cat /etc/fstab
 
Old 02-03-2007, 08:09 AM   #5
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Hmm... none of these does anything.
 
Old 02-03-2007, 09:53 AM   #6
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Ok, I guess the commands were supposed to list the partitions on my disk. They didn't work for some reason, but I think I got this info from the disk partitioner that's on the instalation CD:

Partition Filesystem Size Used Unused Flags
/dev/sda1 ntfs 20.79 GiB 15.49 GiB 5.30 GiB boot
/dev/sda2 ext3 21.51 GiB 2.13 GiB 19.38 GiB
/dev/sda3 extended 972.69 MiB --- ---
/dev/sda5 linux-swap 972.65 MiB --- ---
/dev/sda4 ext3 68.35 GiB 61.90 GiB 6.45 GiB

Partitions sda1,2,4 are not mounted, but I think it might be because I was running Ubuntu from the CD.

Is this info any useful?
 
Old 02-03-2007, 11:40 AM   #7
serafean
Member
 
Registered: Mar 2006
Location: Czech Republic
Distribution: Gentoo, Chakra
Posts: 919
Blog Entries: 13

Rep: Reputation: 124Reputation: 124
ok, could you please tell us which partition is which?
In any case, you could mount them manualy :
Code:
#cd /mnt/
#mkdir "mountpoint"
#mount /dev/sda"x" /mnt/"mountpoint"
where you replace "x" by the partition number you want to mount and "mountpoint" by the folder through which you want them accessible. (all this as root)
e.g. :
Code:
#cd /mnt
#mkdir win
#mount /dev/sda1 /mnt/win
The only problem this could cause is that your files will only be available as root...

I admit this is just evading the problem, but as complete solution, you could try modifying your /etc/fstab accordingly.

Good luck
 
Old 02-03-2007, 12:32 PM   #8
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
ah, sorry

sda1 - windows
sda2 - linux system
sda3 a sda5 - swap (for some reason sda5 is inside sda3 - this must have happened during reinstalation)
sda4 - documents

I managed to mount sda4, but as soon as I mount sda1, the system doesn't allow me to access either one of them:

The folder contentc could not be displayed.
You do not have the permissions necessary to view contents of "mystuff". When I unmount sda1, I can access sda4 again. This happenes also when I mount only sda4. It also means that I still can't access sda4 from Windows either (the partition appears in "My Computer," but shows 0 size and when I try to open it, it says it needs to be formated).

I wish I could modify /etc/fstab, but I have no idea how because as I said, I'm really new to linux.

Last edited by jdcz; 02-03-2007 at 12:43 PM.
 
Old 02-03-2007, 12:56 PM   #9
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Add these to /etc/fstab

/dev/sda1[tab]/pathto/windows[tab]vfat[tab]auto,noexec,umask=0000[tab]0[tab]0
/dev/sda4[tab]/pathto/documents[tab]vfat[tab]auto,noexec,umask=0000[tab]0[tab]0

[tab] refers to Tab key, don't enter it.

Note: Do this as root. Since you're new to Linux, instead of using the command line, try it in graphical mode, i.e., login as root, browse(explore) to /etc, open fstab in text editor, add the lines, save and reboot.

Last edited by Hitboxx; 02-03-2007 at 12:59 PM.
 
Old 02-03-2007, 01:02 PM   #10
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
Thanx, but how do I do that? I couldn`t even find fstab in /etc.
I'm really sorry for my ignorance, so thanx for your patience...
 
Old 02-03-2007, 01:09 PM   #11
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Are you able to get into graphical mode?
 
Old 02-03-2007, 01:27 PM   #12
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
I just managed to do everything you wrote, but the problem is still the same. As soon as I mount sda1, both sda1 and sda4 becole inaccessable and I still can't access sda4 from Windows either.
 
Old 02-03-2007, 01:33 PM   #13
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
Meaning you do have /etc/fstab, can you post it here please?
 
Old 02-03-2007, 01:47 PM   #14
jdcz
LQ Newbie
 
Registered: Feb 2007
Distribution: Ubuntu
Posts: 13

Original Poster
Rep: Reputation: 0
# /etc/fstab: static file system information.
#
# ?file system? ?mount point? ?type? ?options? ?dump? ?pass?
proc /proc proc defaults
0 0
# /dev/sda2 UUID=6162a90d-b6ca-a91d-8ca0f880c5c6 / ext3 defaults,errors=remount-ro 0 1
# sda5 UUID=bcd9549-dd06-4181-86b1-26b863009203 none swap sw
/dev/sdc0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sda1 /pathto/windows vfat auto,noexec,umask=0000 0 0
/dev/sda4 /pathto/documents vfat auto,noexec,umask=0000 0 0

I'm not sure which of the spaces are regular spaces and which are [tab].

There's also a fstab.pre-uuid file which says:

# UNCONFIGURED FSTAB FOR BASE SYSTEM

if that's of any importance.
 
Old 02-03-2007, 02:00 PM   #15
Hitboxx
Senior Member
 
Registered: Mar 2006
Location: India
Distribution: Fedora
Posts: 1,562
Blog Entries: 3

Rep: Reputation: 61
When i said /pathto/windows(documents), i meant your mount point. Ummm, do one thing, create two folders namely windows and documents in /media. Then change the path to reflect these folders if you haven't guessed it by now.

For the swap issue, remove UUID from both those lines, so your /etc/fstab should look like
Quote:
# /etc/fstab: static file system information.
#
# ?file system? ?mount point? ?type? ?options? ?dump? ?pass?
proc /proc proc defaults
0 0
/dev/sda2 / ext3 defaults,errors=remount-ro 0 1
/dev/sda5 none swap sw
/dev/sdc0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/sda1 /media/windows vfat auto,noexec,umask=0000 0 0
/dev/sda4 /media/documents vfat auto,noexec,umask=0000 0 0
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
GDM won't start. Pudduh Debian 14 06-14-2006 09:40 PM
gdm won't start doralsoral Linux - Software 0 10-23-2005 09:37 PM
GDM cannot start... shreks Linux - Software 1 10-23-2005 08:37 AM
GDM can't start Belghouth Fedora 2 01-11-2005 04:11 AM
Start kdm instead of gdm pgte3 Linux - Newbie 3 08-25-2004 03:01 PM


All times are GMT -5. The time now is 05:20 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration