LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-18-2004, 04:00 PM   #1
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Rep: Reputation: 31
fstab ntfs mounting in Ubuntu


Ok, I an trying out Ubuntu linux, and so far it seems really nice.

However, it did not mount my windows drive automatically. I have added a line in my fstab and it is now mounting, but i can't access it as it is owned by 'root' when mounted.

Ubuntu is kind of wierd as there is no root user in the sense that you can log in as root, but i can get a root terminal from a normal user session.

My fstab is this, /dev/hdb1 is the windows drive:

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdb1       /mnt/windows    ntfs    defaults        0       2
/dev/hdc        /media/cdrom0   udf,iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
I'm not sure which options i need to change to get it to be ro but by all users.

As it is now, when booting and mounting it, i see it go by as 'rw' when it mounts the ntfs drive, which would be bad because rw on ntfs isn't supported yet, correct?
 
Old 12-18-2004, 04:13 PM   #2
claudius753
Member
 
Registered: Jan 2004
Distribution: Mac OS X 10.6.4 "Snow Leopard", Win 7, Ubuntu 10.04
Posts: 322

Original Poster
Rep: Reputation: 31
Well, it figures that as soon as i posted, my searches would finally turn up what I was looking for...

I changed the line to

Code:
/dev/hdb1       /mnt/windows    ntfs    noatime,defaults,users,ro,umask=0 0 0
and now everything works as it should.

Ubuntu even put a 'windows' disk on the screen if you go to 'computer->Disks', very nice. It would have been nicer if Ubuntu saw the win partition in the first place during install and asked if i wanted to mount it. The live cd version of Ubuntu had it mounted automatically which was what made me puzzled by its not being there when i installed to disk.... oh well...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto-mounting ntfs partition in fstab Mithrilhall Linux - Newbie 3 09-22-2009 02:03 AM
Mounting NTFS Partitions on Ubuntu vivekian Ubuntu 2 08-01-2005 11:34 AM
fstab help, ntfs. aje Slackware 13 12-19-2004 08:56 PM
Mounting ntfs in fstab calimer Mandriva 2 11-28-2003 09:35 AM
Mounting Ntfs In Fstab jon_k Linux - Software 9 08-31-2003 12:55 AM


All times are GMT -5. The time now is 01:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration