LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-18-2004, 07:41 PM   #1
Iroc
LQ Newbie
 
Registered: Aug 2004
Location: USA, VA
Distribution: Red Hat Linux 7, Gnome
Posts: 1

Rep: Reputation: 0
firefox install error


Hey all, I am new to this forum. A bit back I got this book 'Red hat linux 7 for dummies' and am trying to work thru it. I know its not the latest version but the book goes with the cds it came with.

Anyway I've got a fresh install and I'm trying to install the latest firefox browser. The error I get after I type ./firefox-installer is ....

Code:
./firefox-installer-bin: error while loading shared libraries: libgtk-x11-2.0.so
.0: cannot open shared object file: No such file or directory
I downloaded the tar.gz file into the /root folder and extracted it to /root/firefox-installer

Is this the best place to save files?
Can I install it from this location?

I'm wondering if version 7 is too old to have what the firefox install needs. Red Hat doesnt seem to have a download for 8, or 9 just Fedora.

I thought I needed GTK and I think GTK might need pkgconfig and now I'm on a rollercoaster called CONFUSION

Thanks, Jason
 
Old 08-18-2004, 09:41 PM   #2
Kroenecker
Member
 
Registered: May 2003
Location: The States
Distribution: Gentoo
Posts: 245

Rep: Reputation: 30
Im not going to pretend that I can solve your problems, but did you look to see if you have package config installed on your system? The binary is called pkg-config. Try locate pkg-config. If your system finds the binary, then you are probably ok. In the end you have to look for rpms that you can install. And yes, you will want gtk 2 installed.

You could try to compile and install from source. http://lfs.osuosl.org/blfs/view/stable/ Is where you can find info about compiling and installing gtk from source. Of course your package manager wont be aware of the install if you do it that way. Which means you become responsible for your own actions. (Not that you aren't already.)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Firefox install error markb658 Linux - Software 9 01-29-2006 05:06 AM
Two million error lines in .xsession-error file from FireFox acanton Linux - Software 4 08-28-2005 10:53 AM
Install Error with Firefox - "xpistub" RAMMS+EIN Linux - Software 8 07-18-2005 11:29 AM
Firefox install error PeriT Linux - Software 3 03-10-2005 11:19 AM
Firefox install error, but it still works Dsnapper Linux - Software 2 02-19-2005 02:36 PM


All times are GMT -5. The time now is 10:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration