LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 01-02-2004, 09:50 PM   #1
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Rep: Reputation: 30
Filesystem should be Writeable! Why isn't it?


I'm trying to get my FAT32 partitions writeable under Linux. I've been in my fstab several times in the past but never had this problem. However, even as root, when I change the permissions of the filesystem, something in Linux immediately changes it back (and a change note is immediately reflected). I have been playing in my fstab trying to fix this, and have come across several wierd behaviors, including my access point (/mnt/data to be specific) completely vanishing. What is doing this? Right now, I can read the filesystem on /mnt/data, but I cannot write to it. I'll post my /etc/fstab later if you guys want it.
 
Old 01-02-2004, 10:04 PM   #2
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
/etc/fstab should be something like

/dev/hd? /mnt/data vfat auto,owner,rw 1 2

make sure there is a rw and not only r in the current fstab

After you edit the file do
mount -a

Last edited by darthtux; 01-02-2004 at 10:05 PM.
 
Old 01-02-2004, 10:24 PM   #3
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Original Poster
Rep: Reputation: 30
Here's my current fstab (with a few comments)

LABEL=/1 / ext3 defaults 1 1

none /dev/pts devpts gid=5,mode=620 0 0

LABEL=/home /home ext2 defaults 1 2

none /proc proc defaults 0 0

none /dev/shm tmpfs defaults 0 0

/dev/hda5 swap swap defaults 0 0

/dev/cdrom /mnt/cdrom udf,iso9660 noauto,owner,kudzu,ro 0 0

/dev/cdrom1 /mnt/cdrom1 udf,iso9660 noauto,owner,kudzu,ro 0 0

/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0

/dev/hda1 /mnt/win98 vfat
*Windows 98 home disk*
/dev/hda6 /mnt/winswap vfat
*Windows swap disk*
/dev/hda8 /mnt/oldlin ext2
*an old Linux partition*
/dev/hda7 /mnt/data vfat users 0 0
*my data partition, why not writeable?*

Adding an rw by where I have users causes my access point to vanish. That's what is actually driving me nutzo.

Last edited by lectraplayer; 01-02-2004 at 10:26 PM.
 
Old 01-02-2004, 10:27 PM   #4
scott_R
Member
 
Registered: Jul 2003
Location: Brighton, Michigan, USA
Distribution: Lots of distros in the past, now Linux Mint
Posts: 746

Rep: Reputation: 31
Yeah, the main idea is that fat32 retains whatever permissions it's mounted with. If you mount it with read only permission, then try to chmod a file, you'll get nowhere, even as root. If you mount it read-write, it's dangerous, but it'll work.

If you use your fat32 partitions a lot, you might want to create a user with rw permissions to that mount point, then add that user to whoever needs access. Another user can be set up with just read only permissions, but this is done from the linux side, not the mount/windows side, and can be a real pain to set up correctly.
 
Old 01-02-2004, 10:30 PM   #5
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Try

/dev/hda1 /mnt/win98 vfat auto,owner,kudzu,rw 1 2
 
Old 01-03-2004, 08:48 PM   #6
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Original Poster
Rep: Reputation: 30
I'll try that and see what happens.

Also, if I remember correctly now, I think Kudzu was the killer last time (causing me to lose the /mnt/data access point).

Tried it: /dev/hda7 does not mount in this case. When I mount it by hand, I, again, cannot write to it. The same thing happens all over.

If there was any doubt, I'm trying to make my data partition writeable. /dev/hda7. I have no reason to make /mnt/win98 writeable, as a matter of fact, I would rather that one be read only for now.

Last edited by lectraplayer; 01-03-2004 at 10:03 PM.
 
Old 01-27-2004, 08:32 PM   #7
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Original Poster
Rep: Reputation: 30
Something I've noticed: Lately, RedHat 9 has started saying that FAT32 support is still in ALPHA, though I have never seen that until here lately. Could that have something to do with it? If so, where can I get updates for my FAT32 "engine"?
 
Old 02-03-2004, 09:15 PM   #8
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Original Poster
Rep: Reputation: 30
nudge
 
Old 02-03-2004, 11:07 PM   #9
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
if i remember correctly, even if you set the rw flag in fstab, that still won't work. i didn't for me anyway. what will work is setting the umask option in fstab. if you don't care about who has write permissions to your fat32 partition you can just use:

umask=0000

that will set the permissions of that partition when mounted to 777.
 
Old 02-04-2004, 03:11 PM   #10
lectraplayer
Member
 
Registered: Mar 2003
Location: a little west of Birmingham, AL, USA.
Distribution: SuSE 10
Posts: 915

Original Poster
Rep: Reputation: 30
Thanks! I'll try that. I am the only user here anyway. ...and I like your sig. I guess that explains why I don't get that many crapy ideas, I always fart.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
mounting filesystem writeable lord-fu *BSD 2 07-05-2005 10:59 AM
DVD Re-Writeable rioguia Linux - Hardware 2 03-24-2005 09:28 PM
HD not writeable after few minutes Cyber Maid Linux - Hardware 2 02-25-2005 06:33 PM
Writeable NTFS Drivers? tlawlessrr Linux - Newbie 3 07-10-2004 09:43 PM
world writeable files will not stay world writeable antken Mandriva 1 03-02-2004 06:04 PM


All times are GMT -5. The time now is 06:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration