LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-22-2007, 09:19 PM   #1
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Rep: Reputation: 0
Unhappy Fedora Core 5 - Internet not working


Okay, so, I've googled this which hasn't really helped. I don't have a clue what to do as I'd imagine this should just work, but isn't for some odd reason. Please don't hurt me, I'm complete noob when it comes to linux.

Right, basically, I've got a router (Netgear DG834G). I connect to that via an Ethernet cable. In Windows XP, I just plug it in and it works. I haven't setup a static ip address or anything like that; it's all automatic.

So, I startup Fedora Core 5 (x86_64) (I'm using a dual-boot system). Eth0 (the ethernet port) seems to be fine and is given the [OK]. I go into the Network settings, the hardware seems to be working fine, Eth0 is active. So, all good, right? Well, no. I can't access the internet at all; can't connect at 192.168.0.1 either, so it's not even connecting to my router. I've tried manually setting everything up. Tried static ip addresses. Tried a USB modem (i.e. not using the router). Tried using my USB Wireless adapter (that's even worse, and preferably I want to get that setup too). Nothing works. Can't get the internet at all.

So, what do I need to do? Or if you know any links that might help and I'll try out what's on that page. Anything really, I haven't got a clue about how to do this or what's wrong.

Thanks.

- Ninju
 
Old 09-22-2007, 11:50 PM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Ninju View Post
Please don't hurt me ...
OK. I've put away the cattle prod ...

But I may ask you to type in some commands at a terminal. But don't worry. It is not at all painful.

Quote:
Right, basically, I've got a router (Netgear DG834G). I connect to that via an Ethernet cable. In Windows XP, I just plug it in and it works. I haven't setup a static ip address or anything like that; it's all automatic.

So, I startup Fedora Core 5 (x86_64) (I'm using a dual-boot system). Eth0 (the ethernet port) seems to be fine and is given the [OK]. I go into the Network settings, the hardware seems to be working fine, Eth0 is active. So, all good, right? Well, no. I can't access the internet at all; can't connect at 192.168.0.1 either, so it's not even connecting to my router. I've tried manually setting everything up. Tried static ip addresses.
Rather than try to solve everything right now, I am just going to focus on ethernet. Is the other half of the dual boot perhaps MS Windows? There have been some problems with MS Windows leaving ethernet hardware in a state that was unusable for the Linux drivers. I think this problem has now been resolved, but you are using old software. See this thread for an example. After some wrong turns in solving that problem, the success is reported in post #19 on that thread. So the easy first thing to try is to turn off and unplug the computer for say half a minute. Then boot directly into FC and see if it works.

If this doesn't solve your problem, I would like you to post the output of the command lspci. This will report what hardware you are using. All you have to do is open a terminal window (probably Gnome Terminal ... you should be able to find something in the menus), and type those five letters and hit "enter." You can higlight the output with your mouse, use edit -> copy from the menu and then paste the results into your browser. (It will make it easier to read if you put "code tags" around it; you can do that by highlighting the text in the browser and hitting the pound sign (#). in the toolbar above the box you are posting in.)
 
Old 09-23-2007, 01:12 AM   #3
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Talking

Quote:
Originally Posted by blackhole54 View Post
OK. I've put away the cattle prod ...

But I may ask you to type in some commands at a terminal. But don't worry. It is not at all painful.



Rather than try to solve everything right now, I am just going to focus on ethernet. Is the other half of the dual boot perhaps MS Windows? There have been some problems with MS Windows leaving ethernet hardware in a state that was unusable for the Linux drivers. I think this problem has now been resolved, but you are using old software. See this thread for an example. After some wrong turns in solving that problem, the success is reported in post #19 on that thread. So the easy first thing to try is to turn off and unplug the computer for say half a minute. Then boot directly into FC and see if it works.

If this doesn't solve your problem, I would like you to post the output of the command lspci. This will report what hardware you are using. All you have to do is open a terminal window (probably Gnome Terminal ... you should be able to find something in the menus), and type those five letters and hit "enter." You can higlight the output with your mouse, use edit -> copy from the menu and then paste the results into your browser. (It will make it easier to read if you put "code tags" around it; you can do that by highlighting the text in the browser and hitting the pound sign (#). in the toolbar above the box you are posting in.)
Thanks a lot; turning everything off like that worked. So I guess I'll have to do that everytime I switch then?

PS: I can't believe I didn't include any hardware info in my original post, hahaha.

Thanks again

- Ninju
 
Old 09-23-2007, 01:23 AM   #4
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
You may have better luck if you update to a more recent release. Fedora 7 is the most recent one and number 8 will be coming along in a matter of weeks.

I suspect that your issue is very much hardware specific. I have been using Fedora since FC5 without such problems.
 
Old 09-23-2007, 01:32 AM   #5
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jay73 View Post
You may have better luck if you update to a more recent release. Fedora 7 is the most recent one and number 8 will be coming along in a matter of weeks.

I suspect that your issue is very much hardware specific. I have been using Fedora since FC5 without such problems.
Well, I've always had trouble installing linux, and I actually bought the FC5 DVD about 2 years ago (I had a really god damn awful connection. I downloaded the same FC5 ISO about 6 times and every single time it was bad, so I gave up; don't worry, I only paid about 2.00 and that was p&p). Anyway, so at least I know it works.


I'll probably upgrade next weekend, but I've actually made a serious stab at getting linux running on my machine for a new job I should be starting in a couple of days or so. I need to ssh into the server, and use subversion; stuff like that. Anyway, I need to be able to navigate linux, not to mention svn and stuff is already setup on linux and can be a pain on windows (I don't know how, but I screwed up the windows installation :P). Also, I plan to learn vi.

Yeah, so even though I have a better connection now, I didn't have the time to download FC7 (I'd probably get Ubuntu anyway - I hear it's better), and also, I wanted to make sure it all worked good. I just need to get decent with linux though at the moment. I don't need the latest version to get familiar with at least the basic commands.
 
Old 09-23-2007, 01:36 AM   #6
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Yeah, not a bad choice, Ubuntu. It's all that I'm using most of my time nowadays. Also it's a lot less to download than a full Fedora dvd. Plus you don't get to install another 800MB of updates when you have just installed. And no dependency issues. Ssh is installed by default, subversion isn't but it's only a few clicks away.
 
Old 09-23-2007, 11:57 PM   #7
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by jay73 View Post
I suspect that your issue is very much hardware specific. I have been using Fedora since FC5 without such problems.
TMK, this was only a problem with the forcedeth driver, although I suppose there could be other drivers that had this problem. And as I indicated, I believe this problem has been corrected in the newer versions.

@Ninju,

If it is worth the effort to you, you might do an Internet search to see if you can get a patch for your driver w/o updating your whole system. You can verify whether you are using the forcedeth driver with the command:

Code:
lsmod | grep forcedeth
 
Old 09-30-2007, 07:23 PM   #8
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Okay, having the same problem again. I moved you see. Anyways, I'm at University now, so I don't have any say on the network, just a port in my room. Now, I tried cycling again (is that what it's called?), but it didn't work this time

So anyway, I ran the "lsmod | grep forcedeth" command and it returned this:

Code:
forcedeth 53961 0
So far I've tried entering the default gateway as the primary DNS, and I've tried entering the actual primary DNS and secondary DNS manually too. I'm thinking the problem might be that the Hostname I have is "localhost.localdomain" or something like that? Either that or something to do with this forcedeth thing. Anyway, any help is great. Incase you're too lazy to scroll, I'm running Fedora Core 5 (x86_64).
 
Old 09-30-2007, 08:41 PM   #9
I_like_TUX
Member
 
Registered: Sep 2007
Distribution: Fedora 7, Edubuntu
Posts: 35

Rep: Reputation: 15
Quote:
Originally Posted by Ninju View Post
...Incase you're too lazy to scroll, I'm running Fedora Core 5 (x86_64).
Ninju, you can add distribution information in your profile.

To make things clear, can you do the following?

1. To make sure TCP/IP is working:
$ ping 127.0.0.1

2. Check the ip address of eth0:
$ ifconfig
this makes sure two things, first eth0 is activtied, second is an ip address is assigned to eth0 via DHCP.

3. Try ping ip of eth0

4. Now ping your router, this make sure your machine and the router is connected and on the same network.

5. ping an external ip address, like the DNS supplied by your ISP. If you can ping, you are connected to the Internet.

6. finally, ping an hostname like "yahoo.com", if you can ping, your DNS's are working and everything should be fine now. Did you put your primary DNS as your router's internal ip (192.168.0.1) or the DNS supplied by your ISP?
 
Old 10-01-2007, 01:03 AM   #10
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Ninju View Post
Now, I tried cycling again (is that what it's called?), but it didn't work this time

So anyway, I ran the "lsmod | grep forcedeth" command and it returned this:

Code:
forcedeth 53961 0
Well, we know now that you are using the problematic forcedeth driver. The best solution, of course is to update to the fixed driver. But unless and until you can do that, you are forced to pull the power plug after running MS before running Linux. Make sure you leave the computer unplugged long enough -- things have to actually discharge so that the electronics reset when you plug it back in. (Which is also why a mere power cycle -- turning it off and turning it back on -- is not sufficient; the ethernet interface still has power even when the computer is "off.") I would think half a minute would be plenty, but don't rush it.

I_like_TUX gave you a good troubleshooting procedure if pulling the power plug does not work. Just so you know, based on other threads where this problem was discussed, if the ethernet circuitry is stuck in the state the old forcedeth driver can't handle, you won't even be able to get an IP address from DHCP. ifconfig, however, will claim the interface is "UP," but you won't see an IP address unless you configured it manually. (I imagine configuring it manually is a big no-no on the University network!)
 
Old 10-01-2007, 03:24 AM   #11
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by blackhole54 View Post
Well, we know now that you are using the problematic forcedeth driver. The best solution, of course is to update to the fixed driver. But unless and until you can do that, you are forced to pull the power plug after running MS before running Linux. Make sure you leave the computer unplugged long enough -- things have to actually discharge so that the electronics reset when you plug it back in. (Which is also why a mere power cycle -- turning it off and turning it back on -- is not sufficient; the ethernet interface still has power even when the computer is "off.") I would think half a minute would be plenty, but don't rush it.

I_like_TUX gave you a good troubleshooting procedure if pulling the power plug does not work. Just so you know, based on other threads where this problem was discussed, if the ethernet circuitry is stuck in the state the old forcedeth driver can't handle, you won't even be able to get an IP address from DHCP. ifconfig, however, will claim the interface is "UP," but you won't see an IP address unless you configured it manually. (I imagine configuring it manually is a big no-no on the University network!)
Well, I unplugged the computer AND ethernet cable for about 1 minute, and it didn't work before, but I'll try again just in case I didn't quite do it long enough. Is there any way I can download an updated version of the forcedeth driver in Windows and then install it on linux? (You make it sound like you can't )
 
Old 10-01-2007, 08:09 AM   #12
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by Ninju View Post
Is there any way I can download an updated version of the forcedeth driver in Windows and then install it on linux? (You make it sound like you can't )
I didn't say you can't. Since I didn't really know,I was going to suggest you do an internet search. But I wanted to check something first when I stumbled across this. I thought FC5 was no longer maintained, but that page is from only last march, which I think is after the forcedeth problem was fixed. So you might be able to simply update your kernel (forcdeth has been merged into the mainline kernel for some time now) and get the fixed driver. I would suggest you do your own research to determine if this would work. (I've never actually used the forcedeth driver; I was just involved with some threads where other people were running into this problem.)
 
Old 10-01-2007, 01:12 PM   #13
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by blackhole54 View Post
I didn't say you can't. Since I didn't really know,I was going to suggest you do an internet search. But I wanted to check something first when I stumbled across this. I thought FC5 was no longer maintained, but that page is from only last march, which I think is after the forcedeth problem was fixed. So you might be able to simply update your kernel (forcdeth has been merged into the mainline kernel for some time now) and get the fixed driver. I would suggest you do your own research to determine if this would work. (I've never actually used the forcedeth driver; I was just involved with some threads where other people were running into this problem.)
Ok, so I tried installing the updated kernel, but apparently I already have it installed. I've done some searches online but found nothing of help. I'm really stuck and have no idea what to do right now. I tried searching for an rpm of the updated forcedeth driver or something like that, but no luck. I also ran the command "modprobe forcedeth".. it didn't do anything noticeable or fix the problem.

This is the file name (and type) of the kernel I was trying to install/update:

kernel-2.6.20-1.2320.fc5.x86_64.rpm
 
Old 10-01-2007, 07:58 PM   #14
Ninju
LQ Newbie
 
Registered: Sep 2007
Posts: 15

Original Poster
Rep: Reputation: 0
Okay, so I'm a complete novice when it comes to networks and stuff, so this may sound stupid. I always get assigned the same IP address when I log onto the network. I could not go on it for hours, when I come back on, bang, same IP. Unplug the ethernet cable and computer for a few minutes, plug back in, bang, same IP. So, is it a static IP or can I use this info to setup the network in FC5? On windows it's set to dynamically find the IP info, so I'm guessing it's not a static IP, but since I know:

a) The IP address I'm always assigned
b) Primary and secondary DNS servers
c) DHCP Server

should I try setting up manually? I need some instruction with this though; I only know where to enter DNS servers, and I'm only guessing it's the correct place to enter that info. Screenshots would be brilliant, good directions (i.e. telling me which tab to go to) would be absolutely awesome too. Thanks.

*edit* When I say "log onto the network", I mean being connected to it; there's no login screen or anything like that, or password or username I have to enter.

Last edited by Ninju; 10-01-2007 at 07:59 PM.
 
Old 10-02-2007, 01:09 AM   #15
I_like_TUX
Member
 
Registered: Sep 2007
Distribution: Fedora 7, Edubuntu
Posts: 35

Rep: Reputation: 15
OK, let's make things a bit clearer for everyone:

so you are in university and you connect a network cable from the wall to your router then you connect another network cable from the router to your PC and no more. You can also access the Internet (for example, go to this website) from Windows but for Linux, you cannot access the Internet, not even your router, and you get the same IP address for eth0 everytime. Am I right?

Under Windows, do you also get the same IP address for your PC everytime? If the above setup is what you have, then it is not static IP, it is just that there is only one PC on the local network (the one that start with "192.168.0", we call it network 192.168.0.0) and the router has a preset range of IP addresses (for example, 192.168.0.100 - 192.168.0.200) to assign using its DHCP and the router always pick the first one (192.168.0.100) for your PC. This information should be accessible from your router (you can login to your router in Windows and check it out)

Please also remember your router has TWO IP addresses, one internal (192.168.0.1) and one external (assigned by the university, either static or via DHCP).

I can help you better if you tell me the results of the tests I suggested in previous post.

Last edited by I_like_TUX; 10-02-2007 at 01:11 AM. Reason: typing mistake
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
internet not working in fedora core 3 fakie_flip Linux - Networking 3 06-25-2005 11:09 PM
If i install Fedora Core 2, can i just update to Core 3 from internet? FocusedWolf Fedora 12 02-07-2005 02:03 PM
fedora core 2 no internet, yet working nic ravalox Linux - General 1 06-24-2004 05:32 PM
Upgrading via Internet Fedora Core 1 to Fedora Core 2 cdean Linux - Newbie 2 05-31-2004 12:14 AM


All times are GMT -5. The time now is 12:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration