LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 12-12-2008, 11:47 AM   #1
910Radar
LQ Newbie
 
Registered: Dec 2008
Posts: 11

Rep: Reputation: 0
Question Fedora 10, no sound


Hi All

I feel I shold be able to fix this but having tried a couple of things I'm still not getting anywhere. I've got no sound on my Fedora 10 64 bit installation. I've installed Skype and though the text chat works fine, sound doesn't.

I've tried other applications (Rhythmbox music player set to a radio channel) and even though through PulsAudio volume control I can see what I feel is output its not getting to the speakers. They're not muted before someone asks . . .

The only clue I get is that in the skype terminal I see

ALSA lib control.c:874snd_ctl_open_conf) Cannot open shared library /usr/lib/alsa-lib/libasound_module_ctl_pulse.so

Can anyone help please?

Thanks in advance

R
 
Old 12-12-2008, 12:23 PM   #2
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Try

Code:
iecset audio on
on a terminal/console
 
Old 12-15-2008, 06:35 AM   #3
910Radar
LQ Newbie
 
Registered: Dec 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Hi,

I get

control "IEC958 Playback Default" (index -1) not found

but still no sound . . .

Rgds

R
 
Old 12-15-2008, 02:10 PM   #4
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
hmm, something going wrong there.

Can you please run

alsa-info

on a terminal

And copy/paste the url it gives you after completing.

Thanks
 
Old 12-15-2008, 09:25 PM   #5
trailer8713
Member
 
Registered: Jun 2007
Distribution: Fedora 9
Posts: 109

Rep: Reputation: 15
http://www.alsa-project.org/db/?f=84...b546371e0ad264
I have the same problem to the letter. I do have very little sound if I put the laptop to my ear.
Thank you for any help you would give.
 
Old 12-16-2008, 09:08 AM   #6
910Radar
LQ Newbie
 
Registered: Dec 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Ok, ran the alsa-info and I got . . .

http://www.alsa-project.org/db/?f=2e...ecf8c02522820c

Rgds

R
 
Old 12-16-2008, 01:04 PM   #7
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
Quote:
!!ALSA Device nodes
!!-----------------

crw-rw---- 1 root root 116, 9 2008-12-16 08:31 /dev/snd/controlC0
crw-rw---- 1 root root 116, 8 2008-12-16 08:31 /dev/snd/hwC0D0
crw-rw---- 1 root root 116, 7 2008-12-16 08:31 /dev/snd/hwC0D1
crw-rw---- 1 root root 116, 6 2008-12-16 08:32 /dev/snd/pcmC0D0c
crw-rw---- 1 root root 116, 5 2008-12-16 12:33 /dev/snd/pcmC0D0p
crw-rw---- 1 root root 116, 4 2008-12-16 08:31 /dev/snd/pcmC0D1p
crw-rw---- 1 root root 116, 3 2008-12-16 08:31 /dev/snd/seq
crw-rw---- 1 root root 116, 2 2008-12-16 08:31 /dev/snd/timer
This might be an issue, and IIRC there's at least one other person on LQ using FC10 that had this issue.

Try doing (as root)

chmod a+w -Rv /dev/{snd*,dsp*,mi*}

Then try playing music again.
 
Old 12-17-2008, 04:23 AM   #8
asabjorn
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
I get the same error as above. After the chmod I still have no audio. What is interesting is that it is after one of the recent updates that I lost the sound on FC10, so I used to have sound.
control "IEC958 Playback Default" (index -1) not found
The link to the output from my alsa-info is
http://www.alsa-project.org/db/?f=44...a9ba4c6d721324

thanks
Andreas

Quote:
Originally Posted by x_terminat_or_3 View Post
This might be an issue, and IIRC there's at least one other person on LQ using FC10 that had this issue.

Try doing (as root)

chmod a+w -Rv /dev/{snd*,dsp*,mi*}

Then try playing music again.
 
Old 12-17-2008, 04:28 AM   #9
asabjorn
LQ Newbie
 
Registered: Mar 2004
Posts: 5

Rep: Reputation: 0
there seems to be a mute problem

I solved the problem for my setup. On the commandline I ran 'alsaunmute'. Does that work for you as well? It was not possible for me to perform the same action in the PulseAudio Volume Control application.

Andreas

Quote:
Originally Posted by asabjorn View Post
I get the same error as above. After the chmod I still have no audio. What is interesting is that it is after one of the recent updates that I lost the sound on FC10, so I used to have sound.
control "IEC958 Playback Default" (index -1) not found
The link to the output from my alsa-info is
http://www.alsa-project.org/db/?f=44...a9ba4c6d721324

thanks
Andreas
 
Old 12-17-2008, 04:46 AM   #10
910Radar
LQ Newbie
 
Registered: Dec 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Thanks for all the suggestions but unfortunately at present none of them have worked for me.

A couple more clues: I tried the alsaunmute operation and got


Unknown hardware: "HDA-Intel" "Analog Devices AD1984A" "HDA:11d4194a HDA:11c11040" "" ""
Hardware is initialized using a guess method

Plus in the PulseAudio Volume Control utility I have a small white x on red box next to each speaker button.

Does this give anyone a light?

Rgds

R
 
Old 12-17-2008, 04:22 PM   #11
x_terminat_or_3
Member
 
Registered: Mar 2007
Location: Plymouth, UK
Distribution: Fedora Core, RHEL, Arch
Posts: 342

Rep: Reputation: 38
You could try removing pulseaudio, but I'm not sure what packages require it in FC10.
 
Old 12-18-2008, 12:16 AM   #12
nhchau
LQ Newbie
 
Registered: Dec 2008
Posts: 2

Rep: Reputation: 0
Same here

Same problem happens here. Would you guys try to listen to music from you HEADPHONE? I cannot here any sound from my laptop speakers; however Fedora sound system (listing, recording etc) works well with my headphone and microphone. My laptop speakers are in perfect conditions. They work in Windows XP installed on the same computer with Fedora Core 10.

In System >> Preferences >> Hardware >> Volume control, we can mute/unmute sound of Headphone, Front (speakers) and IEC958 default PCM. I tried mute/unmute but the operations work only on headphone.

Please help me. Thanks a lot.

Last edited by nhchau; 12-18-2008 at 12:18 AM.
 
Old 12-18-2008, 04:08 AM   #13
910Radar
LQ Newbie
 
Registered: Dec 2008
Posts: 11

Original Poster
Rep: Reputation: 0
Yes!! A step forward. I too can get sound through a headset plus I can hear myself through a mic. Still can't use Skype, when I try to call someone I get a pop-up window saying "Problem with Audio playback". I'll try a note to the Skype people to see what they say . . .

Rgds

R
 
Old 12-21-2008, 04:35 PM   #14
listless
LQ Newbie
 
Registered: Dec 2008
Posts: 3

Rep: Reputation: 0
Hi, I also have this problem (sound bars move correctly in pulse audio volume control, `iecset audio on` reports the same error as above and the same for alsaunmute) However to confuse the issue even more I have found a really inconvenient way to fix the problem. If I right click on the KMix speaker icon in the task bar and select Mixer to get the mixer window and then change the volume on the PCM slider, sound suddenly starts working again. I should be clear here - the PCM slider is not muted, nor is the volume low but it seems that in my case, changing the volume on the slider even a little will cure my sound issues.
Does this fix work for anyone else who is having this problem? And can anyone offer an explanation?
The laptop is a dell inspiron 8200 with intel integrated sound. I have had this problem both with fedora 9 and 10.
Thanks etc.

--
edit
oh I should add. The sound fails again as soon as i restart the machine. though logging out and switching users does not kill the sound. This is why i say the fix is inconvenient - sound works but i have to mess with the volume control every time i boot up.

Last edited by listless; 12-21-2008 at 04:41 PM.
 
Old 12-22-2008, 03:33 AM   #15
kilgor
Member
 
Registered: Oct 2002
Posts: 38

Rep: Reputation: 15
confirmed workaround

Quote:
Originally Posted by listless View Post
If I right click on the KMix speaker icon in the task bar and select Mixer to get the mixer window and then change the volume on the PCM slider, sound suddenly starts working again. I should be clear here - the PCM slider is not muted, nor is the volume low but it seems that in my case, changing the volume on the slider even a little will cure my sound issues.
Confirmed. Using "nVidia Corporation MCP51 High Definition Audio (rev a2)", fiddling with the PCM control gets the audio back. alsaunmute and other tricks as mentioned earlier do not work.

Though I have to mention, "no sound" is a bit of a stretch, as I hear silent crackling sounds when doing audio playback after a reboot. These go away once I get the sound back by touching the PCM control in KMix.

This sounds like a bug in alsa, not pulseaudio related. My guess would be, that after a reboot alsa uses the wrong sampling rate and detects the correct one only when the PCM is modified. That's my guess based on the cracking sounds I hear, nothing more.

I'm running a fresh up to date copy of Fedora 10, x86_64.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
no sound fedora 7 with intel sound card duryodhan Fedora 2 01-28-2008 08:54 AM
Fedora Core 5 with Sound Blaster NX USB driver fails to sound maybi7 Linux - Hardware 1 10-26-2006 04:31 PM
Sound card not detected by Fedora Core 2 and no sound. jgr00 Fedora 4 08-19-2004 01:05 PM
Sound Card on Fedora Core 2 only playing test sound silverado0103 Linux - Hardware 0 07-29-2004 04:23 PM
Fedora Core 2 = No sound / Fedora 1 = sound? carlosinfl Fedora 4 06-22-2004 01:28 PM


All times are GMT -5. The time now is 06:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration