LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-31-2005, 06:52 AM   #1
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Rep: Reputation: 0
Fatal Error


I hope Some one Can help with this problem. I recently purchased Linux Mandriva 4 CD + install manual. I followed instructions as set out plus all suggestions that may help.
Booting with CD 1 All goes well to penguin apearence then Hit enter.
Message 1 Loading to memory.
Message 2 Fatal Error Loading to memory
You may restart puter
I tried every other recomended alternative.
My puter is topend Pentium111 Running XP Pro SP2 Quite succesfully for years with 2 x 40 g HD.
1x40g set aside for Linux Exclusive use With Same result.
Still not Beaten I hoped. So I built another P111 with spares Try to load Linux Progress Little better But Same Fatal Error.
PS I exchanged CD set For New Disc1 Alas Same result


Bob_P
 
Old 10-31-2005, 08:19 AM   #2
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
What config do you have exactly?

Did you try the bootprompt option noauto?
(instead of pressing enter after Tux the penguin appears)

Did you try the fb800x600 option?

Did you try to disable any non essential cards in the bios
(incl sound card)

If you did not say xp worked I would have said get memtest86 and
test your memory

Try knoppix 3.8 or 3.9 just as a sanity check
 
Old 10-31-2005, 03:13 PM   #3
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Ta Emmanual_uk After Tux arrives I also Went to F1 Key and tried All options noauto got closer to mark but stalled the same Fatal error after about 10 min+. on the main puter A lot of extra cards Fitted (Graphics+USB+Standard Modem For Fax+ADSL modem). I will Try on spare puter your Disable sugestions P.S ran memcheck also
 
Old 11-01-2005, 02:08 AM   #4
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
Very likely the adsl modem is causing a problem (in my experience), possibly same problem wit hUSB hub if you gone one
Remove the connection to the ADSL modem
Remove the USB hub or any usb connection

You can get them to work one by one once the OS
is installed

What video card have you got?
Maybe it is not supported (or only as vesa)
Try the vesa mode if you get a chance

If the PC installation went further, what were
the last messages before it crashed...
 
Old 11-01-2005, 02:22 AM   #5
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670Reputation: 670
There is an option in BIOS about pnp operating system. Select "no" when installing. This is a bit counter-intuitive. Selecting NO means that the setup will interogate the psi bus itself instead of using what the bios provides. Some BIOSes don't do the best job of this.

You might also have a defective disk. Another possibility is that the drivers for the cdrom drive aren't working right. Although since you don't have an IO error or interrupt error that may not be the case. I'm considering that the error is occurring during the loading of the initrd file, which is what is loaded into the ramdrive during the installation. A bad initrd file may provide a corrupted ramdisk filesystem.

However, please perform the memory check first. It most applicable to the error message returned.
 
Old 11-02-2005, 03:04 AM   #6
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Angry Fatal Error

Ta again to Emmanuel And jschiwal Still no success yet I have dedicated spare Basic Puter to project After memtest It is reduced to bare min Mem 64. After trying your suggestions a little progress is made each time I have reached stage No more Fatal error BUT Now could not mount compressed loopback . THEN it registers fatal error
In the log AltF3 It takes steps to Succesfully compensate for low Memory succeded gz loop . This were it Fails
Alt-F4 kernel msg
<4>hdc: Atapi reset complete
<4>hdc: tray open
<4> end_request: I/O error,dev hdc sector 1254908
<3> buffer I/O error on device hdc, logical block 313727
<6> ide-cd: cmd 0x28 timedout
<4>hdc:irq timeout: status =0xc0 {busy}
<4> ide:Failed opcode was unknown

This message keeps repeating (sector and logical block numbers change )
Untill <3> buffer I/O error on device hdc logical block 313715 This is as Far as it goes no matter what I have Tried Un less I can Get program running on Spare puter I will not attempt to install on main Puter with all its Addon Cards etc.
I hope this will help as You have Both Helped to try and overcome the Problem

Ps after memtest I removed Faulty mem Sticks to see if this would HELP . The extra mem I removed Works Perfectly with WIN 98 SE Linux ????
 
Old 11-02-2005, 03:38 AM   #7
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
It just looks like 64 Mb is too little memory
this spare PC is a PIII, 64 looks too little

I can only suggest you add memory if you want Mandriva on it.
Or try vectorlinux, slackware or other.
But if you are new to linux and have time you may persevere with Mandriva
As I said before try Knoppix live cd (you will need at least 128 mb ram,
just as a sanity check)

uhhw euh, just thought of something about memtest
You used old memory chips: are they all the same speed say PC100?

Last edited by Emmanuel_uk; 11-03-2005 at 01:53 AM.
 
Old 11-02-2005, 10:43 PM   #8
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Re .Fatal Error

Thanks a Lot ( Ta) for all the Suggestions. Installed 128 meg in spare puter.
Tried again repeating the suggestions. Progress apeared better Message Loaded CD Found Linux Loading. But ALAS the same end result Stops at same loading point.
I have replaced CD set No better Result Re formated HD ran Scan Disk CD drivers were updated from win But Linux seems to load it,s own Drivers for CD/Mouse/Keyboard etc. I have tried the usb ports witch Linux seem,s to load its own drivers
I think I might be beaten my system does,nt seem to accept Linux
Bob_P
 
Old 11-03-2005, 02:03 AM   #9
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
Ta for ta
Do not be beaten yet
Maybe try http://www.damnsmalllinux.org/
I recommand you try to duplicate this fatal error with another distro.
The one above is only about 50 Mo

I am puzzled, and start wondering if your cd drive is not an odd one,
but no it must be something else
 
Old 11-03-2005, 07:45 AM   #10
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Original Poster
Rep: Reputation: 0
Ta again Emmanual_uk
Downloaded DSL
Boot up went Great Till
entering runlevel 5 Then guess what
dsl@tty1[dsl]$ This is as far as it goes
The CD drive is old Diamond Data 40X
Tomorrow I will use my Gigabyte DVD ROM from main System in Spare Puter
I scrounged some Ram now its up to 96 (WoW getting bigger)
This spare is Built on Soyo SY-7vba133 It boots up with Pheonix system
It is a total Basic System Put together with leftover Bits
The local IT shop who suggested Linux is gettin me new update System Pentium what ever avail in Jan so you can see why im a bit reluctant to Quit on Linux They suggested Fedora 4 (( To my way of thinking same horse different jocky))
So if Your patients doesnot give up I am willing to Keep Trying I only . I have 10 days left before I go offline til Jan have to buildup $$$$$ bank

Bob_P
 
Old 11-03-2005, 08:05 AM   #11
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
after
Quote:
dsl@tty1[dsl]$
can you enter any command like
ls
cat /var/log/syslog
cat /var/log/Xorg.0.log

Level 5 is when the graphic interface starts.
Hence look like the cd drive is fine
But look like the problem is your video card, maybe
The two last lines above should give you clue about what is the
problem

Can you boot DSL into run level 2?
then type
startx
or
init 5
then look at logs

From what I hear FC4 is not always easy when it comes
to package; there is nothing wrong with mandriva, and you already
have a copy. If you are going to be at ~100 Mb memory
you might be just about ok for Mandriva

I would say this is progress :-)
With all the tinketing you will learn a lot
It is worthwhile investment, even if sometimes frustrating

[edit]
If this was the video card:
try bootprompt option fb800x600 or anything that says
anything about vesa mode or framebuffer mode

Last edited by Emmanuel_uk; 11-03-2005 at 08:10 AM.
 
Old 11-03-2005, 09:03 AM   #12
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Original Poster
Rep: Reputation: 0
DSL

Yes After that Error ??? Esc took me into into 900+ commands I tried what looked like it was relevant But no luck without knowing the command that might work something in my favour one I tried was dsl-hdinstall the error message before it goes wrong is cloop: error-3 uncompressing block 103- about 10 other No,s
this message repeats sequentialy about 12 times before the end Message
 
Old 11-03-2005, 09:19 AM   #13
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
entering runlevel 5 Then guess what
dsl@tty1[dsl]$ This is as far as it goes

If you can type anything, then this is normal
You are in text mode or command line interface, as it is called
cat /var/log/Xorg.0.log
(or some other logname) will tell us why
linux does not want to go in graphic mode

I do not have dsl with me at the minute nor a linux pc
so I cannot say more


type dmesg after failing init 5
you can scroll with <shift> <pge up>

What info can you gather

[edit: had a quick look at dsl 1.5, could not find the log for X,
you will have to look at dmesg; this will not help much.
Am sorry , running out of idea: try F2 at boot and choose
that option where you can interactively set the X server ]

Last edited by Emmanuel_uk; 11-03-2005 at 02:29 PM.
 
Old 11-03-2005, 03:03 PM   #14
Emmanuel_uk
Senior Member
 
Registered: Nov 2004
Distribution: Mandriva mostly, vector 5.1, tried many.Suse gone from HD because bad Novell/Zinblows agreement
Posts: 1,605

Rep: Reputation: 53
try
dsl vga=normal xsetup

Tryvarious XVesa display resolutions, this is what I needed to do here, at home

There is no Xorg.log so try
dmesg | grep -i vesa
dmesg | grep -i video
dmesg | grep -i vga
dmesg | grep -i frame

lspci -v | grep -i vga
 
Old 11-03-2005, 08:23 PM   #15
Bob_P
LQ Newbie
 
Registered: Oct 2005
Posts: 15

Original Poster
Rep: Reputation: 0
G,day Emmanual_uk
After much Frustration I stumbled on Command gnu-utils-restore
It tells me www.ibiblio.org: Hostname lookup failure
Download Error!
This was Site I used SO 1 more Try
as my adsl is back on line
Pushed more ??? it seem The download of 47.7 meg I received is missing what is needed Ty fro different Mirror
BobP
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
fatal error, do I need this? adds2one Slackware - Installation 6 08-31-2005 01:17 PM
Mandrake Move 9.2 error, fatal server error:( silentwhispers Mandriva 1 12-17-2004 12:36 AM
MDK 9.1 Fatal Error in Stage 1: Exec Format Error Beano Mandriva 5 09-12-2004 04:04 PM
Fatal error sunoj81 Linux - General 1 11-03-2003 09:27 PM
Fatal error: XxAndyxX Linux - General 10 06-15-2003 06:56 PM


All times are GMT -5. The time now is 02:27 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration