LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-01-2004, 12:43 AM   #1
ex0r
Member
 
Registered: Jun 2003
Posts: 36

Rep: Reputation: 15
Failed Dependencies, not sure what it means..


I downloaded the new Gaim and tried to install the package and get this...

Code:
error: failed dependencies:
	gtk+2.0 >= 2.0.0 is needed by gaim-0.75-0mdk9.2
	libnss3 is needed by gaim-0.75-0mdk9.2
	perl-base >= 2:5.8.1 is needed by gaim-0.75-0mdk9.2
	libao.so.2   is needed by gaim-0.75-0mdk9.2
	libaspell.so.15   is needed by gaim-0.75-0mdk9.2
	libatk-1.0.so.0   is needed by gaim-0.75-0mdk9.2
	libaudiofile.so.0   is needed by gaim-0.75-0mdk9.2
	libcrypt.so.1   is needed by gaim-0.75-0mdk9.2
	libc.so.6   is needed by gaim-0.75-0mdk9.2
	libc.so.6(GLIBC_2.0)   is needed by gaim-0.75-0mdk9.2
	libc.so.6(GLIBC_2.1)   is needed by gaim-0.75-0mdk9.2
	libc.so.6(GLIBC_2.1.3)   is needed by gaim-0.75-0mdk9.2
	libc.so.6(GLIBC_2.2)   is needed by gaim-0.75-0mdk9.2
	libc.so.6(GLIBC_2.3)   is needed by gaim-0.75-0mdk9.2
	libdl.so.2   is needed by gaim-0.75-0mdk9.2
	libdl.so.2(GLIBC_2.0)   is needed by gaim-0.75-0mdk9.2
	libdl.so.2(GLIBC_2.1)   is needed by gaim-0.75-0mdk9.2
	libgdk_pixbuf-2.0.so.0   is needed by gaim-0.75-0mdk9.2
	libgdk-x11-2.0.so.0   is needed by gaim-0.75-0mdk9.2
	libglib-2.0.so.0   is needed by gaim-0.75-0mdk9.2
	libgmodule-2.0.so.0   is needed by gaim-0.75-0mdk9.2
	libgobject-2.0.so.0   is needed by gaim-0.75-0mdk9.2
	libgtkspell.so.0   is needed by gaim-0.75-0mdk9.2
	libgtk-x11-2.0.so.0   is needed by gaim-0.75-0mdk9.2
	libICE.so.6   is needed by gaim-0.75-0mdk9.2
	libm.so.6   is needed by gaim-0.75-0mdk9.2
	libm.so.6(GLIBC_2.0)   is needed by gaim-0.75-0mdk9.2
	libnsl.so.1   is needed by gaim-0.75-0mdk9.2
	libnspr4.so   is needed by gaim-0.75-0mdk9.2
	libnss3.so   is needed by gaim-0.75-0mdk9.2
	libpango-1.0.so.0   is needed by gaim-0.75-0mdk9.2
	libpangox-1.0.so.0   is needed by gaim-0.75-0mdk9.2
	libpangoxft-1.0.so.0   is needed by gaim-0.75-0mdk9.2
	libperl.so   is needed by gaim-0.75-0mdk9.2
	libplc4.so   is needed by gaim-0.75-0mdk9.2
	libplds4.so   is needed by gaim-0.75-0mdk9.2
	libpspell.so.15   is needed by gaim-0.75-0mdk9.2
	libpthread.so.0   is needed by gaim-0.75-0mdk9.2
	libpthread.so.0(GLIBC_2.0)   is needed by gaim-0.75-0mdk9.2
	libsmime3.so   is needed by gaim-0.75-0mdk9.2
	libSM.so.6   is needed by gaim-0.75-0mdk9.2
	libsoftokn3.so   is needed by gaim-0.75-0mdk9.2
	libssl3.so   is needed by gaim-0.75-0mdk9.2
	libtcl8.4.so   is needed by gaim-0.75-0mdk9.2
	libtk8.4.so   is needed by gaim-0.75-0mdk9.2
	libutil.so.1   is needed by gaim-0.75-0mdk9.2
	libX11.so.6   is needed by gaim-0.75-0mdk9.2
	libXext.so.6   is needed by gaim-0.75-0mdk9.2
	perl >= 0:5.008 is needed by gaim-0.75-0mdk9.2
	perl(AutoLoader)   is needed by gaim-0.75-0mdk9.2
	perl(Carp)   is needed by gaim-0.75-0mdk9.2
	perl(Exporter)   is needed by gaim-0.75-0mdk9.2
	perl(strict)   is needed by gaim-0.75-0mdk9.2
	perl(warnings)   is needed by gaim-0.75-0mdk9.2
	perl(XSLoader)   is needed by gaim-0.75-0mdk9.2
RESULT=1
Now does that mean I need each one of those files or what, I also just tried downloaded the source and compile and when I get to make install I get an error dealing with lss I'm stumped, thanks for help.
 
Old 03-01-2004, 12:49 AM   #2
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
If you're using Slackware, your RPM database is probably empty, which is why you're getting dependency problems, besides you shouldn't use an RPM compiled for Mandrake anyway.
Get the slackpack here:
http://www.linuxpackages.net/
then install it with "installpkg <package.tgz>"
 
Old 03-01-2004, 01:05 AM   #3
ex0r
Member
 
Registered: Jun 2003
Posts: 36

Original Poster
Rep: Reputation: 15
hmmm installpkg command not found...?
 
Old 03-01-2004, 02:16 AM   #4
Demonbane
LQ Guru
 
Registered: Aug 2003
Location: Sydney, Australia
Distribution: Gentoo
Posts: 1,796

Rep: Reputation: 47
try doing it as root, "whereis installpkg" if its still not there
Just to double check, you're running Slackware right?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
failed dependencies koodoo Linux - Newbie 8 03-08-2005 02:14 PM
Failed Dependencies????? igo_mexico Linux - Newbie 2 09-03-2004 08:22 PM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM
Failed Dependencies - Why? leroy27336 General 7 11-18-2003 04:15 PM
failed dependencies emanners Linux - Newbie 2 09-27-2001 04:01 PM


All times are GMT -5. The time now is 01:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration