LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 05-19-2010, 06:59 AM   #1
Nizzok
LQ Newbie
 
Registered: Dec 2009
Posts: 29

Rep: Reputation: 0
external drive mounts as 'read-only'? Lucid Lynx


Hi All,

I just upgraded to lucid lynx, and my trusty external harddrive is now somehow mounting as 'read-only'. What's happened, and how do I fix this? I've gone to the mount point /media/My Passport, the permissions are dwrx-----24, and read-write for my user. When I view the permissions through the desktop file explorer, it says the permissions can't be determined. The drive's fat32. Running on a lenovo g450
 
Old 05-19-2010, 07:43 PM   #2
ewaller
LQ Newbie
 
Registered: Jul 2006
Location: Pasadena, Ca
Distribution: Arch / Gentoo
Posts: 14

Rep: Reputation: 1
How are you mounting the drive?

Using Hal/Dbus?
Have you an entry in /etc/fstab allowing users to mount it?
are you using the mount command with root privileges?

Lets start with the output of:

mount

and

cat /etc/fstab

Thanks.
 
Old 05-20-2010, 01:26 AM   #3
Nizzok
LQ Newbie
 
Registered: Dec 2009
Posts: 29

Original Poster
Rep: Reputation: 0
Hi,

I was just mounting the drive via the auto-mount. I had no problems in karmic, and a few days after switching to lynx, the drive starts to mount as read-only. I've tried mount -f and umount -f, but that doesn't seem to affect the read status. I've also unsuccessfully tried chmoding (noob).


Here's the result of mount (I should mention I'm running badblocks while the usb drive on /dev/sdb1 is unmounted):
Code:
/dev/sda5 on / type ext4 (rw,errors=remount-ro)
proc on /proc type proc (rw)
none on /sys type sysfs (rw,noexec,nosuid,nodev)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /dev type devtmpfs (rw,mode=0755)
none on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
none on /dev/shm type tmpfs (rw,nosuid,nodev)
none on /var/run type tmpfs (rw,nosuid,mode=0755)
none on /var/lock type tmpfs (rw,noexec,nosuid,nodev)
none on /lib/init/rw type tmpfs (rw,nosuid,mode=0755)
gvfs-fuse-daemon on /home/nicholas/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=nicholas)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nod
Here's the result of the cat /etc/fstab
Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda5 during installation
UUID=6095d8c8-7683-47e9-ad9c-8e47c8b8486c /               ext4    errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
UUID=9377517a-0835-49a3-8939-1f35f2c2d58e none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0


I've also included the dosfsck I ran. I've bolded where I think something is going wrong, but I'm not sure where/how to proceed.

Code:
dosfsck -a -v /dev/sdb1
dosfsck 3.0.7 (24 Dec 2009)
dosfsck 3.0.7, 24 Dec 2009, FAT32, LFN
Checking we can access the last sector of the filesystem
There are differences between boot sector and its backup.
Differences: (offset:original/backup)
  67:28/54, 68:fd/1f, 69:0f/fb, 70:d9/16, 72:59/79, 73:5f/20, 74:45/50
  , 75:58/61, 76:54/73, 77:45/73, 78:52/70, 79:4e/6f, 80:41/72, 81:4c/74
  Not automatically fixing this.
Boot sector contents:
System ID "MSWIN4.1"
Media byte 0xf8 (hard disk)
       512 bytes per logical sector
     32768 bytes per cluster
        32 reserved sectors
First FAT starts at byte 16384 (sector 32)
         2 FATs, 32 bit entries
  61040640 bytes per FAT (= 119220 sectors)
Root directory start at cluster 2 (arbitrary size)
Data area starts at byte 122097664 (sector 238472)
  15258273 data clusters (499983089664 bytes)
63 sectors/track, 255 heads
        63 hidden sectors
 976768002 sectors total
/saa2010
  Contains a free cluster (4716032). Assuming EOF.
Reclaiming unconnected clusters.
Unable to create unique name
Also, the result of trying to mess within the drive as sudo...
[code]
nicholas@theseus:/media/MY_EXTERNAL/Nick_files$ cp usgs.pdf usgs2.pdf
cp: cannot create regular file `usgs2.pdf': Read-only file system
nicholas@theseus:/media/MY_EXTERNAL/Nick_files$ sudo cp usgs.pdf usgs2.pdf
[sudo] password for nicholas:
cp: cannot create regular file `usgs2.pdf': Read-only file system
nicholas@theseus:/media/MY_EXTERNAL/Nick_files$ sudo su
root@theseus:/media/MY_EXTERNAL/Nick_files# cp usgs.pdf usgs2.pdf
cp: cannot create regular file `usgs2.pdf': Read-only file system
root@theseus:/media/MY_EXTERNAL/Nick_files#
[code/]

Last edited by Nizzok; 05-20-2010 at 01:39 AM. Reason: addition
 
Old 05-20-2010, 03:48 AM   #4
Nizzok
LQ Newbie
 
Registered: Dec 2009
Posts: 29

Original Poster
Rep: Reputation: 0
Also...

I just noticed, my ipod doesn't work! well, dmesg recognizes it but it doesn't get loaded or recognized by rhythmbox...
 
Old 05-21-2010, 04:23 AM   #5
tommyttt
Member
 
Registered: Oct 2009
Location: Federal Way, WA
Distribution: openSUSE 11.4 x86_64, openSuSE 12.1, Fedora 15
Posts: 207

Rep: Reputation: 34
Quote:
Originally Posted by Nizzok View Post
I just noticed, my ipod doesn't work! well, dmesg recognizes it but it doesn't get loaded or recognized by rhythmbox...
From your previous post -- NEVER EVER run dos/windows checks on a linux partition! Use a live boot CD/DVD and run fsck.ext3 (or correct extension type).

Please do not add comments within the [CODE] blocks, just makes it harder to follow the logic. That said, the fstab looks a little odd, the 1st line with the UUID appears to be missing some options although that could be Ubuntus' style.

Here is one from my openSUSE 11.3:
Code:
/dev/disk/by-id/ata-ST9500420AS_5VJ1AKS0-part11 /    ext3    acl,user_xattr   1 1
For some reason your system thinks there is an error on that partition and so is mounting it RO.
 
Old 05-21-2010, 05:39 PM   #6
Bratmon
Member
 
Registered: Jul 2009
Location: 75.126.162.205:80
Distribution: Arch / Mint 17
Posts: 297
Blog Entries: 3

Rep: Reputation: 50
Here's my Ubuntu /etc/fstab , for what it's worth:
Code:
# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/sda5 during installation
UUID=16d3e6f0-263b-4874-b3cc-fbc4b0f42dd4 /               ext3    relatime,errors=remount-ro 0       1
# swap was on /dev/sda6 during installation
# swap was by UUID, but was manually changed to traditional
/dev/sda6       none            swap    sw              0       0
/dev/scd1       /media/cdrom0   udf,iso9660 user,noauto,exec,utf8 0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto,exec,utf8 0       0
 
Old 05-22-2010, 01:18 AM   #7
Nizzok
LQ Newbie
 
Registered: Dec 2009
Posts: 29

Original Poster
Rep: Reputation: 0
Solved

Hello all,

first, above: thanks for the advice. It was a FAT32 formatted external harddive, so the dosfsck was perfectly legitimate to run, as would chkdsk, to fix the drive if attached to a windoze box(at least what my reading has suggested). fsck was what tipped me off to the true nature of the problem anyway.

Next, sorry, I'm not terribly familiar with the forum's formatting, I didn't expect it to just put the code tags in.

Finally, the issue at heart seems to be that there were bad-sectors on the external. I've backed it up, formatted, and it works like a charm! Now if the ipod would work...
 
Old 05-22-2010, 01:33 AM   #8
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Glad you found the solution and hope that you don't get more bad sectors. It's strange that there were any becuase modern hard drives detect bad sectors for themselves and stop using them (they have a pool of spare sectors to use instead).

The Thread Tools menu can be used to mark the thread SOLVED.
 
Old 05-22-2010, 01:34 AM   #9
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,557
Blog Entries: 28

Rep: Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178Reputation: 1178
Duplicate post text removed
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] fstab mount permissions for ext3 drive in Lucid Lynx someshpr Ubuntu 4 05-03-2010 11:12 AM
uSB External Hard Drive Mounts Very Slowly rahulthewall3000 Linux - Hardware 0 01-20-2008 06:37 AM
USB flash drive (Pen drive) mounts read only prabhatsoni Linux - Hardware 24 07-02-2007 02:28 PM
HFS+ Formatted Flash Drive Mounts as Read-Only applewax Linux - Hardware 4 11-03-2006 11:00 AM
Lexar USB Jump drive mounts read only qaball Linux - Hardware 7 02-06-2004 08:22 AM


All times are GMT -5. The time now is 09:12 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration