LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-02-2010, 06:26 PM   #1
someshpr
Member
 
Registered: Jul 2009
Location: CA, USA
Distribution: Debian, RHEL5.4, CentOS 5.4, 6.2, Ubuntu 11.04,12.04
Posts: 107

Rep: Reputation: 26
fstab mount permissions for ext3 drive in Lucid Lynx


Hi,
I am having some permission issues on my non-boot ext3 partition on lucid. It mounts properly, but I cannot create/delete anything on that partition without sudo. As a workaround I created a directory with in that partition with proper permission for every user. But that is not exactly what I want! I guess, there must be a way to mount with all permissions for the user.

Here is my fstab file, and the partition with problem is UUID=2846e47e-f3cf-4eaa-a64f-6c4fdd4043b0 mounted at /Partitions/Docs/ (line 12-13):
Quote:
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda1 during installation
UUID=fc703dda-3626-49ca-858f-f221379c6af5 / ext3 errors=remount-ro 0 1
# /Partitions/Docs/ was on /dev/sda3 during installation
#UUID=2846e47e-f3cf-4eaa-a64f-6c4fdd4043b0 /Partitions/Docs/ ext3 defaults 0 2
UUID=2846e47e-f3cf-4eaa-a64f-6c4fdd4043b0 /Partitions/Docs/ ext3 rw,suid,dev,exec,auto,user,async,relatime 0 2
# /Partitions/fat32/ was on /dev/sda6 during installation
UUID=B00D-9DC9 /Partitions/fat32/ vfat utf8,umask=007,gid=46 0 1
# /tmp was on /dev/sda5 during installation
UUID=72c2966e-9d1d-49b5-9f39-c19557a4f6e6 /tmp ext3 defaults 0 2
# swap was on /dev/sda2 during installation
UUID=c5c46f54-75da-4961-8277-c839f8f51314 none swap sw 0 0
Now, I tried with both
Quote:
UUID=2846e47e-f3cf-4eaa-a64f-6c4fdd4043b0 /Partitions/Docs/ ext3 defaults 0 2
and
Quote:
UUID=2846e47e-f3cf-4eaa-a64f-6c4fdd4043b0 /Partitions/Docs/ ext3 rw,suid,dev,exec,auto,user,async,relatime 0 2
but the problem persists. What am I doing wrong?

Also, for this partition and for the fat32 partition (/Partitions/fat32), I cannot move any file to trash, they get deleted completely without a trace. I guess this problem is connected with the permission issue for the ext3 partition. Is it? And is there a way to avoid this in the fat32 partition?

Any help is highly appreciated.

TIA,
 
Old 05-02-2010, 10:12 PM   #2
maury0324
Member
 
Registered: Jul 2003
Location: Florida
Distribution: Debian Squeeze amd_64
Posts: 66

Rep: Reputation: 16
Permisions

There are probably better ways as I am not great with command line but I solved the same problem on my system doing this. In a terminal type "gksudo nautilus" and enter your pass word when prompted.This will have
you running your file mgr. as root ( real root not sudo),be careful.
Stay within nautilus and you can change the permissions of your drive.
make sure you tell it to change the permissions on the directories and
sub directories also. Just be careful and you should be able to solve your problem. I xfered about 500gb of data last week after fixing the same problem. Good Luck. Maury.
 
1 members found this post helpful.
Old 05-02-2010, 11:23 PM   #3
Jeiku
Member
 
Registered: Jul 2005
Posts: 64

Rep: Reputation: 18
Hi

As for you not being able to create/write to the drive, you should check the permissions. I presume that root owns the top directory, so you will need to change those perms appropriately for your user.

Also - by default, external drives are owned by root if they are fat32/NTFS and I don't think there is anyway around this other than to elevate your privileges or sudo.

File permissions still apply to any mounted drive in Linux.

Hope this helps
 
1 members found this post helpful.
Old 05-03-2010, 09:12 AM   #4
dr_agon
Member
 
Registered: Sep 2007
Location: Poland
Distribution: Ubuntu 8.04
Posts: 76
Blog Entries: 12

Rep: Reputation: 24
Hello,

Quote:
Originally Posted by someshpr View Post
Hi,
I am having some permission issues on my non-boot ext3 partition on lucid. It mounts properly, but I cannot create/delete anything on that partition without sudo. As a workaround I created a directory with in that partition with proper permission for every user.
It seems to me, that you created by hand a similar directory structure as for "/home" directory, which probably resides on your boot partition mounted at "/", so the first question that comes to my mind is why you don't move the "/home" directory to that partition. This would have many advantages.

If you want each user to have a separate, private, directory on that partition, you did it right, because it requires these directories to have different permissions for each user, and the directory /Partitions/Docs/ remains owned by root. Exactly as in /home directory.

However, if you want to grant all users rw rights to the root directory of that partition, i.e. /Partitions/Docs/ you must after mounting it change the rights to the mount point:
Code:
sudo chmod a+w /Partitions/Docs/
then try unmounting and remounting with default options. I tried it and it retained rw permissions.

Last edited by dr_agon; 05-03-2010 at 09:15 AM. Reason: spelling in chmod line
 
1 members found this post helpful.
Old 05-03-2010, 10:12 AM   #5
someshpr
Member
 
Registered: Jul 2009
Location: CA, USA
Distribution: Debian, RHEL5.4, CentOS 5.4, 6.2, Ubuntu 11.04,12.04
Posts: 107

Original Poster
Rep: Reputation: 26
Thumbs up

Thanks Maury, Jeiku and dr_argon!
It worked as I changed the permission of the folder where the ext3 drive was being mounted as suggested by all of you.
I wanted all folders in /Partitions/Docs/ to be accessible to all, and changing permission of /Partitions/Docs/ did the trick. It retained the permission in subsequent remounts.

However, "move to trash" still doesn't work for the fat32 partition (it is not an external drive, though). I guess, as Jeiku said, there is no way around for fat32 partitions for this.

I am happy with what I have now!

Thansk again,
 
  


Reply

Tags
ext3, fstab


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: What’s New in Ubuntu 10.04 Lucid Lynx LXer Syndicated Linux News 0 04-29-2010 03:10 AM
LXer: Ubuntu 10.04 Lucid Lynx gets 14 new wallpapers LXer Syndicated Linux News 0 04-14-2010 07:41 PM
[SOLVED] Lucid Lynx Beta 1 ? taylorkh Ubuntu 2 03-18-2010 07:28 PM
LXer: Ubuntu 10.04: Waiting for the Lucid Lynx LXer Syndicated Linux News 0 03-16-2010 04:10 AM
New Lucid Lynx theme official: Adium Kenny_Strawn Ubuntu 2 03-05-2010 08:15 AM


All times are GMT -5. The time now is 07:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration