LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 04-17-2004, 07:31 PM   #1
rafc
Member
 
Registered: Apr 2004
Posts: 87

Rep: Reputation: 15
eth0 recognized but not recognized?


I tried getting to know something about setting up a network by reading the wiki tutorial found on this site. So one of the first things I tried was 'ifconfig -a' and it only showed up lo and sit0, not eth0. In yast I see however that my asustek nforce2 ethernetcard is configured (with dhcp it reads). So I also tried 'ifconfig eth0 up' but that returns a no such device answer.

Suggestions are welcome.
 
Old 04-17-2004, 07:36 PM   #2
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
Check to ensure that the module for that card is loaded to run it by running lsmod (that's a lowercase L)

If it's not, you'll have to load it.

Post the lsmod here plz
 
Old 04-17-2004, 09:02 PM   #3
rafc
Member
 
Registered: Apr 2004
Posts: 87

Original Poster
Rep: Reputation: 15
Tnx for helping out.

I also discovered that in the textual startup (I mean when pressing f2 I see what happens during startup) it says eth0 failed. yast says it is configured though.

the lsmod result:

Module Size Used by Not tainted
snd-pcm-oss 50144 1 (autoclean)
snd-mixer-oss 15704 1 (autoclean) [snd-pcm-oss]
videodev 6176 0 (autoclean)
isa-pnp 31560 0 (unused)
ipv6 144980 -1 (autoclean)
snd-intel8x0 22244 2
snd-pcm 71168 0 [snd-pcm-oss snd-intel8x0]
snd-timer 13376 0 [snd-pcm]
snd-ac97-codec 35696 0 [snd-intel8x0]
snd-mpu401-uart 3840 0 [snd-intel8x0]
snd-rawmidi 15584 0 [snd-mpu401-uart]
snd-seq-device 4512 0 [snd-rawmidi]
snd 40900 0 [snd-pcm-oss snd-mixer-oss snd-intel8x0 snd-pc m snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3748 0 [snd]
st 29716 0 (autoclean) (unused)
sr_mod 13720 0 (autoclean)
sg 27804 0 (autoclean)
mousedev 4372 0 (unused)
joydev 5792 0 (unused)
evdev 4192 0 (unused)
input 3264 0 [mousedev joydev evdev]
usb-ohci 19720 0 (unused)
ehci-hcd 17612 0 (unused)
usbcore 63116 1 [usb-ohci ehci-hcd]
raw1394 15828 0 (unused)
ohci1394 17716 0 (unused)
ieee1394 36496 0 [raw1394 ohci1394]
ide-scsi 10384 0
ide-cd 31964 0
cdrom 30304 0 [sr_mod ide-cd]
reiserfs 217364 1
ataraid 6564 0 (unused)


As far as I can understand there's nothing referring in this list to my ethernet card so I guess I should try to load it.
 
Old 04-20-2004, 09:01 AM   #4
PenguinPwrdBox
Member
 
Registered: Oct 2003
Location: /illinois/chicago
Distribution: Slackware/Gentoo/FC/RHEL
Posts: 568

Rep: Reputation: 30
What kind of card is it?
 
Old 04-20-2004, 07:25 PM   #5
rafc
Member
 
Registered: Apr 2004
Posts: 87

Original Poster
Rep: Reputation: 15
It's an integrated 3com and nvidia lan on an asus a7n8x motherboard. I've been looking on the asus site for a driver but the downloads site seems to be unavailable for now.
 
Old 04-21-2004, 01:02 AM   #6
abhijitpethkar
LQ Newbie
 
Registered: Mar 2004
Location: India
Posts: 8

Rep: Reputation: 0
what r the o/p of lspci, netconf.
then try kudzu to detect a new h/w
 
Old 04-21-2004, 03:26 AM   #7
Evilone
Member
 
Registered: Oct 2002
Location: UK
Distribution: Slack 9.1 (2.6.5)
Posts: 307

Rep: Reputation: 30
via-rhine should do you for the 3com port !!
 
Old 04-21-2004, 04:13 AM   #8
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
I have the same motherboard. You have two options. You can patch your kernel with the forcedeth patch and then recompile it.

You could also(which would probably be easier) install the drivers provided by nvidia. Download the appropriate rpm for your Suse version from here. Install the rpm package and then do as root:

modprobe nforce

You should be okay after that but you may have to restart your network to pick up an IP address.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to internet - eth0 not recognized guyfromcanada Fedora 14 10-04-2004 10:30 PM
Eth0 not being recognized in Slackware 9.1 Lucinda Linux - Networking 5 05-20-2004 11:52 PM
Eth0 Not Being Recognized Lucinda Slackware 4 05-19-2004 11:32 AM
eth0 not recognized (sometimes!) cucolin@ Linux - Networking 1 11-10-2003 05:33 PM
eth0 recognized but no hardware address rickenbacherus Linux - Hardware 5 05-12-2003 09:00 AM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration