LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
LinkBack Search this Thread
Old 12-21-2002, 06:56 PM   #1
Negativ13
LQ Newbie
 
Registered: Dec 2002
Location: TX
Distribution: Mandrake 9.0
Posts: 22

Rep: Reputation: 15
Editing LILO


Two things...

First. I want XP to be my default OS not linux in LILO. I searched the internet on how to do this. I figure I am driving you people mad by now. I found how. I did what it said. Nothing changed. Here is what I have in lilo.conf:

boot=/dev/hda
map=/boot/map
default=NT
keytable=/boot/us.klt
prompt
nowarn
timeout=100
message=/boot/message
menu-scheme=wb:bw:wb:bw
ignore-table
disk=/dev/hdd bios=0x81
image=/boot/vmlinuz
label=linux
root=/dev/hdd5
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi quiet"
vga=788
read-only
image=/boot/vmlinuz
label=linux-nonfb
root=/dev/hdd5
initrd=/boot/initrd.img
append="devfs=mount hdc=ide-scsi"
read-only
image=/boot/vmlinuz
label=failsafe
root=/dev/hdd5
initrd=/boot/initrd.img
append="devfs=nomount hdc=ide-scsi failsafe"
read-only
other=/dev/hda1
label=NT
table=/dev/hda
other=/dev/fd0
label=floppy
unsafe

When I restart my computer. It behaves as if I changed nothing and Linux still loads as default. What do I need to do to change this?

And second...

When the GUI comes up in Linux it is Gnome. I like gnome under Redhat but not mandrake. I want KDE to be the default GUI. I thought I changed this, I guess not. How do I change it?

Thank all of you for your help and I hope I haven't driven you to the mad house quite yet. Give me time. I am just learning.

In time I WILL drive you to the mad house... then again you use Linux, you are ALREADY there!
 
Old 12-21-2002, 07:16 PM   #2
Negativ13
LQ Newbie
 
Registered: Dec 2002
Location: TX
Distribution: Mandrake 9.0
Posts: 22

Original Poster
Rep: Reputation: 15
OK, I got it to work. I didn't know I had to type "lilo" at the command prompt under root after editing and saving lilo.conf. I did it and bada-bing bada-bang, it worked. Cool beans, now about my second question...
 
Old 12-21-2002, 07:17 PM   #3
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
You probably didn't re-run lilo after the changes..
As root type:
/sbin/lilo -v

This "updates" lilo in the MBR.

That's it for #1, I will give someone else a shot at #2

Cool

<edit>
OH man! Glad to see you found out on your own though, too bad it was shortly before my reply
</edit>

Last edited by MasterC; 12-21-2002 at 07:18 PM.
 
Old 12-23-2002, 03:10 PM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix, 98,2000 + various
Posts: 3,171

Rep: Reputation: 51
cat > ~/.xinitrc
startkde
<control-d>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Editing Lilo Kane2002 Linux - General 2 07-06-2004 11:29 PM
Editing LILO Nukem Linux - Newbie 7 11-25-2003 10:53 AM
No new kernel-option in LILO after editing lilo.conf corwax Debian 3 08-26-2003 08:55 PM
Editing the Lilo wings9191 Linux - Newbie 1 02-12-2002 05:22 PM
Editing Lilo tmnt_power Linux - General 7 12-02-2001 07:13 PM


All times are GMT -5. The time now is 04:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration