LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 09-06-2005, 04:00 PM   #1
krnlkule
LQ Newbie
 
Registered: Sep 2005
Location: Altoona, IA
Distribution: Fedora Core 4
Posts: 1

Rep: Reputation: 0
DualBoot Fail: System Rebuild: Error upon reinstalling FC4 in Dual boot config


This is my first attempt at installing Linux. I'm not at all familiar with navigation in a Unix type shell. With that disclaimer I did check the FAQ at the Fedora project and Searched in this forum for the error or similar experience. I then googled the error with no results. I do have the anacondump available if needed.

The following is my step by step process from original install to the first occurrence of the error.

Equipment: Compaq Presario 6415cl (original config with exception of Seagate 80Gig HDD)
Seagate HDD ST340012A Primary (Contains Compaq Windows XP Home img.)
Seagate HDD ST380013A Secondary( My Intended destination for FC4)


Having done my research and prep work prior to attempting install.
Selected FC4 because of Anaconda installer for ease of use.
Purchased 80Gig HDD for the Linux install.
Booted from the Fedora Core disk 1 iso.
Ran Disk Druid setting hdb as the location for my boot, root, and swap using recommended size requirements.
Used Grub as my boot loader. (not sure if it was placed on hda or hdb... suspect hda) Set Windows XP as Default.
FC4 installed with personal computer basic configuration.

Install was successful.

When attempting to boot to Windows XP. The system goes into recovery mode. This occurs in a continuous loop.

Removed Partions on both drives and reloaded Windows XP from Compaq Presario 6415cl img to hda. Leaving hdb free and unformatted.

This resolved the WinXP Boot issue.
Attempted to reinstall FC4
Received the following error when selecting US English KB setting

Bug: Assertion (head_size <= 63) at disk_dos.c:580 in function probe_partition_for_geom() failed.
*
Ignored error and continued with install.
Used the Automated partitioning tool in Anaconda this time around.

In the Grub Boot loader setup I Defaulted once more to WinXP. Set hdb as the location for the boot loader. FC4 failed to complete installation.

At several points during the install I received the same error.

As I have no experience in debugging a program, any help resolving this error would greatly be appreciated.

Shawn T. Nelson
 
Old 09-06-2005, 10:56 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,549

Rep: Reputation: 180Reputation: 180
"Bug: Assertion (head_size <= 63) at disk_dos.c:580 in function probe_partition_for_geom() failed."

This says that you had some sort of problem on your new hard drive. Most likely something went wrong when Disk Druid partitioned and formatted the hard drive. The best thing to do would be to create the partitions again and format them again. See if the error goes away. A much less likely possibility is that you have a bad spot on your new hard drive.

"Used Grub as my boot loader. (not sure if it was placed on hda or hdb... suspect hda)"

It was installed on the Master Boot Record of hda.

---------------------------
Steve Stites
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 dual boot error abk4523 Linux - Software 7 08-31-2005 02:26 PM
yoper install fail on dual boot win-linux system coz `linux partition not found` coolview210 Yoper 5 11-24-2004 02:04 PM
rebuild kernel 2.6 boot fail on soft RAID fs Ducko Fedora 4 10-05-2004 08:40 PM
system-config tools fail to start Elyson Fedora - Installation 2 08-29-2004 12:57 PM
gentoo -- how do i properly config grub for a dual boot system Laptop2250 Linux - Distributions 3 01-02-2004 08:19 PM


All times are GMT -5. The time now is 05:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration