LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2003, 04:11 PM   #1
CtPoem
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Rep: Reputation: 0
Exclamation Dual Boot Windows Xp and Linux


Hi,

I really need some help here as I am a real newb when it comes to Linux. Right.. well what happned was I partitioned my hard-drive with Partition Magic when I was on win XP and then let it reboot and partition the drive. It then went on to install Red Hat 9 on the new partition. I now have a partition at the beggining the SWAP partition, then Windows Xp and then Linux.
Ok.. well the problem is when I boot up the computer all it does is go to the grub boot loader and only gives me the option to run Linux. I know that my windows partition is still there and everything is still on it.. but I just cant access it... please help....
Oh btw.... Linux is on hda1 and WindowsXP is on hda2 and I think the SWAP is on hda0 partition. The names got a bit mixed around because of a bad first go at installing Linux a while before. Does this make any difference?

Please help :|
 
Old 11-19-2003, 04:41 PM   #2
leroy27336
Member
 
Registered: Nov 2003
Distribution: LTS Ubuntu 6.06
Posts: 127

Rep: Reputation: 15
you have to first figure out if you are using lilo or grub to boot, once you figure that out you perform one of the two following things. to figure out what is the partition numer xp is loaded on you will have to type:

"fdisk -l" at the command line:


Add this entry to /etc/lilo.conf, then rerun lilo.

other = /dev/hda1
table = /dev/hda
label = Windows

The other points to the partition containing Windows and table points to the partition table of the disk.

Add this entry to /boot/grub/grub.conf

title Windows
root (hd0,0)
makeactive
chainloader +1

According to the grub disk numbering, /dev/hda is hd0, hdb is hd1, etc. The partitions are numbered from zero. Therefore, hda1 is hd0,0, hdc4 is hd2,3.
 
Old 11-20-2003, 04:19 AM   #3
CtPoem
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
Ok... Well I think I am running the grub booter but where is the command line I need to type fdisk -l ... is at the booter when I start the computer and it gives me the option to run linux ??

Is that also the place I need to type the other bits too or am I supposed to typed them into a command prompt in linux itself ??

Sorry ... am a real newb at linux as I said b4...
 
Old 11-20-2003, 06:21 AM   #4
guygriffiths
Member
 
Registered: Jun 2003
Location: Reading, UK
Distribution: Debian 3.0, LFS
Posts: 524

Rep: Reputation: 37
A command line is invoked by running a program.
If you use Gnome, right-click and pick the New Terminal option (it's something like this anyway)
In KDE, click the K menu, System, Konsole, or press Alt-F2, type konsole and press enter

Then type fdisk -l and press enter
The other bits you need to add to the file /etc/grub.conf, which you should open with a text editor. You can probably use kedit or gedit (depending whether you use KDE or Gnome) which will be in the menus, or you can start them by typing "kedit" or "gedit" at the command line.
 
Old 11-20-2003, 01:08 PM   #5
CtPoem
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
rite... well I tried alll that an got on ok.. but I still cant run windows .... let me show you some of my specs...

HARD DRIVE ::

/dev/hda
--------------1 1 < Free Space
hda3-------1 64 502 linux-swap
-------------65 65 <1 Free space
hda2------65 5156 39943 ntfs
hda1------5157 9538 34373 ext2
-------------9539 9539 <1 Free Space



GRUB.CONF file ( I have edited as you told me) ::


# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/hda1
# initrd /boot/initrd-version.img
#boot=/dev/hda
default=0
timeout=10
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
title Red Hat Linux (2.4.20-8)
root (hd0,0)
kernel /boot/vmlinuz-2.4.20-8 ro root=LABEL=LINUX hdd=ide-scsi
initrd /boot/initrd-2.4.20-8.img
title Windows
root (hd0,1)
makeactive
chainloader+1




When I load up the booter it gives me the option for windows but when I chose it .. the screen just goes to boot up .. and then goes back to the grub booter...

What am I doing wrong ???

Oh btw ... when I typed fdisk -l in the terminal all I got was bash: fdisk: command not found..

Please respond as soon as ya can

Last edited by CtPoem; 11-20-2003 at 01:10 PM.
 
Old 11-20-2003, 01:59 PM   #6
leroy27336
Member
 
Registered: Nov 2003
Distribution: LTS Ubuntu 6.06
Posts: 127

Rep: Reputation: 15
what happens if you add this into the grup.conf:


title Windows XP
rootnoverify (hd0, 1)
chainloader +1

exactly like that......that should be right under

initrd /initrd-2.4.20-8.img
 
Old 11-20-2003, 02:00 PM   #7
leroy27336
Member
 
Registered: Nov 2003
Distribution: LTS Ubuntu 6.06
Posts: 127

Rep: Reputation: 15
mine doesn't have "makeactive"....that might be the thing screwing you up
 
Old 11-20-2003, 05:06 PM   #8
CtPoem
LQ Newbie
 
Registered: Nov 2003
Posts: 5

Original Poster
Rep: Reputation: 0
ok everyone.. didnt exactly work as planned.. but in the end I re formatted the partition and put a boot up option for windows in there and it works ok...

New problem though

When I chose windows... it starts booting up ok.. and goes to the blue login screen as it usually would but before it brings up login details it displays this message on the screen...

xmnt2002 NOT FOUND - SKIPPING AUOTCHECK
autochk NOT FOUND - SKIPPING AUTOCHECK

then it reboots...

Now.. I have viewed a few other forums of people that have had the same problems and it has been when they have used partition magic and it has set the windows partition to hidden...
they changed it back to visible ( ie set the status to none ) and it works fine...

How do I set it to visible ?? I dont have a boot disk so I cant do it through ms-dos .. can i do it on Red Hat ??
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Solution Dual Boot Windows & Linux [ALL DONE IN WINDOWS] No Linux terminology DSargeant Linux - Newbie 35 02-07-2006 04:29 PM
Solution Dual Boot Windows & Linux [ALL DONE IN WINDOWS] No Linux terminology DSargeant Linux - Newbie 4 11-10-2005 12:37 PM
How do I dual boot Linux and Windows XP from Windows boot file andyri Linux - Newbie 4 08-04-2004 11:09 PM
On Windows and LInux dual boot - why install Windows first? yanar99 Linux - Newbie 13 12-18-2003 10:20 AM
Win98/Linux - dual boot : windows boot says logical drives exist past z ashpai Linux - Software 3 03-22-2001 10:00 AM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration