LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-06-2004, 03:46 PM   #46
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377

Quote:
Originally posted by unixfreak
Or do I do it the same way as with the "Eth0" Problem??? Like FILE/OPEN etc...??? (Which I would assume).
yes, that's right...

Quote:
Now, after changing this, what will I have to do next? Reboot, or what?
you need to give me the exact message you get when you type:

ls -l /dev/modem

Quote:
Also, do I have to re-enable the "Bringing up eth0"??? I hope not.
this has nothing to do with that...
 
Old 08-06-2004, 08:22 PM   #47
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Ok,

I typed in this

ls -l/dev/modem

error message as follows:

ls: invalid option --/
Try 'ls --help' for more info

You need to tell me what characters are these commands made of up. On my keyboard, I used the letter (LOWERCASE) "L" then after (ls) I used the lowercase 'L' again for (-l)

I dont know whats the problem.

So how many more steps will I have to achieve to maintain a connection

And when do you want me to edit the Gedit???

Amd what do I need to do after when I edit the stuff in Gedit?? Reboot or what?

Just tell me what to do next. I HATE TO KEEP ON REBOOTING THE MACHINE ON AND ON AGAIN. Im afraid it will fry the components. Just tell me the exact steps on what to do in all in what post or page.

And BTW, do ALL external modems work with ALL Linux Distros???

Last edited by unixfreak; 08-06-2004 at 08:43 PM.
 
Old 08-06-2004, 08:52 PM   #48
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Now, do I have to type the previous commands again????

and then open GEDIT???
 
Old 08-06-2004, 10:16 PM   #49
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Am I almost done yet? I have not done anything yet. Just tell me what do to.
 
Old 08-06-2004, 11:03 PM   #50
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Quote:
Originally posted by unixfreak
Ok,

I typed in this

ls -l/dev/modem

error message as follows:

ls: invalid option --/
Try 'ls --help' for more info

You need to tell me what characters are these commands made of up. On my keyboard, I used the letter (LOWERCASE) "L" then after (ls) I used the lowercase 'L' again for (-l)

I dont know whats the problem.
the problem is that you didn't put the space between the "-l" and "/dev/modem"...

this is what you typed:

ls -l/dev/modem


this is what you are supposed to type:

ls -l /dev/modem


Quote:
And when do you want me to edit the Gedit???
you should have already done that by now...

Quote:
Just tell me the exact steps on what to do in all in what post or page.
don't start getting bossy now...

=)
 
Old 08-07-2004, 12:03 AM   #51
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
ITS NOT YOU. Im suprised you have still patience with me. Im just excited about this.

So, should I type the command again like I did before?

And when the COm List part comes up under the NIC, which COM port would I have to select?
 
Old 08-07-2004, 12:18 AM   #52
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Ok, got it.

From the SECOND command that you gave me the results were:

lr - xr -xr - x 1 root root 10 Aug 7 05:05 /dev/modem > /dev/ttyS3 (The /dev/modem and the /dev/ttyS3 werw highlighted with blinking red flashes) Please tell me if this is a good sign.

Then I changed the stuff in GEDIT

Have not tested the connections yet. When I do, which COM port do I have to select???

Last edited by unixfreak; 08-07-2004 at 12:47 AM.
 
Old 08-07-2004, 12:53 AM   #53
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
you configured the com port when you changed the 3 to a 4 in the /etc/init.d/serial file, so i'd say don't touch that part in the dial-up connection utility...

okay, your /dev/modem link is also pointing to the wrong com... so you need to change that... this is the last thing you need to do before you try to dial-up your ISP once again... just become root and type this command:

ln -sf /dev/ttyS4 /dev/modem

good luck...
 
Old 08-07-2004, 12:56 AM   #54
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Ok, now after this command you gave me, what will I have to do next?? Reboot before I try the connection??

After I hit Enter, what are the results that Im looking for here?

What will I have to look for after i hit enter??? Do I need to change some things back in GEDIT?

Please explain to me what should be done after this command. So I could report back the results next week to you.

Last edited by unixfreak; 08-07-2004 at 01:04 AM.
 
Old 08-07-2004, 01:10 AM   #55
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Just incase this does not work, will external modems work for all Linux distros???

Would the COM settings in Linux change the settings in Windows too?

Last edited by unixfreak; 08-07-2004 at 01:15 AM.
 
Old 08-07-2004, 01:15 AM   #56
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Quote:
Originally posted by unixfreak
Ok, now after this command you gave me, what will I have to do next?? Reboot before I try the connection??
you don't need to reboot...

Quote:
After I hit Enter, what are the results that Im looking for here?
after typing enter, you shouldn't get any output...

to make sure it worked simply do the "ls -l /dev/modem" again and check that the link points to /dev/ttyS4 instead of /dev/ttyS3...

Quote:
What will I have to look for after i hit enter??? Do I need to change some things back in GEDIT?
nope... you already edited the /etc/init.d/serial file, right??

Quote:
Please explain to me what should be done after this command.
after this just go into your dial-up utility again and attempt to connect to your ISP... don't change the com number, remember you already set that manually...
 
Old 08-07-2004, 01:16 AM   #57
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Quote:
Originally posted by unixfreak
Just incase this does not work, will external modems work for all Linux distros???
the 5610B works... besides, it's not like if you bought an external modem you wouldn't have to do any configuration... there's no magic bullet...

but yes, most external modems work with linux...

 
Old 08-07-2004, 01:16 AM   #58
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
Just incase this does not work, will external modems work for all Linux distros???

Would the COM settings in Linux change the settings in Windows too? I will give you a report tomorrow.

Last edited by unixfreak; 08-07-2004 at 01:19 AM.
 
Old 08-07-2004, 01:18 AM   #59
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
Quote:
Originally posted by unixfreak
Would the COM settings in Linux change the settings in Windows too?
NO.
 
Old 08-07-2004, 02:05 AM   #60
unixfreak
Member
 
Registered: Jul 2004
Distribution: Linux 2.4.21-0.13mdk, W2K
Posts: 412

Original Poster
Rep: Reputation: 30
No luck. Connection Failed.

I went into the NIC and selected:

Use Auto-detection
Standard Modem
(Then there was the COM ports 0 to 9 I think. then at the last one was listed as (dev/modem). COM0 was checked by default.) I tried every combination attempts. Who knows.

And before this, I edited the Gedit like you told me to.

Then I started filling out my Connection name user id, password, access# (BTW, is it in this format? 123-1234 or 1231234??), PAP.

Then clicked on Test Connection and failed.

I followed yuor exact instructions. And the last command detected or was pointing to ttyS4 like you said.

I did this before BTW. Or maybe I should of rebooted??

maybe i should go out and buy an external modem, what do you think?

I've noticed that on the website were I downloaded the driver, it said below that this is just a BETA version and not supported ny US Robotics.

Last edited by unixfreak; 08-07-2004 at 02:25 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
modem drivers bof Linux - Software 2 10-14-2004 01:46 PM
Modem Drivers Darkness-Inc Mandriva 2 04-25-2004 10:50 PM
Modem Drivers digitaldeity Slackware 1 08-20-2003 03:00 PM
Pc Tel hsp56 modem riser modem drivers matt_w_lambert Linux - Hardware 1 03-23-2003 05:38 PM
modem drivers satheeshk Linux - Software 1 03-07-2001 10:12 PM


All times are GMT -5. The time now is 12:08 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration