LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-13-2003, 09:53 AM   #1
leefarrant
LQ Newbie
 
Registered: Nov 2003
Location: London
Posts: 9

Rep: Reputation: 0
Don't know how to boot in a non-text mode


hi,

I was happily using my new installation with the window environment then when I rebooted it started booting in the text environment.

Does anyone know why this would be and how I can switch it back?

Also are there 2 window environments or just one?

Thanks

Lee
 
Old 11-13-2003, 09:57 AM   #2
Thimanjer
LQ Newbie
 
Registered: Nov 2003
Posts: 2

Rep: Reputation: 0
Hello,

Log with root account

vi /etc/inittab
Replace
id:3:initdefault:
with
id:5:initdefault:

Tape:
init 5

Let's go with X server

After "init 5" to go in text or X environnement.

Ctrl + Alt + F1 to F6 and Ctrl + Alt + F7 to X


Last edited by Thimanjer; 11-13-2003 at 09:58 AM.
 
Old 11-13-2003, 01:13 PM   #3
leefarrant
LQ Newbie
 
Registered: Nov 2003
Location: London
Posts: 9

Original Poster
Rep: Reputation: 0
Booting in a non-text mode.

id:5:initdefault:

the above line is already in this file?

Also I don't understand what your asking me to do here?
Sorry


Tape:
init 5

Let's go with X server

After "init 5" to go in text or X environnement.

Ctrl + Alt + F1 to F6 and Ctrl + Alt + F7 to X
 
Old 11-13-2003, 01:59 PM   #4
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
Type: 'init 5' to switch to runlevel 5 without rebooting. Otherwise just reboot. The 'id:5:initdefault:' defines the default runlevel. Since you didn't change anything, it should have a '5' (for graphical logon). The other key combos are for switching virtual consoles. 'Ctrl'+'Alt'+'F(1-6)' switches to the text consoles tty1-tty6. 'Ctrl'+'Alt'+'F7' Switches back to the first X (graphical) screen.
 
Old 11-13-2003, 02:07 PM   #5
leefarrant
LQ Newbie
 
Registered: Nov 2003
Location: London
Posts: 9

Original Poster
Rep: Reputation: 0
thanks for your reply.

The only ctr alt keys that do anything are f1 and f2 this switches between a text new logon and my existing one ?

Lee
 
Old 11-13-2003, 02:13 PM   #6
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
The number of tty's are determined by the inittab file. If there are only two, you can switch them using F1 & F2, but then F3 will be X. On my Slack there are 6, so F7 goes to X.
 
Old 11-13-2003, 04:01 PM   #7
Chu
Member
 
Registered: Nov 2003
Location: Australia
Distribution: Slackware 9.1
Posts: 166

Rep: Reputation: 30
Isn't Slack initab:4?
 
Old 11-13-2003, 05:39 PM   #8
leefarrant
LQ Newbie
 
Registered: Nov 2003
Location: London
Posts: 9

Original Poster
Rep: Reputation: 0
Hi,

I don't know what Slack it, but I am stuck with a text interface when RedHat had previously installed a windows interface , I think it was called Gnome or something like that.

If anyone has any more ideas?

Thanks

Lee
 
Old 11-14-2003, 07:55 AM   #9
aaa
LQ Guru
 
Registered: Jul 2003
Location: VA
Distribution: Slack 10.1
Posts: 2,194

Rep: Reputation: 46
There are many windowmanagers/desktop enviroments available in Linux. You have the XFree86 (or just X) program, which does the graphics stuff. You have a program that manages windows called a window manager (like fvwm or kwin). Without it you wouldn't have the bar that most windows have on them, and you wouldn't be able to move windows around. A window manager bundled with a bunch of other programs is called a desktop enviroment (like kde or gnome).
For your text-only problem, did you type 'init 5'? Also try 'startx', and post the errors if any.
In the Slackware Linux distrobution, the runlevel for graphical X logon is 4. In most others, such as Red Hat, it is 5.
 
Old 11-14-2003, 08:31 AM   #10
jdruin
Member
 
Registered: Jul 2003
Location: Louisville aka Derby City
Distribution: WinXP SP2 and SP3, W2K Server, Ubuntu
Posts: 313

Rep: Reputation: 30
Hey leefarrant,

Until you get the hang of setting up the Xwindows environment like you want, just log in to the text environment (aka your shell) like normal.

I.E. when the computer boots and the text login comes up put in:

<your user name>
<your password>

at the prompt. THen you will be logged into your shell and be at some prompt like:

>>

or

$

or whatever. Then, like aaa said, just type in the command "startx". THis will start the Xwindows system for you. When you set the initialization file called inittab to runlevel 5, you are telling Linux to start the OS into the Xwindows system. Run level 3 is just starting up into the text shell. On my RedHat box, run level 4 doesnot really do anything, so dont ask me why they skipped run level 4, but it may have meaning on other Linux flavors. The folks above are all correct in trying to get you to set the run level to 5, but this can be hard for a newbie(like me) to do at first. What Thimanjer was trying to get you to do was open up a text file that controls start up called "inittab" located in the directory called "/etc" and edit the file directly. This will change the runlevel for good, until you open the inittab file again and change it back.
 
Old 11-15-2003, 08:35 AM   #11
leefarrant
LQ Newbie
 
Registered: Nov 2003
Location: London
Posts: 9

Original Poster
Rep: Reputation: 0
I am replying from my Linux box . yipeee

Thanks everyone for your help.

The reason why the gnome GUI did not start automatically on boot was because there was network issues. It was already configured to do so.

The reason I has network issues was I was plugged into a duff card. Use another one.

Also the startx worked fine and I could flip between the two interfaces with the F keys.

I am getting there!

Thanks again from a very new newbie.


Lee
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Boot in text mode Fredstar Linux - Newbie 7 01-17-2005 03:31 AM
HELP: boot up in text-mode only? kevingpo Linux - Hardware 4 12-12-2004 08:53 AM
HOw to boot from init to go to text mode sujith_marar Linux - Newbie 2 06-25-2004 05:25 PM
How to boot without X (Text mode)??? Jefklak Red Hat 5 10-16-2003 04:10 PM
How to boot into console (text) mode? dhsieh Linux - Hardware 2 10-02-2003 08:45 PM


All times are GMT -5. The time now is 12:59 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration