LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-07-2008, 09:48 AM   #1
jazzey69
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu Studio 7.10
Posts: 9

Rep: Reputation: 0
Smile Disable ivp6 in Ubuntu 7.10 ;-)


Dear Sirs or madams,
I have Ubuntu 7.10 studio.I have a connection to my firefox web browser but nothing to the rest of the OS.I disabled ivp6 on firefox then i got a broadband connection to the internet, Great!!! but nothing else is working ;-(
I have opened a terminal as root and put in /etc/modprobe.d/aliases but i get this out, permision Denied lol ;-( Why is that ? can anybody help me out there in linux land ;-) Also i have tried this which i got from the ubuntu website,gksudo gedit/etc/modprobe.d/aliases , nothing happens ;-( not a list opens nothing, i take it i am supossed to see a list so i can change the line to read, alias net-pf-10 off ?
Best regards to all,Steve Rickards Linux newbie...
 
Old 07-07-2008, 10:21 AM   #2
Takla
Member
 
Registered: Aug 2006
Distribution: Debian
Posts: 188

Rep: Reputation: 33
Disabling IPv6 under a 2.6 kernel

Quote:
To disable IPv6 it should be as simple as adding the lines

alias net-pf-10 off
alias ipv6 off

to /etc/modprobe.d/00local (creating the file if it exists).

It is important that this comes in a file earlier in an alphanumeric sort than aliases since that contains aliases that turn this on.

Once you've made this change/addition you will need to restart the box afterwards - since the modules won't unload.
 
Old 07-08-2008, 08:57 AM   #3
jazzey69
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu Studio 7.10
Posts: 9

Original Poster
Rep: Reputation: 0
Dear Takla,
Many thanks for the info i put in the line /etc/modprobe.d/OOlocal
i got this out, bash: no such file or directory ;-(
Any other thoughts for this problem ?
Take care Steve Rickards...;-)
 
Old 07-08-2008, 09:24 AM   #4
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
I think that was 00local - not OOlocal (the number zero - not the capital letter "O")
To create the file and put the lines in it you can use vi ar any other editor.
Code:
vi /etc/modprobe.d/00local
Or you do this instead:
Code:
cat >> /etc/modprobe.d/00local << "EOF"
alias net-pf-10 off
alias ipv6 off
EOF
 
Old 07-14-2008, 09:36 AM   #5
jazzey69
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu Studio 7.10
Posts: 9

Original Poster
Rep: Reputation: 0
Smile Hello Jomen...

Dear Sir,
Many thanks for the info but i still can not disable ivp6 seems nothing is happening.Is there any other way to do this ? any help would be great !!!
Thankyou to all who have helped me.
take care, be safe, Steve Rickards...;-)
 
Old 07-14-2008, 06:20 PM   #6
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Can you describe more thoroughly what your problem is?
What you described was how you think (or where told) how to solve the problem you seem to have - but you did not describe the problem itself enough.
Based on that you got a solution - which is obviously not solving the actual problem (which is?).

Something to do with internet connection.
... to firefox (which is working, you said - so you can browse the web?) - but nothing else? What else?

What do you want to achieve?
What did you do to achieve that?

Last edited by jomen; 07-14-2008 at 06:24 PM.
 
Old 07-15-2008, 10:14 AM   #7
jazzey69
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu Studio 7.10
Posts: 9

Original Poster
Rep: Reputation: 0
Smile Hello Jomen...

Many thanks for your reply,
At the moment i only have a connection to my forefoz web browser nothing else,well that is the way it seems to me.I also have a opera web browser that does not work i just get errors no connection also i have pigin instant msg that will not connect.I will need envy legacy to install a grafix card driver as my grafix look two dimentional at the moment. repositories multivers and univers, will also be needed so i can download envy legacy.To install nvidia grafix card drivers.My upgrade manager has no upgrades ,well there should be at least one to upgrade to 8.04 but nothing,synaptic also is not working also just, errors.When i first log into Ubuntu i am also getting this,There was an error starting the gnome settings daemon, with a big no entry sign.So to me it all points to ivp6 needs to be disabled.I am told that ivp6 will never be used for a long time and the os should fall back to ivp4 ? but in my case it has not done so.So i can say that the connection to the os is fine well it must be i have a connection to firefoxbut nothing else to other fetures.
Any other info will be given gladly,
Many Thank to you,best regards Steve Rickards...;-)
 
Old 07-15-2008, 06:34 PM   #8
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
It appears that you have problems with your internet connection.
What we would need to know in order to help is at least:

What kind of internet connection do you have? (DSL/ADSL - or what?...)
Did it ever work before?
Where, when, how? (the operating system)
If (A)DSL: do you have a modem - or do you connect through a router connected to that modem?
On what hardware is this installation of Ubuntu 7.10 studio running on?
 
Old 07-17-2008, 07:42 AM   #9
jazzey69
LQ Newbie
 
Registered: May 2008
Distribution: Ubuntu Studio 7.10
Posts: 9

Original Poster
Rep: Reputation: 0
Smile Hi Jomen...

Dear Sir ,
Thanks for the reply,i will list what you want to know.
1.I have a broadband connection adsl connected from the phoneline with virginmedia.
2. I have a dlink modem router DSL-G624T.
3.My tower unit is a dual boot system one hard drive for windows xp one hard drive for Ubuntu studio 7.10 both ide drives pentium 4 1.7 ghz cpu.Mother board an AS rock P4i65G.768 ram.
4.This pc is connected to the modem with an ethernet cable.My daughter uses a laptop with a connection from the modem wireless,no problem with that .Also no problem with the windows xp from this pc,it is just the Ubuntu connection.So i have a duel boot pc with 2 hard drives one for Xp one for Ubuntu both IDE types.
5.I did a boot from DVD 4 months ago and it has never worked only now that the Firefox web browser is working thanks to Linux Format magazine ,which told people how to disable ivp6 in Firefox and it worked but nothing else does...
6.I have worked through the documentation at the Ubuntu website but have had not much success with that.
Take care, be safe always, Steve Rickards...
 
Old 07-17-2008, 08:32 AM   #10
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Yours seems to be a very odd problem - are you sure your router is corrctly configured? Can you even reach it, now that firefox is working?
I found another way to disable ipv6 support - which I have active too and which does not create any problem...

Prevent the module ipv6 from beeing loaded - by writing its name into a file in /etc/modprobe.d/

the file could be named: blacklist-ipv6
and its contents should be : blacklist ipv6

Code:
sudo cat >> /etc/modprobe.d/blacklist-ipv6 << "EOF"
blacklist ipv6
EOF
Would be very interesting to know why this works IF it works. It seems unlikely to me.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ivp6 - should this be enabled dth1 Linux - Software 1 11-03-2007 09:15 AM
Best way to disable compiz from Ubuntu cli suguru Linux - Software 1 06-06-2007 03:25 PM
i must disable IVP6 rex11 Linux - Networking 1 07-01-2006 06:32 AM
Disable ipv6 in ubuntu? ksgill Linux - Newbie 7 03-25-2006 10:05 PM
disable selinux on ubuntu linuxmandrake Ubuntu 2 01-11-2006 06:10 AM


All times are GMT -5. The time now is 06:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration