LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-08-2008, 05:42 PM   #1
the_new_z
LQ Newbie
 
Registered: Mar 2006
Location: The Netherlands
Distribution: Ubuntu 6.06 LTS Server
Posts: 22

Rep: Reputation: 15
Disable IPTABLES init script


Hello guys,

Before I used to run an iptables script I found on howtoforge, but now I switched to arno's firewall. The problem now is that on bootup arno is initiated first and then iptables, which effectively overrides arno's. So, should I remove the iptables script from /etc/init.d/? Doesn't arno's firewall need iptables? How can I make sure that the two don't interfere?

As you can see I am a beginner and very confused, so any help is welcome.
 
Old 07-09-2008, 10:20 AM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
If arno's script has it's own init script, usually you can do a chkconfig <name-of-init-script> off to disable an init script.

man chkconfig for more details.
 
Old 07-09-2008, 10:55 AM   #3
the_new_z
LQ Newbie
 
Registered: Mar 2006
Location: The Netherlands
Distribution: Ubuntu 6.06 LTS Server
Posts: 22

Original Poster
Rep: Reputation: 15
Thank you. I read about chkconfig and from what I understand, I can stop the init script I don't need. However, my concern is that I have to disable the iptables init script, which seems like a bad idea to me. Because, as far as I know, arno's script is based on iptables and probably it won't run without iptables.

So, does anybody know how to leave iptables, but tell it not to load the old iptables rules that I used before?
 
Old 07-09-2008, 11:00 AM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
iptables is a command, not a service per se. If arno's script calls iptables when it runs, it should start all the firewall rules. What distribution is this on? I know in Red Hat or CentOS, the default firewall configs can reside in /etc/sysconfig
 
Old 07-09-2008, 11:36 AM   #5
the_new_z
LQ Newbie
 
Registered: Mar 2006
Location: The Netherlands
Distribution: Ubuntu 6.06 LTS Server
Posts: 22

Original Poster
Rep: Reputation: 15
Sorry, it is Ubuntu 6.06 LTS Server. Arno's iptables firewall has an init script in /etc/init.d/ and a symlink in /etc/rcS.d/ while I see iptables in all run levels and I am thinking that I shouldn't disable iptables with chkconfig.
 
Old 07-09-2008, 12:02 PM   #6
the_new_z
LQ Newbie
 
Registered: Mar 2006
Location: The Netherlands
Distribution: Ubuntu 6.06 LTS Server
Posts: 22

Original Poster
Rep: Reputation: 15
OK, I found that iptables active and inactive counters are located in /var/lib/iptables/. I guess the init script calls the active set and I don't want it to call anything, because arno's script has already started by that time. Do you know how I can accomplish this?
 
Old 07-09-2008, 12:27 PM   #7
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,687

Rep: Reputation: 54
Both your original and the new (arnos) firewall-script use the "iptables" command to setup the filter rules for your firewall.
You should know what makes the one better than the other - after all it was you who decided to toss the prior one in favour of arnos script.
You only need one - though you really should know what one does better than the other.

AFAIK disabling a service is done by: update-rc.d -f yourfirewallscript remove
The same way you add the other script: update-rc.d arnosscript multiuser (for instance)
 
Old 07-09-2008, 12:47 PM   #8
the_new_z
LQ Newbie
 
Registered: Mar 2006
Location: The Netherlands
Distribution: Ubuntu 6.06 LTS Server
Posts: 22

Original Poster
Rep: Reputation: 15
Thank you, guys. This pretty much worked:

update-rc.d -f yourfirewallscript remove

Now, only arno's loads. As to why I am using it, because the old script I used was rather basic and I read some good reviews of arno's and decided to switch. I guess it's more secure and it also offers some extra plugins and stuff that I am about to figure out.

Well, thanks again. I am amazed by how quickly I find the answer over here. ALWAYS! I really appreciate everyone's help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
An error occured getting IPtables status from the command /etc/rc.d/init.d/iptables s CrazyMAzeY Linux - Newbie 10 08-12-2010 06:25 AM
Disable GUI boot on Init 5 rickylim Linux - Enterprise 4 05-30-2006 03:01 PM
can I disable the graphical init?? EnTe Fedora 7 04-21-2006 08:39 AM
disable "shutting down eth0" from init-script? tyrann Linux - General 3 07-13-2003 01:00 PM
init id 1 respawning too fast : disable for 5 minutes nogor Linux - General 1 06-10-2003 09:56 AM


All times are GMT -5. The time now is 04:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration