LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Enterprise Linux Forums > Linux - Enterprise
User Name
Password
Linux - Enterprise This forum is for all items relating to using Linux in the Enterprise.

Notices

Reply
 
Search this Thread
Old 05-04-2006, 11:09 PM   #1
rickylim
Member
 
Registered: Jan 2006
Location: Malaysia
Distribution: RedHat & FreeBSD
Posts: 68

Rep: Reputation: 15
Disable GUI boot on Init 5


Dear all,

I am currently running linux enterprise 4 ES. Default login is init 5.

My questions is:-
1) How can i disable the GUI boot in init 5 without having to change to init 3. And when we type #startx only it will load GUI.

Please advice

Many Thanks

rgds.
Lim
 
Old 05-05-2006, 12:38 AM   #2
raskin
Senior Member
 
Registered: Sep 2005
Location: Russia
Distribution: NixOS (http://nixos.org)
Posts: 1,893

Rep: Reputation: 68
What for?? Why not init 3? Try going /etc/rc.d/rc5.d (or similar?) and finding *xdm/*kdm/whatever boots to allow you graphical login and renaming it in order to not have S as a first letter of the symlink. You'll be left with text console after reboot, I hope.
 
Old 05-05-2006, 02:12 AM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
For what you want to do, setting the system to boot at init 3 seems a lot easier than finding some hack to stop the login manager.
 
Old 05-05-2006, 02:45 PM   #4
Harry Seldon
Member
 
Registered: Feb 2004
Distribution: SLES 9
Posts: 112

Rep: Reputation: 15
Plus, if you set it at init 3, you should still be able to execute startx and fire up the GUI at your discretion.
 
Old 05-30-2006, 02:01 PM   #5
LinuxGeek
Member
 
Registered: Jun 2002
Posts: 302

Rep: Reputation: 31
As far as I remember, the GUI is started from /etc/inittab under RHEL. Open /etc/inittab and you should find that the last 1 or 2 lines in the file are the ones that start X in runlevel 5. It's the one that has the following in it: /etc/X11/prefdm Comment out the line(s) and then your system should boot without X. But, as suggested in the previous posts, it probably best you just go to runlevel 3. Or, if you really want to, you could customize runlevel 4 to do this.

Note:
The following link gives you detailed information about the RHEL boot process: http://www.redhat.com/docs/manuals/e...n-process.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
can I disable the graphical init?? EnTe Fedora 7 04-21-2006 07:39 AM
Disable GUI Desktop on Solaris 10. Zepiroth Solaris / OpenSolaris 2 11-04-2005 08:31 AM
Disable GUI Login and Config StartX firefly2442 Linux - Newbie 6 07-21-2003 11:02 PM
init id 1 respawning too fast : disable for 5 minutes nogor Linux - General 1 06-10-2003 08:56 AM
Disable GUI in Redhat 8.0 TexasDex Linux - General 3 03-24-2003 12:12 PM


All times are GMT -5. The time now is 11:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration