LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-14-2007, 07:24 PM   #1
kreng
LQ Newbie
 
Registered: Nov 2006
Posts: 4

Rep: Reputation: 0
dead keys issue


I use dead keys a lot to create accented characters and up to now this has worked fine for me under different platforms. Unfortunately, I have run into a problem since installing Xandros 4.1. Previously, typing a dead key like the ' character followed by a consonant would simply produce what was typed. In this way, contractions like I'm, don't, won't, etc. could be created just by typing them normally.

Now, with Xandros, the only way to achieve this is to follow the dead key with a space character before continuing with the consonant. Otherwise nothing appears. I find this very unintuitive and it breaks the flow of my typing. As a result I keep making mistakes.

My question is if there is not an alternative keyboard layout for kde that I could download and install that would produce a more normal dead key behaviour. Alternatively, could anyone tell me in what files the dead key behaviour is produced? I am an absolute beginner where Linux is concerned, but I do know how to alter configuration and script files. My thinking is to find the routine or variable that produces the original dead key character when followed by the spacebar, and just copy that for all the other consonents.

The other option, having more than one layout installed and switching between them, doesn't really appeal to me. In Windows I can just type normally and I only have to follow the dead key with a space when I want to override the default accent character, and that only occurs when the dead key is followed by a vowel. The keyboard routine is smart enough to know that when the dead key is followed by most consonants in Latin languages, no accented character is possible so a contraction must be intended. That's the behaviour I would like to have with Xandros.

Any suggestions would be much appreciated.
 
Old 08-22-2007, 06:31 PM   #2
titopoquito
Senior Member
 
Registered: Jul 2004
Location: Lower Rhine region, Germany
Distribution: Slackware 14.1 (32 and 64 bit)
Posts: 1,593

Rep: Reputation: 123Reputation: 123
I'm not sure if KDE is the one that made your layout change. It is possible to activate keyboard layouts in KDE, but for example on my machine it's the X server that handles the keyboard. What does your /etc/X11/xorg.conf say which layout you're using and which language do you need? Tweaking the value might show you if X or KDE are responsible for that behaviour.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No dead keys in KDE applications colindo Linux - Software 2 02-17-2007 03:19 PM
XKB: Configuring multipurpose dead keys Monk15 Linux - Software 0 10-20-2005 05:13 PM
Dead keys or diacritic in OpenOffice - solution jlinkels Linux - Software 1 02-16-2005 11:26 AM
Dead F-Keys in X cothrige Linux - Newbie 7 05-10-2004 04:34 AM
Slackware + dead keys + openoffice ccool Slackware 8 02-18-2004 10:58 PM


All times are GMT -5. The time now is 05:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration