LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 05-04-2004, 04:39 PM   #1
cothrige
Member
 
Registered: Oct 2003
Distribution: Debian, Slackware
Posts: 48

Rep: Reputation: 15
Dead F-Keys in X


I sometimes use Orpheus to play music of mixed formats on the console, such as mp3s and ogg files. Normally I can load or save a playlist using the f2 and f3 keys, but if I happen to be running X I cannot. They get no response at all, though oddly f5 does work. I have noticed a couple of other times in some other apps that the f keys were non-responsive when I expected them to work, though I cannot recall now which ones, though it was always while using X. I have looked through the obvious XF86Config entries relating to the keyboard and I don't see anything relevant. I have googled and got nothing back which seemed to relate either. I am using an IBM "clicky" keyboard, which I assumed would be a generic 101 key US keyboard, and so designated it as such in xf86config. Am I overlooking something obvious here? I imagine it is likely, but I just can't seem to find it. I appreciate any tips which may fix this.
 
Old 05-04-2004, 06:55 PM   #2
Match
LQ Newbie
 
Registered: Oct 2003
Location: Virginia
Distribution: Debian 3.0
Posts: 19

Rep: Reputation: 0
It may depend on what window manager you're running. I use fluxbox, and can configure the F keys through fluxbox's init file. Perhaps your window manager is overriding your otherwise defined F keys.
 
Old 05-04-2004, 10:20 PM   #3
cothrige
Member
 
Registered: Oct 2003
Distribution: Debian, Slackware
Posts: 48

Original Poster
Rep: Reputation: 15
Good idea, that never occurred to me. And my window manager is heavily key based (ratpoison) and has stolen keystrokes from other programs, which would have made it a likely culprit. Unfortunately, after looking in my files, man pages, info and google searches focussed on ratpoison and f keys, I found nothing to suggest it. They don't appear, at least, to be used by ratpoison for anything at all, and there is no reference to any of them in any of the documentation at all. But, I suppose that maybe it is still affecting them in some way. I will have to search for a newsgroup or site dedicated to that WM specifically to make sure.

Thanks for the suggestion.
 
Old 05-04-2004, 11:08 PM   #4
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
I've noticed that with the default settings for both
xterm and rxvt some ncurses apps (namely MC)
have problems with F-Keys in rxvt, but not in xterm.
I don't use MC enough to bother hunting down why
it doesn't work with my otherwise preferred terminal,
so just run that one in an xterm instead.

Maybe the problem is related to your terminal application
as well?


Cheers,
Tink
 
Old 05-05-2004, 12:03 AM   #5
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
2 comments

1) if it's one of them nu fancy fandangle me-crow-soft kee-bored-s turn on that f lock key

2) much more likely:

gaim (0.68 and 0.75) have absorbed (on several occasions) my F-keys
I am guessing this is the price of running gnome software in kde.

Even stranger was that when investigating the problem it was the F2, F3 key only, F1 still worked fine.

so consider that ... the above mentioned are also plausible

Good look
 
Old 05-05-2004, 11:59 AM   #6
cothrige
Member
 
Registered: Oct 2003
Distribution: Debian, Slackware
Posts: 48

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Tinkster
I've noticed that with the default settings for both
xterm and rxvt some ncurses apps (namely MC)
have problems with F-Keys in rxvt, but not in xterm.
That did it. I use rxvt by default. I like the slightly larger font and the fact that it doesn't clear the screen after every app is finished. After running less or more I like to be able to quit and then look at the info left on the screen while I am using it. With xterm it all disappears. Any idea, btw, on how to stop that? But, in any case, you were absolutely right, and with xterm in orpheus the f2 and f3 keys worked fine. And, like you and mc, I don't use orpheus all that much and so probably won't worry too much about adjusting, if possible, rxvt. Perhaps I will find an app one day which I feel is just too necessary and may look into it. But, I am glad to know what is going on, and that it is not my settings. I guess I am a bit anal about having all my configurations working correctly.

Many thanks for the info and help. I appreciate it.
 
Old 05-05-2004, 03:00 PM   #7
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Pleasure m8 :)

Maybe some day, if/when I have HEAPS of time,
I'll look at the default key bindings in both and adjust
rxvt to behave like xterm ;)



Cheers,
Tink
 
Old 05-10-2004, 04:34 AM   #8
chakkerz
Member
 
Registered: Dec 2002
Location: Brisbane, Australia
Distribution: RedHat (RHEL, FC, CentOS), openSuSE, Mac OS X
Posts: 653

Rep: Reputation: 32
curious bug ....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xkb: How to configure Multipurpose Dead Keys? Monk15 Linux - Software 2 10-31-2005 08:31 AM
XKB: Configuring multipurpose dead keys Monk15 Linux - Software 0 10-20-2005 05:13 PM
Dead keys not working on X client-server Sibidi Linux - Software 2 03-06-2005 05:56 AM
Dead keys or diacritic in OpenOffice - solution jlinkels Linux - Software 1 02-16-2005 11:26 AM
Slackware + dead keys + openoffice ccool Slackware 8 02-18-2004 10:58 PM


All times are GMT -5. The time now is 06:26 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration