LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-01-2007, 01:44 PM   #1
digity
Member
 
Registered: Apr 2005
Posts: 105

Rep: Reputation: 15
copying files & folders with ALL CAPS


I'm having problems copying files and folders that have all capitals letters in their filenames to my Linux box. If I copy a file or folder with a name like SWAT or 2THIRTY it'll create the name as swat or 2thirty on the linux system. And if it's a folder it won't copy its files/content because the uploading/copying machine is looking for /path/to/2THIRTY when it's actually been changed to /path/to/2thirty by the linux system.

this is happening when copying stuff from my Windows box to my Linux box (Ubuntu 7.10).

Why is it lowercasing all caps files & folders and how do I get it to not do that?

TIA
 
Old 11-01-2007, 01:59 PM   #2
visaris
Member
 
Registered: Dec 2004
Distribution: gentoo
Posts: 190

Rep: Reputation: 30
This happens because windows is case insensitive and linux is case sensitive. As an example, in windows, the files "Foo", "FOO", and "foo" are all the same. It doesn't care about the caps on the names. In linux, "Foo", "FOO", and "foo" are totally different files, because the caps matters.

I suppose linux must default every windows file to lower case to keep all the names clean and consistent, but I can see how this might be annoying at times... not sure of an easy way to fix it, though..
 
Old 11-01-2007, 06:02 PM   #3
digity
Member
 
Registered: Apr 2005
Posts: 105

Original Poster
Rep: Reputation: 15
well how do I at least get Linux to allow ALL CAPS in a file/folder name?

what I'm basically doing is duplicating my iTunes music folder from my Windows computer to my home server (which is the Linux box) using Retrospect and the script keeps failing because of the capitalization problem. Maybe there's a work around?
 
Old 11-01-2007, 06:43 PM   #4
The_JinJ
Member
 
Registered: Apr 2004
Location: Scotland
Distribution: Suse, OpenWRT
Posts: 299

Rep: Reputation: 30
Have a look at the 'r' option for mount - may be what your looking for (not tested myself) - it allows upper and lower case

EDIT
Or 'posix' for NTFS
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Copying files from multiple folders into one aardwolf64 Linux - General 4 01-02-2006 11:53 PM
folders not being named in caps Tyir Linux - General 2 03-09-2004 10:38 AM
Kdevelop IDE & copying files carlosmg Programming 0 12-15-2003 05:30 PM
files&folders permissions under SAMBA share shani Linux - Software 2 11-20-2003 11:48 AM
Inporting files & folders ? fin Linux - Newbie 4 03-28-2003 10:00 PM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration