LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-13-2006, 10:36 PM   #1
doowttam
LQ Newbie
 
Registered: Mar 2006
Distribution: Ubuntu 6.06
Posts: 20

Rep: Reputation: 0
conflicting dependencies?


I'm trying to install a newer version of glibc, and I thought I had downloaded all of the required dependencies. But, when trying to install the rpms, I get this:

Code:
$ rpm -ivh glibc-common-2.4-4.i386.rpm
warning: glibc-common-2.4-4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        glibc < 2.4 conflicts with glibc-common-2.4-4.i386
$ rpm -ivh glibc-2.4-4.i386.rpm
warning: glibc-2.4-4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        glibc-common = 2.4-4 is needed by glibc-2.4-4.i386
        gdb < 6.3.0.0-1.111 conflicts with glibc-2.4-4.i386
        glibc > 2.3.5 conflicts with glibc-common-2.3.5-10.i386
The first complains about me having a glibc version below 2.4, but the second says I need the first to have a glibc version of 2.4. I'm using FC4. What am I doing wrong?

Oh, and as I side note, please don't give the advice to install with yum or anything like that because I currently have no internet connection with the fedora box. This glibc stuff is all part of trying to get my wireless card working with fedora, so I'm using a flash drive to shuttle files between it and another computer.
 
Old 03-14-2006, 12:19 AM   #2
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
You can always try
Code:
rpm -Uvh <package1.rpm> <package2.rpm>
All on 1 line. This will upgrade rather than install "over the top".

See if that clears up some of the dependancy errors.

HTH
Baldrick
 
Old 03-14-2006, 01:19 AM   #3
doowttam
LQ Newbie
 
Registered: Mar 2006
Distribution: Ubuntu 6.06
Posts: 20

Original Poster
Rep: Reputation: 0
Well, now I'm getting different errors:

Code:
$ rpm - Uvh glibc-2.4-4.i386.rpm glibc-common-2.4-4.i386.rpm
warning: glibc-2.4-4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        gdb < 6.3.0.0-1.111 conflicts with glibc-2.4-4.i386
        glibc = 2.3.5-10 is needed by (installed) glibc-headers-2.3.5-10.i386
        glibc = 2.3.5-10 is needed by (installed) glibc-devel-2.3.5-10.i386
I get that I need to upgrade gdb, but I don't understand what the second two errors mean.
 
Old 03-14-2006, 01:46 AM   #4
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
It means you need to upgrade glibc-devel and glibc-headers as well as upgrading gdb.

Baldrick
 
Old 03-15-2006, 08:03 PM   #5
doowttam
LQ Newbie
 
Registered: Mar 2006
Distribution: Ubuntu 6.06
Posts: 20

Original Poster
Rep: Reputation: 0
I have a version of gdb that meets the dependencies (as seen below), but its still complaining. Do I need a version of gdb that is > 6.3.0.0-1.111 but < 6.4? Because I haven't been able to find that.

Code:
$ rpm -Uvh glibc-2.4-4.i386.rpm glibc-common-2.4-4.i386.rpm glibc-devel-2.4-4.i386.rpm glibc-headers-2.4-4.i386.rpm
warning: glibc-2.4-4.i386.rpm: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
error: Failed dependencies:
        gdb < 6.3.0.0-1.111 conflicts with glibc-2.4-4.i386
$ gdb -v
GNU gdb 6.4
Copyright 2005 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu".
 
Old 03-19-2006, 03:52 AM   #6
Baldrick65
Member
 
Registered: Aug 2003
Location: Dunedin NZ
Distribution: Mint 13 Cinnamon
Posts: 653

Rep: Reputation: 31
You can always force it using the --nodeps option, but that could cause more problems.

Baldrick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
firefox and conflicting plugins?? ptawe Debian 1 08-29-2005 09:33 AM
conflicting files mab_123 Linux - Software 2 01-30-2005 03:43 AM
Conflicting packages apokryphos Linux - Software 3 10-02-2004 04:20 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 08:58 PM
ppp and eth0 conflicting? MikeeX Slackware 3 03-07-2003 07:36 PM


All times are GMT -5. The time now is 01:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration