LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 11-19-2013, 04:54 AM   #1
rockhopper_penguin
Member
 
Registered: Oct 2013
Location: Amsterdam
Distribution: Debian
Posts: 46

Rep: Reputation: Disabled
compiling --> make: no target specified, no makefile


Hi,

I'm not entirely sure why bash is giving me an error when I run 'make' over here.
  • I run Debian latest stable 64 bit.
    Gitcloned: bfgminer
    Installed dependencies
    ran ./autogen.sh
    ran ./configure
    did 'make'

To confuse me even more the directory contains two makefiles. Makefile.am & Makefile.in

Any pointers would be greatly appreciated.
 
Old 11-19-2013, 05:51 AM   #2
NM04
Member
 
Registered: Jan 2011
Distribution: Back Track,Fedora,centos
Posts: 239

Rep: Reputation: 14
after "./configure" do " make install " and then " make "
 
Old 11-19-2013, 06:05 AM   #3
rockhopper_penguin
Member
 
Registered: Oct 2013
Location: Amsterdam
Distribution: Debian
Posts: 46

Original Poster
Rep: Reputation: Disabled
Gives me this:
Quote:
make install

make: *** No rule to make target `install'. Stop.
 
Old 11-19-2013, 04:12 PM   #4
rtmistler
Moderator
 
Registered: Mar 2011
Location: Sutton, MA. USA
Distribution: MINT Debian, Angstrom, SUSE, Ubuntu
Posts: 4,110
Blog Entries: 10

Rep: Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525Reputation: 1525
Quote:
Originally Posted by NM04 View Post
after "./configure" do " make install " and then " make "
I believe that should have been in reverse:

after "./configure" the normal steps are to run "make" and then "sudo make install".

However you should view their README or INSTALL file for recommendations on what build and install actions you should be following.

Please post the error you receive from your make. You're saying that you get an error after running make, people need to see that error before they can offer some recommendations as to what is wrong. That is likely the fastest way to resolve your problem.
 
Old 11-19-2013, 07:16 PM   #5
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 16,829

Rep: Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409Reputation: 2409
i am guessing that your "configure" line did not have any options and failed to compleat

there MUST 100% MUST be a file created by "configure" called " Makefile"

if there is no Makefile make can NOT run

also

some Makefile's REQUIRE !!!! an option!!!

like
Code:
make olinux 
or
make dlinux
or
make mlinux 
--- or if mingw build -- same code--
make win32 
or
make mingw 


or even a normal options
make test 
make all
make clean
 
1 members found this post helpful.
Old 11-20-2013, 02:38 AM   #6
NM04
Member
 
Registered: Jan 2011
Distribution: Back Track,Fedora,centos
Posts: 239

Rep: Reputation: 14
Quote:
Originally Posted by rtmistler View Post
I believe that should have been in reverse:

after "./configure" the normal steps are to run "make" and then "sudo make install".
rtmistler,
thank you for correcting me, it should be "make" after "./configure".

rockhopper,
could you please post the error you received after running make. Also I hope you followed the below procedure to install bfgminer.

1: Open Terminal or SSH into your Linux machine.

2: Run "apt-get update"

3: Run "apt-get install git autoconf automake libtool pkg-config libcurl4-gnutls-dev libjansson-dev uthash-dev libncurses5-dev"

4: Run "git clone git://github.com/luke-jr/bfgminer.git"

5: Enter the bfgminer directory

6: Run "./autogen.sh"

7: Run "./configure" (if you do not want to use GPUs on the machine, add --disable-opencl)

8: Run "make"

9: After make completes, you can run bfgminer directly (may require sudo), or create a shell script that includes your arguments.

Running BFGMiner:
./bfgminer -o stratum+tcp://stratum.btcguild.com:3333 -u username_workername -p 123 -S all --icarus-options 115200:1:1 --icarus-timing 3.0=100
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
MAKEFILE ERROR:' make: *** No rule to make target `MacroCompletudeExe', needed by all ssica Linux - Newbie 5 04-23-2012 11:56 AM
Error in Makefile:No rule to make target `g++',needed by... stop karthik.c Programming 5 03-09-2009 01:55 AM
Problem in Makefile-" No rule to make target " asprakash Linux - Kernel 4 08-07-2008 09:39 AM
Belkin Wirless G RTL8185L make[1]: *** No rule to make target `Makefile'. Stop. SilverRock Linux - Wireless Networking 2 02-11-2007 08:25 AM
No rule to make target `/mkspecs/default/qmake.conf', needed by `Makefile'. Stop Julianus Linux - General 0 12-21-2003 08:17 AM


All times are GMT -5. The time now is 05:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration