LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 08-08-2005, 10:10 AM   #1
gamor
Member
 
Registered: Jul 2004
Posts: 77

Rep: Reputation: 15
changing locale


HI all,
When I got my laptop, linux was already installed. It was all installed in French. My problem is that I was to change locale or just add to them. I need to have eng_us

When I run some commands i get:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "en_US:en",
LC_ALL = (unset),
LC_PAPER = "fr_BE",
LC_ADDRESS = "fr_BE",
LC_MONETARY = "fr_BE",
LC_SOURCED = "1",
LC_NUMERIC = "fr_BE",
LC_TELEPHONE = "fr_BE",
LC_MESSAGES = "en_US",
LC_COLLATE = "en_US",
LC_IDENTIFICATION = "fr_BE",
LC_MEASUREMENT = "fr_BE",
LC_CTYPE = "en_US",
LC_TIME = "en_US",
LC_NAME = "fr_BE",
LANG = "en_US"
are supported and installed on your system.

I checked for the locale installed and I have:
C
CP1251
ISO-8859-1
ISO-8859-10
ISO-8859-13
ISO-8859-14
ISO-8859-15
ISO-8859-2
ISO-8859-3
ISO-8859-4
ISO-8859-5
ISO-8859-7
ISO-8859-9
KOI8-R
KOI8-U
POSIX
UTF-8
fr
fr_BE
fr_BE.ISO-8859-1
fr_BE.ISO-8859-15
fr_BE.UTF-8
fr_CA
fr_CA.ISO-8859-1
fr_CA.ISO-8859-15
fr_CA.UTF-8
fr_CH
fr_CH.ISO-8859-1
fr_CH.ISO-8859-15
fr_CH.UTF-8
fr_FR
fr_FR.ISO-8859-1
fr_FR.ISO-8859-15
fr_FR.UTF-8
fr_LU
fr_LU.ISO-8859-1
fr_LU.ISO-8859-15
fr_LU.UTF-8
franšais
french


Also, Whenever I open a console I get:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


Just so you know, I have mandrake 10.1 installed kde3.2.
I dont know how to change locale or add to it. It should be possible. If so, would you let me know how.

Thanks,
Ghita
 
Old 08-08-2005, 06:01 PM   #2
gamor
Member
 
Registered: Jul 2004
Posts: 77

Original Poster
Rep: Reputation: 15
Anyone know how to fix the locale problem. Any hints ?
Your help would be appreciated
 
Old 08-08-2005, 09:12 PM   #3
mohit dhawan
Member
 
Registered: Mar 2005
Posts: 92

Rep: Reputation: 15
jus try this(prototype for setlocale sys call)

include<locale.h>
char setlocale(int category,const char* locale);

category will be whtever u wanted; say LC_ALL
locale is either C , POSIX ,en_US


hope i understood wht u wanted

bye
 
Old 08-09-2005, 05:05 AM   #4
gamor
Member
 
Registered: Jul 2004
Posts: 77

Original Poster
Rep: Reputation: 15
Sorry but where am I supposed to do this? Where is the setlocale supposed to be?
Just to make sure what you are telling me to do is what I need. In a simpler way, I need en_US , en_US.UTF8 to be included in locale. When I do locale -a, the encodings that show are all for French.
thanks again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 10 03-24-2013 09:35 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 04:34 AM
Changing locale setting. kponenation Slackware 3 02-17-2005 05:17 PM
Locale changing Belegdol Mandriva 2 11-11-2004 05:54 AM
Changing default locale/GNOME language elluva Linux - Software 5 01-13-2004 03:20 PM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration