LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-26-2001, 03:58 AM   #16
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47

Did you run as root depmod -ae ? Does it indicate anywhere in dmesg that it recognized your cdrom drive and where it's connected?
 
Old 12-26-2001, 04:58 AM   #17
Cheese
LQ Newbie
 
Registered: Dec 2001
Location: In a van, you can guess the rest
Distribution: redhat 7.2
Posts: 29

Rep: Reputation: 15
Yep

I tried the depmod -ae, it returns nothing, so I'm not sure what it actually did. It looks like my cdrom is recognized in dmesg. I just recompiled my kernel, but still no dice. here's a bit of my dmesg:

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: chipset revision 16
VP_IDE: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdcMA, hddio
hda: WDC WD400BB-00AUA1, ATA DISK drive
hdb: WDC WD400BB-00CLB0, ATA DISK drive
hdc: Hewlett-Packard CD-Writer Plus 9100b, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63
hdb: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63
ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx
VP_IDE: IDE controller on PCI bus 00 dev 39
VP_IDE: chipset revision 16
VP_IDE: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xd000-0xd007, BIOS settings: hdaMA, hdbMA
ide1: BM-DMA at 0xd008-0xd00f, BIOS settings: hdcMA, hddio
hda: WDC WD400BB-00AUA1, ATA DISK drive
hdb: WDC WD400BB-00CLB0, ATA DISK drive
hdc: Hewlett-Packard CD-Writer Plus 9100b, ATAPI CD/DVD-ROM drive
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
hda: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63
hdb: 78165360 sectors (40021 MB) w/2048KiB Cache, CHS=4865/255/63

Here's my new fstab:

LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/hdb6 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda1 /mnt/ntfs auto defaults 0 0
/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0

[edit] one more unrelated question; I notice at the top of the dmesg, there is the "ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx". where do i override the 33mhz setting? would this possibly be a reason my hdparm -Tt scores are so shitty?

Last edited by Cheese; 12-26-2001 at 05:01 AM.
 
Old 12-26-2001, 05:02 AM   #18
whepin
Member
 
Registered: Dec 2001
Location: thunder bay, on, Canada
Distribution: Windows vista & Ubuntu
Posts: 113

Rep: Reputation: 15
sorry,maybe ur cdrom driver is bad

I encountered the same problem as u.
 
Old 12-26-2001, 05:04 AM   #19
Cheese
LQ Newbie
 
Registered: Dec 2001
Location: In a van, you can guess the rest
Distribution: redhat 7.2
Posts: 29

Rep: Reputation: 15
So......

Did you fix it? How?
 
Old 12-26-2001, 08:29 PM   #20
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Did the cdrom drive work with the original kernel? I've never compiled a kernel before. Maybe you left something out.

As for ' idebus= ', it just tells the linux ide driver what the bus speed is. It can't change it. I found that explanation here .

Last edited by linuxcool; 12-26-2001 at 08:31 PM.
 
Old 12-27-2001, 01:04 AM   #21
Cheese
LQ Newbie
 
Registered: Dec 2001
Location: In a van, you can guess the rest
Distribution: redhat 7.2
Posts: 29

Rep: Reputation: 15
I doubt it

Considering it says this: "override with idebus=xx", I'd be willing to bet you can override it. I didn't follow you r link past the first page, maybe I will tomorrow, I"m ripped now.

To answer your question, I'm not sure if the cd ever worked. I never wanted to use it till now. It's always worked off the boot, so I've been under the assumption it worked till i tried to use it for the first time.

Btw, what's a good cd buring program to use? I'll mostly be burning divx .avi's to cd to watch at work. Some music cd's mostly data cd's is what I plan to burn. I've got Fireburner, but it appears it's only shareware. Buying softare defeats my whole intention of migrating to linux.
 
Old 01-29-2002, 08:53 PM   #22
grokman
LQ Newbie
 
Registered: Jan 2002
Distribution: redhat
Posts: 1

Rep: Reputation: 0
Unhappy same persistant problem

I too have tried the depmod -ae suggestion, along with the modprobe cdrom. I'm not sure what else I can do. It seems this is a problem with ATAPI cdrom burners (as seem on the redhat bugzilla messages), but I'm not sure if someone has discovered a solution. If anyone has gotten their ATAPI cdrom to work under Redhat 7.2 please reply and help us out. Thanks in advance.

Shane
 
Old 01-30-2002, 01:44 AM   #23
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Maybe this thread will help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cdrom Problems Soulful93 Slackware 4 05-12-2005 09:53 AM
Second CDROM problems Maverick1182 Linux - Newbie 8 08-30-2004 07:57 AM
cdrom problems... punked Linux - Hardware 1 08-15-2004 07:28 AM
CD problems: /mnt/cdrom and /dev/cdrom okok Linux - Newbie 5 04-09-2003 10:11 AM
CDROM Problems neovox Linux - General 12 03-04-2001 07:29 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:05 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration