LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-29-2001, 01:38 PM   #1
kizaroth
LQ Newbie
 
Registered: Oct 2001
Distribution: Slackware 8.0
Posts: 15

Rep: Reputation: 0
cdrom problems...


Hi guys!

I've managed to get redhat 7.2. The point is, when I want to mount the cdrom using "mount /dev/cdrom /mnt/cdrom", the console shows me this error: "mount: /dev/cdrom is not a valid block device".
Now; I checked my /etc/fstab file and the place that's meant to have the cdrom configuration reads this: "/dev/cdrom /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0". Shall I change this so it reads /dev/hdc /mnt/cdrom iso9660 noauto,owner,kudzu,ro 0 0" (which is my cdrom drive).

Eager to know the answer...

"The omelet"
 
Old 10-29-2001, 01:52 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
yes, change it, assuming you can mount the thign winth

mount /dev/hdc /mnt/cdrom

it'll be fine, 'cdrom' devices are 90% of the tiem simply symlinks to the ide hdX device anyway.

you do know tho, that if the cdevice is configured ok, you need only specify one of /dev or /mnt on a mount command, as fstab is used to fill in the gaps

Last edited by acid_kewpie; 10-29-2001 at 01:56 PM.
 
Old 10-29-2001, 02:36 PM   #3
kizaroth
LQ Newbie
 
Registered: Oct 2001
Distribution: Slackware 8.0
Posts: 15

Original Poster
Rep: Reputation: 0
Thanks, but the problem is still one. When I boot my computer I can read something like this: "hdc (model of my cdrom drive)"; Just finished to configure /etc/fstab with the entry hdc as cdrom drive, but I get no response and I get the same error "hdc is not a valid block device".


Don't know what to do...
 
Old 10-29-2001, 02:41 PM   #4
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
try changing 'iso9660' to 'auto'
 
Old 10-29-2001, 02:59 PM   #5
kizaroth
LQ Newbie
 
Registered: Oct 2001
Distribution: Slackware 8.0
Posts: 15

Original Poster
Rep: Reputation: 0
No, even that doesn't work. IMHO it's a problem with the device. how can I configure that?
 
Old 10-29-2001, 03:17 PM   #6
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
try a '1' after the hdc in your fstab,
 
Old 10-30-2001, 07:59 PM   #7
kizaroth
LQ Newbie
 
Registered: Oct 2001
Distribution: Slackware 8.0
Posts: 15

Original Poster
Rep: Reputation: 0
problem solved.
(Installed RH 7.1)

Now I'd want to know somthing: how can I change this graphical login thing?
 
Old 12-19-2001, 02:17 AM   #8
thadr
LQ Newbie
 
Registered: Dec 2001
Posts: 2

Rep: Reputation: 0
For future reference try running "modprobe cdrom". You should be able to mount your cdrom drive after this command. Of course, you have to do this everytime you reboot so it is not the ideal solution. Seems like a RH7.2 bug.
 
Old 12-19-2001, 01:17 PM   #9
Shadow_Walker
LQ Newbie
 
Registered: Dec 2001
Location: Portland, OR
Distribution: Redhat 6.2(Cartman) Redhat 7.1(Seawolf) Redhat 7.2(Enigma)
Posts: 5

Rep: Reputation: 0
Exclamation modprobe works

I was having the same issues with Redhat 7.2, I have tried tweaking fstab a couple of times, setting the file system to auto, and changing the link to /dev/hdc. Anyways.. point is after running modprobe I was able to mount my cdrom.

Just FYI that the solution worked.

Thanks

Shadow Walker
 
Old 12-20-2001, 03:48 AM   #10
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
As root, run depmod -ae and see if that fixes the problem. It's supposed to be a known bug in RH 7.2.
 
Old 12-21-2001, 05:49 PM   #11
thadr
LQ Newbie
 
Registered: Dec 2001
Posts: 2

Rep: Reputation: 0
Thanks!! The "depmod -ae" fixes the problem for good on RH7.2. No need to run the "modprobe cdrom" command after each reboot.
 
Old 12-21-2001, 10:39 PM   #12
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
You're welcome, thadr.
 
Old 12-25-2001, 07:33 PM   #13
Cheese
LQ Newbie
 
Registered: Dec 2001
Location: In a van, you can guess the rest
Distribution: redhat 7.2
Posts: 29

Rep: Reputation: 15
still no dice for me

I've tried all the suggestions above....still no dice. I can't mount my CD-ROM.

[root@jihad-75h6sw75s etc]# more fstab
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/hdb6 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/cdrom /mnt/cdrom auto auto noauto,owner,kudzu,ro 0 0
/dev/hda1 /mnt/ntfs auto defaults 0 0
/dev/hdc /mnt/cdrom auto iso9660,noauto,owner,kudzuro 0 0


There's my /etc/fstab.

[root@jihad-75h6sw75s etc]# mount /dev/hdc /mnt/cdrom
mount: /dev/hdc is not a valid block device
[root@jihad-75h6sw75s etc]# mount /dev/cdrom /mnt/cdrom
mount: /dev/cdrom is not a valid block device
[root@jihad-75h6sw75s etc]#


Amy ideas? I'm stumped.
 
Old 12-25-2001, 09:59 PM   #14
linuxcool
LQ Addict
 
Registered: Jun 2001
Posts: 1,183

Rep: Reputation: 47
Cheese, the following two lines of your fstab file are incorrect:

/dev/cdrom /mnt/cdrom auto auto noauto,owner,kudzu,ro 0 0
/dev/hdc /mnt/cdrom auto iso9660,noauto,owner,kudzuro 0 0


They should look like this:

/dev/cdrom /mnt/cdrom auto noauto,owner,kudzu,ro 0 0
/dev/hdc /mnt/cdrom auto noauto,owner,kudzu,ro 0 0


You should need only one of those lines if you have only one cdrom drive. If your cdrom drive is connected as secondary master, then use the second line. The first line has ' /dev/cdrom ' in it. That is usually a symbolic link to a device. It's probably pointing to /dev/hdc. You can get rid of it if the second line allows you to mount your cdrom drive.

Try this first: mount -t iso9660 /dev/hdc /mnt/cdrom . If this works, then the second line is the one to use.
 
Old 12-26-2001, 02:17 AM   #15
Cheese
LQ Newbie
 
Registered: Dec 2001
Location: In a van, you can guess the rest
Distribution: redhat 7.2
Posts: 29

Rep: Reputation: 15
driving me nuts

[root@jihad-75h6sw75s etc]# more fstab
LABEL=/ / ext3 defaults 1 1
none /dev/pts devpts gid=5,mode=620 0 0
LABEL=/home /home ext3 defaults 1 2
none /proc proc defaults 0 0
none /dev/shm tmpfs defaults 0 0
LABEL=/tmp /tmp ext3 defaults 1 2
LABEL=/usr /usr ext3 defaults 1 2
LABEL=/var /var ext3 defaults 1 2
/dev/hdb6 swap swap defaults 0 0
/dev/fd0 /mnt/floppy auto noauto,owner,kudzu 0 0
/dev/hda1 /mnt/ntfs auto defaults 0 0
/dev/hdc /mnt/cdrom auto noauto,owner,kudzu,ro 0 0

still get :
[root@jihad-75h6sw75s etc]# mount -t iso9660 /dev/hdc /mnt/cdrom
mount: /dev/hdc is not a valid block device
[root@jihad-75h6sw75s etc]#

[edit] I just noticed I've got a string of these in 'dmesg' :

hdc: driver not present

That surely doesn't sound too good.


Last edited by Cheese; 12-26-2001 at 02:21 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Cdrom Problems Soulful93 Slackware 4 05-12-2005 09:53 AM
Second CDROM problems Maverick1182 Linux - Newbie 8 08-30-2004 07:57 AM
cdrom problems... punked Linux - Hardware 1 08-15-2004 07:28 AM
CD problems: /mnt/cdrom and /dev/cdrom okok Linux - Newbie 5 04-09-2003 10:11 AM
CDROM Problems neovox Linux - General 12 03-04-2001 07:29 PM


All times are GMT -5. The time now is 03:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration