LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 04-10-2012, 08:59 AM   #1
fnguy4545
LQ Newbie
 
Registered: Jan 2012
Posts: 26

Rep: Reputation: Disabled
Can't start xwindows


When I run # startx I receive an error and I don't really know much about x to help me figure how to get it to run.

I installed xwindows with "yum groupinstall "xwindows system" "GNOME Desktop Environment"

Now if I run # startx I receive (EE) Failed to load module "vmwgfx" (module does not exist, 0)

(EE) open /dev/fb0: No such device.
 
Old 04-10-2012, 09:15 AM   #2
jimtony
Member
 
Registered: Jan 2011
Location: Shanghai,China
Distribution: fedora
Posts: 73
Blog Entries: 1

Rep: Reputation: 2
What distribution are you use?
It should have desktop environment default.
 
Old 04-10-2012, 09:23 AM   #3
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,651
Blog Entries: 2

Rep: Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095Reputation: 4095
Have you the VMware tools installed? Seems to me that you are running that OS in a VMware VM and it misses the graphics drivers.
 
Old 04-10-2012, 09:34 AM   #4
fnguy4545
LQ Newbie
 
Registered: Jan 2012
Posts: 26

Original Poster
Rep: Reputation: Disabled
This is RHEL 5. It didn't have the desktop environment so we installed it to allow us to use a couple tools. Yes, the vmware tools are installed (I believe) and in this case we were installing X to use the VM tools configurator.
 
Old 04-10-2012, 07:50 PM   #5
jimtony
Member
 
Registered: Jan 2011
Location: Shanghai,China
Distribution: fedora
Posts: 73
Blog Entries: 1

Rep: Reputation: 2
Check your dmesg and X.org.0.log files.There should be some information in this files.

Last edited by jimtony; 04-10-2012 at 08:01 PM.
 
  


Reply

Tags
xwindows


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why can't i start xwindows? casd Debian 4 03-07-2006 12:56 PM
Can't start Xwindows Luke771 Debian 3 01-23-2006 10:48 AM
can't start xwindows ust Linux - Software 6 10-27-2003 08:16 PM
Can't start xwindows juno Linux - General 6 11-17-2002 01:34 PM
start xwindows lakshman Linux - General 3 10-15-2002 11:41 AM


All times are GMT -5. The time now is 03:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration