LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 04-15-2004, 11:25 AM   #1
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Rep: Reputation: 15
Can't see samba on the network...


For some reason I can't see my linux computer on the network at school. I can connect to it however, by typing it's name in the address, or using SSH and all those fun things, but when I do type in the address, it says I am not authorized to log in from that station.

Why would it do that?
Heres a bit of information...
security = user
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no


And here is the share definition for it..
[iso]
comment = iso
browseable = yes
path = /home/enigx/iso/cd
guest ok = yes
public = yes
read only = yes
writable = no
 
Old 04-15-2004, 02:11 PM   #2
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,090

Rep: Reputation: 41
post up the rest of the smb.conf file.
 
Old 04-15-2004, 04:18 PM   #3
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
I will tommarow at school, Most of it is just commented out though. I thought those lines were the only ones that would have any relevance :/
 
Old 04-16-2004, 07:49 AM   #4
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
#======================= Global Settings =====================================
[global]
workgroup = BUSINESS
server string = Linux
netbios name = Linux-Tech
guest account = iso
load printers = no
username map = /etc/samba/smbusers
log file = /var/log/samba.%m
max log size = 50
security = user
ssl CA certDir = /etc/ssl/certs
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no

#============================ Share Definitions ==============================
[iso]
comment = iso
browseable = yes
path = /home/enigx/iso/cd
guest ok = yes
public = yes
read only = yes
writable = no
 
Old 04-16-2004, 10:56 AM   #5
RockmanExe
Member
 
Registered: Aug 2003
Distribution: Mandriva, Slackware
Posts: 265

Rep: Reputation: 30
Try changin

security = user

to

security = share

hope this helps
 
Old 04-16-2004, 01:28 PM   #6
trey85stang
Senior Member
 
Registered: Sep 2003
Posts: 1,090

Rep: Reputation: 41
Have you setup any users?
 
Old 04-26-2004, 07:34 AM   #7
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
Changing it to Share does work, but then I can't log into linux, only open files that I set to everyone able to read. If I try to log into a shared accout, the password doesn't work. I use:
smbpasswd -a [user]
Then enter my passwords, and then reboot the server and try to login with that username and password and it doesn't work.

I have tried to make a user, I could try again though, but why won't it show on the network?

Last edited by EnigmaX; 04-26-2004 at 07:41 AM.
 
Old 04-26-2004, 09:46 AM   #8
doug.thorne
LQ Newbie
 
Registered: Nov 2003
Posts: 3

Rep: Reputation: 0
I hope I can help Jeff.

I've been banging my head for weeks trying to figure out a similar issue. And you're going to bang your head too when you figure out how simple it is.

The default firewall you installed when you installed linux is preventing SMB access. On Red Hat you can remove the firewall by going to System Settings --> Security Level and disabling it. This probably not the most secure way of setting things up but it started me off.

Good Luck.
 
Old 04-26-2004, 12:41 PM   #9
EnigmaX
Member
 
Registered: Jul 2003
Distribution: Fedora Core 4
Posts: 107

Original Poster
Rep: Reputation: 15
It's not a firewall that is causing the problem, because if I change the security level then it works fine for accounts using guest access

Last edited by EnigmaX; 04-26-2004 at 12:45 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
samba..? network..? how..? captain skywave Linux - Networking 5 12-12-2004 02:37 PM
Samba share - network name no longer available when browsing samba from win2k dorango Linux - Software 0 03-02-2004 01:02 PM
Samba in Mixed Network Arch3r Linux - Networking 0 07-26-2003 05:55 AM
network cd-r with samba alaios Linux - Networking 6 06-17-2003 01:45 PM
Samba and Network Neighbourhood 2 TriniMan Linux - Networking 30 08-26-2002 10:24 PM


All times are GMT -5. The time now is 10:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration