LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 07-31-2008, 12:18 AM   #1
jmite
Member
 
Registered: Jun 2008
Distribution: Ubuntu
Posts: 266

Rep: Reputation: 36
Can't read Thai fonts


Right now, I'm running Debian Etch with KDE. I'm trying to use KWordQuiz to make Thai alphabet flashcards. I have downloaded several different font sets, including ttf-thai-tlwg, but all these fonts still appear in western letters.

Is there a certain way I need to install the fonts to make them appear as thai? Does anyone know why this might be happening? I might just be installing them incorrectly. Ideas?

Thanks!
 
Old 08-01-2008, 06:20 AM   #2
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
สวัสดีครับ jmite

I just tried it on Ubuntu (Which is a debain based distro) and it is all working fine. You have installed Thai on your machine right?
 
Old 08-01-2008, 11:34 AM   #3
jmite
Member
 
Registered: Jun 2008
Distribution: Ubuntu
Posts: 266

Original Poster
Rep: Reputation: 36
What do you mean by "installed Thai"? I've installed thai fonts, and libthai0. This is probably exactly what I'm looking for. Is there a specific thai language module I need to install?

Thanks!
 
Old 08-01-2008, 11:44 AM   #4
jax8
Member
 
Registered: Feb 2004
Location: Australia
Distribution: Ubuntu, Fedora 10
Posts: 632

Rep: Reputation: 31
Well...I run KDE so this will probably be different in Gnome or other window managers.

KMenu --> System Settings
Select "Regional and Language"
Click "Install new Langauge" and find Thai, then click install
This will allow you to convert your system to recognise Thai as the system language.

Now select "Keyboard Layout"
Find "Thai" and add it to the Active layouts section.

Press OK to everything and close all windows.

Now you will have a button on your taskbar where you can select US or THAILAND. If you select the Thai flag you will be able to type in Thai.

If you want to do this via the command line, I have no idea. I imagine that this process will be very similar for Gnome.

-Good luck: jack

Last edited by jax8; 08-01-2008 at 11:45 AM. Reason: spelling error
 
Old 08-01-2008, 07:41 PM   #5
jmite
Member
 
Registered: Jun 2008
Distribution: Ubuntu
Posts: 266

Original Poster
Rep: Reputation: 36
I did just that (Thai must have already been installed, all I had to do was add they keymap) and it now works fine. Thanks so much!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
New install of KDE... fonts are wrong and can't read them. FireRaven Linux - Newbie 1 01-17-2008 06:34 PM
install Thai fonts - thanks LQ and Barry Kauler pppaaarrrkkk Linux - Newbie 0 09-24-2007 06:37 PM
Problem setting Thai Fonts in OOo 1.1.1 on RH9 gmichel Linux - Newbie 18 11-15-2004 08:37 AM
Thai fonts problem in GTK 2 - slack 9.1 static_drc Slackware 5 01-05-2004 10:46 PM
Tip for OO/SO - if you have crappy fonts, read on akohlsmith Linux - Software 0 10-24-2002 12:52 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie

All times are GMT -5. The time now is 09:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration