LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Slackware
User Name
Password
Slackware This Forum is for the discussion of Slackware Linux.

Notices

Reply
 
Search this Thread
Old 10-23-2003, 02:27 PM   #1
static_drc
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian GNU/Linux
Posts: 23

Rep: Reputation: 15
Thai fonts problem in GTK 2 - slack 9.1


In my full install of Slackware 9.1, Thai characters appear as hex boxes in all of my GTK 2 applications, more specifically, Gaim. (0.71)

All other characters tested (Japanese, Chinese, Korean...) display perfectly.

The only modifications I did to the full default 9.1 setup concerning fonts is adding my own personal font directory and compiling and reinstalling freetype-2.1.5 with the INTERPRETER on.

Symptoms:
- In 9.0, Thai fonts displayed beautifully by default.
- In 9.0, I triend compiling and installing the latest Pango and GTK 2 libraries, but Thai language broke. (those hex boxes) So I tried installing only GTK 2 (by using the Pango with 9.0 instead of the latest) and Thai fonts worked.
- In 9.1, when I run Mozilla with xft support built in, Thai displays perfectly. When I run mozilla without xft support, Thai DOES display, but there are empty "boxes" where spaces should be.
- In 9.1, my GTK 2 applications (Gaim, gqview, gftp) will not display Thai, neither from Slackware nor compiled by me. They all used to in 9.0.
- I can run KDE in Thai mode. The whole system is in perfect Thai characters! So what's up with GTK not being able to find the same fonts?? Grrr...

...Is anyone else having trouble displaying Thai fonts in GTK 2 in 9.1? Or is any other language giving anyone else those hex boxes?

Please ask you need more info. I'm out of ideas on what is wrong! :'(

Thank you very much!

Dave
 
Old 10-23-2003, 05:02 PM   #2
minio
Member
 
Registered: Sep 2003
Location: Czech Republic - Prague
Distribution: Slackware 9.1
Posts: 61

Rep: Reputation: 15
Do you have directory with thai fonts in your FontPath? (look in /etc/X11/X86Config)
 
Old 10-23-2003, 05:56 PM   #3
static_drc
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian GNU/Linux
Posts: 23

Original Poster
Rep: Reputation: 15
Yes, I have all the default font paths, along with my own person /usr/local/share/fonts path. So, not only did I install some Thai fonts in my own directory, but I should also be using the default Slackware Thai fonts. (the same that KDE uses, I guess)

The thing that boggles me is, I upgraded (a full reinstall) from 9.0 to 9.1 two days ago, and Thai fonts do not work by default like they did in 9.0. Are Thai fonts for GTK 2 really broken in 9.1, or did I mess something up so quickly just after a brand new install??
 
Old 10-23-2003, 09:01 PM   #4
static_drc
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian GNU/Linux
Posts: 23

Original Poster
Rep: Reputation: 15
It would be really helpful if someone could please see if they have the same problem... My favortie way to test is:

1) Start a GTK 2 app, I use Gaim 0.71, and open an IM window.
2) Go to http://news.mweb.co.th/ (for Thai text!)
3) Highlight some Thai text and paste it into the Gaim window.
4) Does it work?

Thank you so much!
 
Old 10-23-2003, 11:01 PM   #5
Rodrin
Member
 
Registered: May 2003
Location: Upstate NY, U.S.
Distribution: Slackware
Posts: 247

Rep: Reputation: 31
I don't generally have much need for Thai fonts, but I thought I'd check to see if this would be a problem on my 9.1 machine also. It is. I tried pasting text into gedit and got the hex boxes as you did. I also tried pasting into AbiWord and got little circles instead of Thai characters. They pasted perfectly into Kword. It doesn't seem like a problem with fontconfig because the characters display fine in Mozilla, which uses fontconfig. This one seems kind of odd.
 
Old 01-05-2004, 10:46 PM   #6
static_drc
LQ Newbie
 
Registered: Oct 2003
Distribution: Debian GNU/Linux
Posts: 23

Original Poster
Rep: Reputation: 15
SOLUTION

I've been using Slackware since 8.0. I did a full install of Slackware 9.1 onto a clean harddisk on my Fujitsu P2110 laptop.

The problem was Thai language would not show up in GTK2 applications. Thai characters would appear as ugly hex boxes. All other languages show fine, including Japanese, Arabic, and Chinese characters. I have some Thai fonts on my computer, and Thai was working in 9.0.

After a lot of poking around, I found the problem lies in the Pango library. So, to make a yucky story short, pango-1.2.1 (9.0) displays Thai correctly and pango-1.2.5 (9.1) does not.

An easy solution is to install the 9.0 pango package into a 9.1 install. A better solution is to compile your own pango-1.2.1, because 9.1 has some extra font features that 9.0 didn't.

Sorry, it's kind of a yucky solution, but it works. Here's hoping for Slackware 10!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fonts ok in GTK but not GTK2? bram2000 Linux - Software 3 04-19-2005 09:35 AM
Problem setting Thai Fonts in OOo 1.1.1 on RH9 gmichel Linux - Newbie 18 11-15-2004 08:37 AM
Problem with THAI character nandipinto Programming 0 08-24-2004 02:41 AM
Problem with Gnome fonts (DPI) after installining GTK+2 satellitejune Linux - Software 1 12-26-2003 08:41 PM
slack fonts problem in printing (bad kerning) codec Slackware 3 12-07-2003 06:57 PM


All times are GMT -5. The time now is 01:44 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration