LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-10-2004, 05:38 PM   #1
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Rep: Reputation: 15
Can't mount except as su.


I'd like to be able to mount and umount as a user. However, I just get an error message:
Code:
~$ mount /dev/dvd
mount: must be superuser to use mount
~$ mount /mnt/dvd
mount: must be superuser to use mount
~$
The permissions are set right, I believe....
Code:
~$ ll /bin/mount /dev/dvd /dev/hdd
-rwxr-xr-x  1 root bin    68804 2004-05-27 17:26 /bin/mount*
lrwxrwxrwx  1 root root       3 2004-09-10 03:22 /dev/dvd -> hdd
brw-rw----  1 root cdrom 22, 64 2004-09-10 03:22 /dev/hdd
~$ groups
users root bin sys adm floppy cdrom slocate www mount music
~$
Here is my /etc/fstab:
Code:
~$ cat /etc/fstab
/dev/hdb1        /                ext2        defaults        1   1
/dev/hda1        /boot            ext2        defaults        1   2
/dev/hda3        /ntfs-c          ntfs        ro,umask=0222   1   0
/dev/cdrom0      /mnt/cdrom0      iso9660     noauto,ro,user  0   0
/dev/cdrom1      /mnt/cdrom1      iso9660     noauto,ro,user  0   0
/dev/dvd         /mnt/dvd         iso9660     noauto,ro,user  0   0
/dev/fd0         /mnt/floppy      auto        user,noauto     0   0
/dev/sda1        /mnt/usbdisk     vfat     user,noauto,umask=0002    0   0
/dev/muvo        /mnt/muvo        vfat     user,noauto,umask=0002    0   0
//MATRIX/SharedDocs  /mnt/smb/matrix  smbfs       user,noauto     0   0
//LIB/SharedDocs     /mnt/smb/lib     smbfs       user,noauto     0   0
devpts           /dev/pts         devpts      gid=5,mode=620  0   0
proc             /proc            proc        defaults        0   0
~$
 
Old 09-10-2004, 06:09 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Try moving the noauto option to the end, also make sure /dev/dvd does actually point to the right device ( i.e /dev/hdc ).

The file type should probably be auto for DVD's since they can take iso9660 and UDF.
 
Old 09-10-2004, 08:14 PM   #3
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
Tried your suggestions... no change. Thanks for the tip about DVD fs types, though.

Note that this is not just a problem with /dev/dvd... the same thing happens for anything I'm supposed to be able to mount as user..... /dev/muvo, /dev/floppy, &c&c.

Nobody seems to have any clue what is wrong here! What the hell!?! *Slams on keyboard*
 
Old 09-10-2004, 08:31 PM   #4
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
Well... I solved the problem by chgrp mount /bin/mount /bin/umount, mount being a dedicated group for those I want to be able to mount, and chmod +s the same files.

This works, but is not a very clean solution and doesn't really explain what I am doing wrong. The "user" in my fstab should be enough!! Anyone know why this happens?

Thanks

--S

Afherthought: It actually seems like this would be a BETTER solution than getting the user option to work, since then I can control WHO can mount, but there are other ways of doing this.... chown o-x mount for instance.
 
Old 09-10-2004, 09:05 PM   #5
J.W.
LQ Veteran
 
Registered: Mar 2003
Location: Boise, ID
Distribution: Mint
Posts: 6,642

Rep: Reputation: 83
Have you tried using "users" instead of "user"? That will open it up to all users -- J.W.
 
Old 09-10-2004, 09:06 PM   #6
egag
Senior Member
 
Registered: Jul 2004
Location: Netherlands
Distribution: Slackware
Posts: 2,721

Rep: Reputation: 52
Thanx for that... ( helped me too... ) ,but if you want to be able to use all commands from /bin, add yourself to the goup " bin " in /etc/group.

( maybe you gotto reboot after doing that...? )

egag
 
Old 09-10-2004, 11:57 PM   #7
Sinope
Member
 
Registered: Aug 2004
Location: Chicago
Distribution: Debian testing/unstable
Posts: 82

Original Poster
Rep: Reputation: 15
I have already tried both of your suggestions.

BTW, JW, the way I understand it, "users" does not mean any user can mount, it means any user can UNmount, regardless of who mounted to begin with. If you use "user", then only the mounter can unmount.

Still looking for answers....

--S
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to give not-root user ability to mount devices to any mount point??? jdupre Linux - General 8 02-04-2012 11:03 AM
NFS mount of smb mount of windows share: permission denied problem :( Bagatur Linux - Networking 4 07-07-2009 12:34 PM
mount: unknown filesystem type 'ntfs' when trying to mount windows drive... DiZASTiX Linux - Hardware 12 09-28-2008 08:29 PM
can mount C not D FAT: invalid media value (0x45) mount: wrong fs type, bad option Emmanuel_uk Linux - Newbie 10 11-29-2005 03:47 AM
automount: mount(generic): failed to mount (null) (type iso9660) on /mnt/media/ vasudevadas Slackware 5 10-17-2005 04:05 PM


All times are GMT -5. The time now is 06:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration