LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 09-26-2004, 05:02 AM   #1
Gnixon
LQ Newbie
 
Registered: Aug 2004
Location: The Netherlands
Distribution: SuSE 9.1
Posts: 16

Rep: Reputation: 0
Question can't get amsn and tcl/tk to intsall


Heey,

I'm kinda new to linux and have just installed SuSE 9.1 and everyting is running fine.
I want to install amsn but this is where the problems started.
I've tried just about every method I can find to get amsn running on my linux but none work. first of all the amsn installer.bin doesn't work. when I open it (dubble-click on it) it does absolutly nothing. Than I tried the RPM installer for suse 9.1 (amsn-0.93-0.gbv.1.src.rpm).
When I opend this a windows asking if I wanted to install amsn and tcl/tk but than when i click install with YaST it opens a window, stays open very short and than just closes the windows. No error messege or anything.
Ok so I thought i'll just try installing the amsn-0_93.tar.gz file and the tcl interpreter seperate.source.gz.tar
This also did not work. I got the amsn installed right (I think, I just extracted it somewhere into my home partition) but there is no executable with a msn icon in there. ok so everywhere else on forums it says this means i have to install tcl/tk. well I downloaded the tcl8.4.7-src.tar file. went into terminal and tried just about every command it listed on forums to try and get it installed correctly including: cd /home/[user]/tcl8.4.7/unix and than ./configure but that comes up with this:
loading cache ./config.cache
checking whether to use symlinks for manpages... no
checking compression for manpages.. no
checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH

well ofcourse wish doesn't work yet so that failed..sym didn't work either and neither did make or make install ...

ok so what exactly should I do to get amsn running? there must be an easier way to do this? what am i doing wrong? could someone please tell me the simplest way of installing amsn and exactly which steps to follow?
Cheers,
Graham
 
Old 09-26-2004, 05:07 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
install gcc and all related development libraries.

or

use a real rpm. you had a source (src) one there, which is of no use to you, as it's effectively only doing what installing from source would, like you tried to.
 
Old 09-26-2004, 09:27 AM   #3
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
ive never managed to get aMSN working properly, i find it is unstable and crashes frequesntly....
i normally dont recomend alternate software to people, but seeing as you are "newish" maybe you dont realise about the alternatives...

if you are a KDE user, make sure you have installed the "Kde Network" package, then run "kopete" from the "start menu thing" -> Netowork / Internet menu. this is an instant messenger that works with MSN YAHOO ICQ JABBER and many others..

if you are a GNOME users, have a look at gaim... http://gaim.sf.net it recently reached version 1.0 and is the best messenger that will work without KDE installed... (In my honest Opinion, others may dissagree)
 
Old 09-26-2004, 09:49 AM   #4
Gnixon
LQ Newbie
 
Registered: Aug 2004
Location: The Netherlands
Distribution: SuSE 9.1
Posts: 16

Original Poster
Rep: Reputation: 0
yeah allready figured that out =p thanks, I find that Kopete runs much more stable on my system and you don't need any extra junk for it+ you can use ICQ and Yahoo with it too, so i'll just stick with that

thanks guys,
Cheers
 
Old 09-26-2004, 02:46 PM   #5
Komakino
Senior Member
 
Registered: Feb 2004
Location: Somerset, England
Distribution: Slackware 10.2, Slackware 10.0, Ubuntu 9.10
Posts: 1,938

Rep: Reputation: 55
Quote:
Originally posted by qwijibow
ive never managed to get aMSN working properly, i find it is unstable and crashes frequesntly....
i normally dont recomend alternate software to people, but seeing as you are "newish" maybe you dont realise about the alternatives...

if you are a KDE user, make sure you have installed the "Kde Network" package, then run "kopete" from the "start menu thing" -> Netowork / Internet menu. this is an instant messenger that works with MSN YAHOO ICQ JABBER and many others..

if you are a GNOME users, have a look at gaim... http://gaim.sf.net it recently reached version 1.0 and is the best messenger that will work without KDE installed... (In my honest Opinion, others may dissagree)
I've had no such problems. Ever. aMSN is great...perhaps you're doing something wrong.

Anyway, for whoever's thread this was....does anything happen when you type "wish" at the command line? And as for the amsn_installer.bin file, you most likely need to make it executable first by typing:
Code:
chmod +x amsn_installer.bin
 
Old 09-26-2004, 03:10 PM   #6
tutwabee
Member
 
Registered: Jan 2004
Location: California
Distribution: Ubuntu 10.04
Posts: 145

Rep: Reputation: 15
I used SuSE 9.1 a week ago and I had a similar compiling problem with many programs. SuSE seems to have cpp partially installed but not gcc somehow. You may want to check these threads:
http://www.linuxquestions.org/questi...hreadid=232859
http://www.linuxquestions.org/questi...hreadid=223630
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
TCL/TK installation for amsn salmanucit Linux - Software 1 09-23-2004 12:45 PM
AMSN Interface Isn't Working after install of Tcl/Tk on RH9 kingofcamel Linux - Software 0 06-28-2004 09:48 PM
amsn says tcl/tk not correctly installed? please help! phiqtion Linux - Newbie 2 05-29-2004 01:08 AM
How To Install TCL? (For amsn messenger) Nukem Linux - Software 1 12-05-2003 10:21 PM
still trying to install this tcl/tk /amsn / emess jasonmcneil0 Linux - Software 69 10-19-2003 10:08 PM


All times are GMT -5. The time now is 01:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration