LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices

Reply
 
Search this Thread
Old 02-13-2005, 01:49 AM   #1
benco420
LQ Newbie
 
Registered: Feb 2005
Posts: 2

Rep: Reputation: 0
Blank Screen after Suse Boot - HowTo boot from grub to command line


New to Linux installations, choose SuSe 9.2 and YaST install went fine, except Radeon 9800 was not on the driver list. Defaulted to a ATI 320 something.

First boot I got KDE to load and display except the screen was offset. So I went to control center and attempted to change the display resolution and got an unsupported screen mode error on my flatscreen and havent been able to see the screen since. When I reboot it comes back to blank screen (no monitor errors)

Google'd and found a CTRL + ALT + [NUMPAD + or -] to cycle screen resolutions and I can see my MultiLink Adapter changing resolutions through unsupported modes and can cycle through, but it always comes back to the blank screen again.

Formatted and reinstalled with same setup now didnt even get that first time screen, just back to the blank screen.

Welcome to Linux. So I figure first thing I need to do is install the SuSe Radeon 9800 drivers (8.8.25) - if anyone can fill me into why I can download these drivers from SuSe http, but not the YaST updater let me know.

I downloaded the fglrx-XXXX.rpm via SuSe http on my XP partition, but now cant get them to where Linux rpm can recognize them. I can only get to a command line through the install DVD via the Recovery Method, and it will not let me mount my CD drive which I burnt the drivers to so I figured it wouldnt let me mount a NTFS drive as well.

Question is: How do I boot from GRUB to a regular command line?

I have the grub GUI loading fine when I turn the PC on and it gives me the SuSe, Windows, Floppy, SuSe (FailSafe - which also gives blank screen) menu. I notice when I highlight (FailSafe) it shows a Boot Options command line fillin underneath with the arguments to load FailSafe, is there an argument I can enter there to just boot into a command line that will let me mount the cdrom?

Ive searched google.com/linux and read linuxquestions.com all night, and I know I've got some work ahead to get the 9800 working, but Im crippiled right now.

Thanx,
_ben

Last edited by benco420; 02-13-2005 at 02:08 AM.
 
Old 02-13-2005, 02:39 AM   #2
KimVette
Senior Member
 
Registered: Dec 2004
Location: Lee, NH
Distribution: OpenSUSE, CentOS, RHEL
Posts: 1,794

Rep: Reputation: 46
If you know the location for key components, etc. you can boot to a given device/partition/etc from a grub command line.

When you are at the grub boot menu, type 'c' to get to the boot prompt.

Next, you enter a line similar to (borrowing from my current configuration):

Code:
kernel (hd1,0)/boot/vmlinuz root=/dev/hdb1 vga=0x31a splash=silent resume=/dev/hdb2 showopts
Once you change the hd and partition parameters to match your configuration in the above line, hit enter.

Now you need to enter one more line:

Code:
initrd (hd1,0)/boot/initrd
Question though: is there any reason you couldn't just boot to single user mode? Try entering either "init 3" or "linux 3" at the bootprompt and it "should" boot to runlevel 3, which will enable you to reconfigure the box (assuming you don't have xdm / rcxdm starting in runlevel 3), and if that fails, you could try single user mode, which is init1, and disable xdm / rcxdm by editing the init.d scripts (change id:5:initdefault: to id:5:initdefault in /etc/inittab )
 
Old 02-13-2005, 03:49 AM   #3
postmaik
Member
 
Registered: May 2004
Location: @ Lake Constance, Germany
Distribution: FC3, Kernel 2.6.10
Posts: 46

Rep: Reputation: 15
Post hope this helps

Hi,

first of all you can have just a command line if you start the system (although you can't see anything then) and wait till the system is set up (go smoking and after you come back it should be there). Then you press the keys CTRL + ALT + Fx where x can be from 2 to 6. F1 is the startup console and F7 is the X running. SuSE starts the X console automatically after boot process, but you can switch to another console all the time linux is running.

So now first try this and then go on with installing the fglrx driver. First search the internet that you can find the HOWTO for installing the driver. Therefor you have to install the driver, patch it, install the kernel module, configure it.

Hope that helped you a little.
 
Old 02-13-2005, 05:50 AM   #4
benco420
LQ Newbie
 
Registered: Feb 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks guys

I think postmaik response is what I was looking for, the system is running in the background, I just cant see anything, hopefully switching to another console will change the screen res back to something I can see.

I also try the 'c' at grub boot prompt and manually load kernel from there.

If neither of those do the trick, I'll just bring my box to work and connect to a different moniter.

Thanks again
_ben
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Doesn't boot. Comes up with GRUB command line. jjbuchan Linux - Newbie 4 10-24-2005 01:00 PM
Newby: Can't boot up Redhat - getting command line screen instead livecontent Red Hat 6 09-01-2005 12:02 AM
after booting screen goes blank and will not boot in failsafe mode suse 9.1 personal hairy5050 Linux - Software 2 02-19-2005 10:36 PM
Uninstalled... how do I use grub (command line) to boot winXP? once here Linux - Software 3 02-28-2004 07:49 AM
SuSE 9 only boot to command line OgNogg Linux - Laptop and Netbook 0 12-10-2003 10:44 PM


All times are GMT -5. The time now is 10:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration