Visit the LQ Articles and Editorials section
Go Back > Forums > Linux Forums > Linux - Newbie
User Name
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!


  Search this Thread
Old 02-23-2007, 05:47 PM   #1
Registered: May 2005
Location: PA
Distribution: Ubuntu
Posts: 204

Rep: Reputation: 30
backslash in vi


I cannot delete in vi using the backslash key --
is there some kind of setting that i need to change somewhere?

Old 02-23-2007, 05:57 PM   #2
Senior Member
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , RHEL
Posts: 1,948
Blog Entries: 1

Rep: Reputation: 190Reputation: 190
Are you sure that you are in "insert" mode? Make sure that you're in insert mode. Open up the vi file, type:

vi <filename>

Here <filename> is the name of your file. Once the file is open, press i and you'll be in "insert" mode
Old 02-23-2007, 05:59 PM   #3
Registered: May 2005
Location: PA
Distribution: Ubuntu
Posts: 204

Original Poster
Rep: Reputation: 30

i am in the insert mode, but i noticed that i cant even use backslash in emacs..could that be a problem with the settings on the server where i m running bash? i am remotely logged in via ssh on this server.

Old 02-24-2007, 12:20 AM   #4
Registered: Sep 2004
Location: So Cal
Distribution: Slackware 12
Posts: 60

Rep: Reputation: 16
I think it may have something to do with your vi settings. try putting this into vim

set backspace-indent,eol,start
If you want this to be permanently set in vim, add it to your .vimrc in your home directory.

Also, there might be a default .vimrc file on your hard disk.
Old 02-24-2007, 12:35 AM   #5
Registered: Jan 2006
Location: Israel
Distribution: Windows Xp, Slackware
Posts: 316
Blog Entries: 3

Rep: Reputation: 30
I think that should help you using it:
Old 02-24-2007, 06:27 AM   #6
Registered: Nov 2006
Posts: 51

Rep: Reputation: 15

Im using vi via SSH too and it works fine?
Are you absolutely 100% sure that you are in insert mode?
Press "i" and then try.
If it isnt working you could try using vim?
It would be interesting to see if that works.
Anyway Good Luck!


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I cd into a directory with a leading backslash? closet geek Linux - General 28 07-20-2006 04:56 PM
Help Deleting a Backslash! Am i an idiot? farmerjoe Programming 3 03-21-2005 11:03 AM
backslash input in script esasse Linux - Newbie 6 02-17-2005 06:55 AM
Trailing Backslash problem duerra Linux - Newbie 6 01-28-2004 12:58 PM
Backslash in URL Cynthia Blue Linux - Newbie 17 08-18-2003 07:36 AM

All times are GMT -5. The time now is 11:55 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration