LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices



Reply
 
Search this Thread
Old 07-14-2005, 10:53 AM   #1
Waerner
Member
 
Registered: May 2005
Location: Írebro, Sweden
Distribution: Ubuntu 6.06
Posts: 92

Rep: Reputation: 15
ATI Drivers in Ubuntu - refuses to install?


Hi, I asked some things about this for a time ago, and more problems have appeard.


root@AMD64:/home/linus/Program/ATI # dir

ati-driver-installer-8.14.13.run fglrx64_6_8_0-8.14.13-1.x86_64.rpm
check.sh fglrx64-6-8-0_8.14.13-2_amd64.deb

root@AMD64:/home/linus/Program/ATI # sudo ./ati-driver-installer-8.14.13.run
sudo: ./ati-driver-installer-8.14.13.run: command not found

root@AMD64:/home/linus/Program/ATI # ./ati-driver-installer-8.14.13.run
bash: ./ati-driver-installer-8.14.13.run: Access Denied


So then I tried the .DEB-file instead:


root@AMD64:/home/linus/Program/ATI # dpkg -i fglrx64-6-8-0_8.14.13-2_amd64.deb

(Reading database ... 86884 files and folders installed.)
Decompressing fglrx64-6-8-0 (from fglrx64-6-8-0_8.14.13-2_amd64.deb) ...
dpkg: Error by the handling of fglrx64-6-8-0_8.14.13-2_amd64.deb (--install):
trying to overwrite "/usr/X11R6/lib/libGL.so.1.2" which is also included in xlibmesa-gl
dpkg-deb: Sub proceess paste killed by signal (Broken pipe)

Error appeard under handle of:
fglrx64-6-8-0_8.14.13-2_amd64.deb


I've translated everything as good as I can - but I guess it doesn't says exactly the same on an Eng-version. And it's definitly not that many grammar faults, but lets stick to the problem

And if I try to remove xlibmesa-gl it says that it need to remove the alsamixergui, x-window-core (or something like that) etc, totally 40 packages need to be removed.

What to do?

Last edited by Waerner; 07-14-2005 at 08:21 PM.
 
Old 07-14-2005, 12:34 PM   #2
pats
Member
 
Registered: Jul 2005
Distribution: Debian Sarge/Etch, (K)Ubuntu, FC6, AIX5.3, VMWare ESXServer
Posts: 159

Rep: Reputation: 30
you have taken X windows down first right?

init 3
then
[ctrl][alt][F1]
log in as root
do what you have to do then
init 5
then log back into kde or whatever

you may have tried this already but i thought i'd mention it cos i made a similar mistake
 
Old 07-14-2005, 04:47 PM   #3
Waerner
Member
 
Registered: May 2005
Location: Írebro, Sweden
Distribution: Ubuntu 6.06
Posts: 92

Original Poster
Rep: Reputation: 15
Code:

root@AMD64:/home/linus # init 3

(CTRL+ALT+F1)

Login: root
Password:

root@AMD64:/home/linus/Program/ATI # dpkg -i fglrx64-6-8-0_8.14.13-2_amd64.deb

(Reading database ... 86884 files and folders installed.)
Decompressing fglrx64-6-8-0 (from fglrx64-6-8-0_8.14.13-2_amd64.deb) ...
dpkg: Error by the handling of fglrx64-6-8-0_8.14.13-2_amd64.deb (--install):
trying to overwrite "/usr/X11R6/lib/libGL.so.1.2" which is also included in xlibmesa-gl
dpkg-deb: Sub process paste killed by signal (Broken pipe)

root@AMD64:/home/linus/Program/ATI # init 5
Same error as before :-/

Last edited by Waerner; 07-14-2005 at 05:14 PM.
 
Old 07-15-2005, 07:57 AM   #4
pats
Member
 
Registered: Jul 2005
Distribution: Debian Sarge/Etch, (K)Ubuntu, FC6, AIX5.3, VMWare ESXServer
Posts: 159

Rep: Reputation: 30
sorry that wasn't any help.
thats all i can think of. it seems like from the error output that the package is corrupted maybe. i don't know though because i haven't had much experience with debian based distros
good luck
 
Old 07-15-2005, 08:25 AM   #5
hfawzy
Member
 
Registered: Aug 2002
Location: Egypt
Distribution: Debian Sarge, Slackware 10.0
Posts: 163

Rep: Reputation: 30
First, backup /usr/X11R6/lib/libGL.so.1.2 and then try this :
Code:
dpkg -i --force-overwrite fglrx64-6-8-0_8.14.13-2_amd64.deb
This will replace libGL.so.12 with the new one provided by the package you just installed.
 
Old 07-15-2005, 09:22 AM   #6
Waerner
Member
 
Registered: May 2005
Location: Írebro, Sweden
Distribution: Ubuntu 6.06
Posts: 92

Original Poster
Rep: Reputation: 15
Thanks alot mate, the problem is now solved

I'm learning new things every day - but I'm still a Linux-n00b

Once again, thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install ATI drivers ne more!!! shorty_boy Debian 1 05-23-2005 04:22 PM
trying to install ati drivers machineunreal Linux - Newbie 4 04-03-2005 10:10 AM
Cannot Install ATI Drivers RoninBlade Linux - Hardware 3 12-25-2004 06:52 PM
Install ATI drivers gaborn415 Linux - Newbie 1 04-14-2004 02:06 AM
ATI M9 install drivers estrondo Linux - Laptop and Netbook 0 02-19-2004 10:57 AM


All times are GMT -5. The time now is 12:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration