LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 03-18-2005, 10:28 PM   #1
machineunreal
LQ Newbie
 
Registered: Mar 2005
Posts: 14

Rep: Reputation: 0
trying to install ati drivers


[root@johnny root]# rpm -ivh fglrx64.rpm
error: failed dependencies:
libX11.so.6()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libXext.so.6()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libc.so.6()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libc.so.6(GLIBC_2.2.5)(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libc.so.6(GLIBC_2.3)(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libdl.so.2()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libdl.so.2(GLIBC_2.2.5)(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libm.so.6()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libm.so.6(GLIBC_2.2.5)(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libpthread.so.0()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by fglrx64_6_8_0-8.10.19-1
librt.so.1()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
librt.so.1(GLIBC_2.2.5)(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libstdc++.so.5()(64bit) is needed by fglrx64_6_8_0-8.10.19-1
libstdc++.so.5(CXXABI_1.2)(64bit) is needed by fglrx64_6_8_0-8.10.19-1 libstdc++.so.5(GLIBCPP_3.2)(64bit) is needed by fglrx64_6_8_0-8.10.19-1


running mandrake 9.0.....what do I do?

if i downloaded the wrong drivers, what ones do i download?

card is a 3d rage pro, agp 1x/2x
 
Old 03-19-2005, 11:22 AM   #2
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
It's probably the wrong one. Try to download the one for your system. Not sure what your system is.
 
Old 03-19-2005, 03:59 PM   #3
Robert G. Hays
Member
 
Registered: Jan 2003
Location: Atlanta, Ga., USA
Distribution: Gentoo, Mandrake, ~others
Posts: 157

Rep: Reputation: 30
Thorny thing to do -- I've tried several times & am about to again, but no longer under suse -- I'm abandoning suse for *something*... (ATI All In Wonder 9600, dual-monitors, 128MB AGP 8x.)

You will need to know your exact card & if it is a TRUE ATI-branded, AND your installed XFree86 or XOrg version:

rpm -q XFree

should tell you this if XFree; not sure naming if XOrg.

Anyway, with these in hand, go to ati.com & find the right rpm, and see how far that gets you.
I understand that Mandrake is still ATI-friendly, which is nice, since ATI was always Linux-friendly when no one else was.

LOL,

Last edited by Robert G. Hays; 03-19-2005 at 04:05 PM.
 
Old 04-02-2005, 08:45 AM   #4
machineunreal
LQ Newbie
 
Registered: Mar 2005
Posts: 14

Original Poster
Rep: Reputation: 0
after doing a little "rpm -q XFree" it tells me that XFree is not installed. So i goto Xfree.org, and install the correct one. (after checking with sh xinstall.sh -check) and that says it's totally successfull in installing, so i ask the command prompt "rpm -q XFree" again and it still says XFree is not installed!
 
Old 04-03-2005, 09:10 AM   #5
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
rpm -qa | grep X

the other way it must match exactly where using grep you can filter the output of all installed rpm's and return anything with X in it like XFree86 or Xorg.




Last edited by DavidPhillips; 04-03-2005 at 09:13 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't install ATI drivers ne more!!! shorty_boy Debian 1 05-23-2005 03:22 PM
ATI Drivers : Problem After Install JyushinX Mandriva 10 03-15-2005 07:00 AM
Cannot Install ATI Drivers RoninBlade Linux - Hardware 3 12-25-2004 05:52 PM
Install ATI drivers gaborn415 Linux - Newbie 1 04-14-2004 01:06 AM
ATI M9 install drivers estrondo Linux - Laptop and Netbook 0 02-19-2004 09:57 AM


All times are GMT -5. The time now is 07:48 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration