LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-11-2011, 08:17 AM   #1
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Rep: Reputation: 31
.aspx links in my browser are wrongly saved as files


Hi!

I did a setting. After that all my .aspx links in my browser are saved as files. For example this shortcut:

http://sverigesradio.se/sida/default.aspx?programid=412

How do I alter the file association setting for .aspx files back to normal?

I'm running Firefox on Linux Mint 11.

Last edited by thort; 12-17-2011 at 09:22 AM.
 
Old 12-11-2011, 09:09 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,817

Rep: Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002Reputation: 1002
Go to Preferences in firefox, and click on the applications tab. Double check to make sure that the asp and aspx file extensions are not set. If you still have the problem, you could always create a blank .aspx file within your file manager, right click, the click on "open with" and tell it to ask every time.

Cheers,

Josh
 
Old 12-12-2011, 02:31 AM   #3
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
Thanks Josh!

Quote:
Originally Posted by corp769 View Post
Go to Preferences in firefox, and click on the applications tab. Double check to make sure that the asp and aspx file extensions are not set.
I did go to Preferences, and set it to "always ask". Here you can see my Firefox setting

Now, when I try opening a aspx-link in Firefox this window pops up. If I choose open with, this window appear, but I don't know what to choose here.

Quote:
Originally Posted by corp769 View Post
If you still have the problem, you could always create a blank .aspx file within your file manager, right click, the click on "open with" and tell it to ask every time.
I right-clicked on the .aspx file. And choosed "open with". But, here also, I don't find my way in the complicated folder structure. I assume I have to find Firefox somewhere.

I would appreciate some more assistance.
 
Old 12-17-2011, 01:55 AM   #4
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
Bump

I'm thankful for every little hint. Some way, it must be possible to reset my Firefox to open up .aspx links.
 
Old 12-17-2011, 10:38 AM   #5
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
I think the point is that "aspx" should not appear in the list in the "Applications" tab, because it means Firefox thinks those files are things that must be handled by external programs. I'm not sure how to remove it from the list, though. I did find this, that you might like to try. Edit: If that doesn't help, I'd try creating a new profile.

Last edited by Nylex; 12-17-2011 at 10:40 AM.
 
Old 12-18-2011, 03:56 AM   #6
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
Thanks Nylex! I do appreciate your advices.

Quote:
Originally Posted by Nylex View Post
I did find this, that you might like to try.
I installed the "User Agent Switcher" extension. But, I don't understand the purpose of this extension. What is an "User Agent" and why switch it? In the settings there are options for Internet Explorer and IPhone. Nothing about Firefox. And I can't find any manual for the extension.

Quote:
Originally Posted by Nylex View Post
Edit: If that doesn't help, I'd try creating a new profile.
I tried this also. But it didn't help. Still, every time I click on an .aspx link a window pops up questioning me how to open up the file type.

I would appreciate some more help.
 
Old 12-19-2011, 06:05 AM   #7
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
The user agent is how your browser is identified to websites. The switcher extension is for, well, switching that identification which is useful for some sites that claim to not support certain browsers. Come to think of it, I'm not sure now why that's supposed to be relevant for that problem.

I'm also out of suggestions, I'm afraid. If people here are unable to help you, then I'd try the Mozilla forums here.
 
Old 12-19-2011, 12:28 PM   #8
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
Hi Nylex! Thanks for your reply! It seems like a good idea to ask about my problem at the Mozilla forum. My problem seems to be related to Firefox.

When my problem is solved I will post the solution here.
 
Old 12-19-2011, 12:38 PM   #9
Nylex
LQ Addict
 
Registered: Jul 2003
Location: London, UK
Distribution: Slackware
Posts: 7,464

Rep: Reputation: Disabled
No problem.

Quote:
Originally Posted by thort View Post
When my problem is solved I will post the solution here.
That's what we like to hear .
 
Old 12-28-2011, 04:49 AM   #10
thort
Member
 
Registered: Nov 2003
Location: Sweden
Distribution: Linux Mint Cinnamon 17.3
Posts: 192

Original Poster
Rep: Reputation: 31
Hi again!

Now I have found the solution. I found out it was only aspx-links on http://sverigesradio.se that didn't open up in Firefox. In Google Chromium they all open up. A Swedish thread on Ubuntu Sverige gave me the solution.

I installed the Firefox add-on UAControl. With this add-on it's possible to prevent Firefox from sending User Agent information. It's possible to block this for specific sites. This I did. Now, all aspx-links on sverigesradio.se opens up.

sverigesradio.se is the Swedish Radio public service. It's strange their site doesn't work on Firefox Linux.

Last edited by thort; 12-28-2011 at 04:53 AM.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't open saved web pages just saved by web browser... JeanBrownHarrel General 2 04-06-2008 12:52 PM
Playing aspx files on Damn Small Linux... MegaSvensk Linux - Software 0 10-11-2007 09:02 AM
Doom 3: Using native installer and can't locate saved game files or config files JBailey742 Linux - Games 11 08-14-2006 07:09 PM
My browser Lost Saved Passwords rabeea General 2 09-07-2005 03:58 PM


All times are GMT -5. The time now is 02:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration