LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 10-16-2003, 12:12 AM   #31
vegeta_nc
LQ Newbie
 
Registered: Oct 2003
Location: Spring Tx.
Distribution: Mandrake and Slackware
Posts: 16

Rep: Reputation: 0

I'd go ahead and through in that card and make the drive single/master and on the first ide channel. If the card is supported by your kernel, then the drive should be /dev/hde
 
Old 10-16-2003, 12:12 AM   #32
mcas
LQ Newbie
 
Registered: May 2003
Posts: 24

Original Poster
Rep: Reputation: 15
No, I am pretty sure its not. It's keyed and has a blocked out pin, so it can't fit in any other way. Also, the bios on the computer and the initialization of Red Hat Linux 9 recognizes the drive. I just can't seem to figure out how to partition it. Is there a way to run Disk Druid from the command line or on the GUI interface? I was wondering if that would make it show up?
 
Old 10-16-2003, 12:13 AM   #33
mcas
LQ Newbie
 
Registered: May 2003
Posts: 24

Original Poster
Rep: Reputation: 15
Ok I'll give that a try in the morning. Getting cross eyed right now. Better check out for some zzzzzzzz.
 
Old 10-16-2003, 10:40 AM   #34
mcas
LQ Newbie
 
Registered: May 2003
Posts: 24

Original Poster
Rep: Reputation: 15
Went ahead and put in the Promise Technology ATA card and Linux can now see the drive. I got the fdisk to work - set up one large partition (I am working on a large database), since this is my spare drive. I tried to run mkfs -c -t ext3 /dev/hde1 but it doesn't seem to work. Get a "bad blocks count" type error. When I check it out using the Hardware Browser it shows up as a NTFS format. ( I had deleted the partition I initially installed described above using Maxtors Fdisk as NTFS. When I ran fdisk, I was able to delete this old partion, put in a new one as primary 1. When I ran "v" it said there were 62 unallocated sectors - I assume this was OK and when I ran w, it said the partition table had been altered. Do I have to do something like mount it before I run mkfs? Making progress, but still confused. That's a newbie for you!
 
Old 10-16-2003, 10:43 AM   #35
mcas
LQ Newbie
 
Registered: May 2003
Posts: 24

Original Poster
Rep: Reputation: 15
Well, tried mkfs with just "mkfs -t ext3 /dev/hde1" and that seems to be working. Not sure what the problem was with -c and -v options. We'll see where this leads.
 
Old 10-16-2003, 12:01 PM   #36
mcas
LQ Newbie
 
Registered: May 2003
Posts: 24

Original Poster
Rep: Reputation: 15
It appears to be working now. I'll summarize the issues I faced and their resolution.

Problem: I couldn't get a Maxtor 160G ATA/133 second hard drive recognized by Red Hat Linux 9.0. My primary drive is a Western Digital 180G ATA/100 drive. The physical hardware connection seemed to go fine with the drive recognized by the bios, and even by the Maxtor utility program and if I reran Red Hat installation. However, when I went to run fdisk /dev/hdb I would get an error "Unable to open /dev/hdb"

Solution: Upon the recommendation of vegeta_nc, I installed a Promise Technology Ultra100 tx2 ATA controller card and connected the drive to it. This allowed Linux to see the drive. The following steps were used to completion.

1) Ran "fdisk /dev/hde1"
a) Used the commands "p" to display the existing partitions
b) "d" to delete a partion I created when I ran the Maxtor utility.
c) "n" to add a new partition, selecting p for Primary and 1 for partition number and using the defaults 1 and 19920 for the first and last cylinders (just pressed enter at the command prompt). I stayed with the default Id type of 83 Linux native, because I found this supported the ext3 format.
d) ran "v" to verify the partion table
e) ran w to write the table.


2) then I ran "mkfs -t ext3 /dev/hde1". I had problems with the "-c" and "-v" settings, but without that it seemed to work fine.

3) I created the directory /mnt/hde1 using mkdir /mnt/hde1.

4) I then edited /etc/fstab and added the line "/dev/hde1 /mnt/hde1 ext3 defaults,users 1 1"

5) I rebooted and everything looks fine. I am copying files and testing the drive to see how it goes.

6) My next challenge is to try to reconfigure MySQL to use the new drive as its default directory. Hopefully that won't be as challenging!

Hope this helps someone else out there. As a newbie I appreciate these forums in treking through a new world! Best of luck and thanks to those that responded!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
weird fdisk problem (Fdisk unable to see winxp partitions) khidot Slackware - Installation 5 04-07-2007 09:26 PM
fdisk on SCSI drive tdmg Slackware 4 07-11-2005 06:59 PM
How do I fdisk a scsi drive??? dabauer Linux - Hardware 3 02-10-2005 05:30 PM
I have destroyed my second drive partition w/ FDISK AceTech747 Linux - Software 2 04-15-2004 08:58 AM
did I kill my hard drive using FDISK? jodansmif Linux - Hardware 1 02-24-2004 05:27 PM


All times are GMT -5. The time now is 08:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration