LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Newbie
User Name
Password
Linux - Newbie This Linux forum is for members that are new to Linux.
Just starting out and have a question? If it is not in the man pages or the how-to's this is the place!

Notices


Reply
  Search this Thread
Old 12-16-2003, 06:14 PM   #16
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Rep: Reputation: 30

when you get back..

right click somwhere on ur desktop

go to run command or command line - (somehting liek that)

type:

koqueror

this should bring up a window

in the address bar type in /etc/X11/XF86Config

this should open up a file with a lot of text

scroll all the way down and keep an eye out for a little klump of iniformation related to resolutions

you will see a few resolutions if your in the right area ("640x840" or "800x600")

now right after all those resolutions put your disired resolution
example:

"1024x768"

now save the file and restart

also make sure your have the right drivers
 
Old 12-16-2003, 06:16 PM   #17
Longinus
Member
 
Registered: Sep 2003
Distribution: Redhat 9.0 && Slackware 9.1
Posts: 420

Rep: Reputation: 30
woops:

konqueror

is what you type in that first part
 
Old 12-16-2003, 06:19 PM   #18
MartinN
Member
 
Registered: Nov 2003
Location: Ronneby, Sweden
Posts: 555

Rep: Reputation: 30
Try this with redhat-config-xfree86:

Try probing for first the video card and then monitor. It's under the "Advanced" tab. Check that it got both the video card manufacturer/model and the monitor manufacturer/model correct. If it didn't then you might need to know some more information about the monitor.

There are two fields where you can set the horizontal and vertical sync ranges for the monitor. These should be in the manual for your monitor or you can search for your monitor's specification on the Net. Enter these ranges in the fields and then try to go to 800*600.

As a last resort, you could try these settings (they are for a _very_ old 14" IBM monitor). They will probably work, but may not utilize your monitor's full capacity.

Hsync 30-38 kHz
Vsync 50-90 Hz

I'm going to sleep now (it's well beyond midnight here in Sweden). I'll check in sometime tomorrow to see if it worked out for you.

Good luck!
Martin
 
Old 12-16-2003, 06:22 PM   #19
caid
Member
 
Registered: Dec 2002
Location: NZ
Distribution: slack current
Posts: 61

Rep: Reputation: 15
>>>EDIT : Whoops, didn't see this second page, my bad. ignore the stuff below, it's been covered.

i don't really know, but if you're not using the "vesa" driver already, you could try that?

as root, modify the Section: Device section of your XF86Config file with a text editor e.g. kwrite if you're in x, vi if you're at the console

it'll look something like this:

Section "Device"
Identifier "Card0"
Driver "vesa" <<<< change this to vesa if it isn't already
VendorName "All"
BoardName "All"

and you may also need to change the modes lines in Section: Screen to say something like this (although i would imagine the red hat configurator would have done that for you already...)

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "800x600" "640x480" << this one
EndSubSection
SubSection "Display"
Depth 4
Modes "800x600" "640x480" <<this one etc
EndSubSection
SubSection "Display"
Depth 8
Modes "800x600" "640x480" << all the different modes lines all the way down
EndSubSection
SubSection "Display"
Depth 15
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 32
Modes "800x600" "640x480"
EndSubSection
EndSection

save, exit, then restart X (Ctrl-Alt-Backspace)

if neither of those work, i dunno ;o) i'm just a noob myself, and my nvidia drivers seem to cure all video ills.

good luck

caid

Last edited by caid; 12-16-2003 at 06:25 PM.
 
Old 12-16-2003, 06:43 PM   #20
carlgulliver100
Member
 
Registered: Dec 2003
Distribution: Debian, FC5, Win2003 Server
Posts: 118

Original Poster
Rep: Reputation: 15
Thanks all, I will try those now.

Thanks again
Carl...
 
Old 12-16-2003, 06:57 PM   #21
carlgulliver100
Member
 
Registered: Dec 2003
Distribution: Debian, FC5, Win2003 Server
Posts: 118

Original Poster
Rep: Reputation: 15
Hi peeps. I entered konqueror in the terminal and i found the /etc/X11/XF86Config file and edited it but when i come to save it says you do not have write permission? What does this mean? Please help.

Thank you.
Carl...
 
Old 12-16-2003, 08:31 PM   #22
caid
Member
 
Registered: Dec 2002
Location: NZ
Distribution: slack current
Posts: 61

Rep: Reputation: 15
you need to be root.

i don't use red hat so i don't know if there's a way to open a "superuser konqueror", but you could either

1) open a terminal, su, then type konqueror to open it as root, or
2) if you use KDE then hit alt-F2 keys to open up the run command option, type konqueror, click on options, check the "run as different user", make sure root is selected under username and then fill in the password field below.

caid

Last edited by caid; 12-16-2003 at 08:41 PM.
 
Old 12-17-2003, 02:46 AM   #23
carlgulliver100
Member
 
Registered: Dec 2003
Distribution: Debian, FC5, Win2003 Server
Posts: 118

Original Poster
Rep: Reputation: 15
Hi, I have done that and added my resolutions but my monitor is still going off when i change it, It will only stay on if i use 640x480. Please help.

Thank you
Carl...
 
Old 12-17-2003, 06:13 AM   #24
ears
LQ Newbie
 
Registered: Dec 2003
Posts: 5

Rep: Reputation: 0
Unhappy strange

Does anyone use Debian? If so do you know how i can write a shell script to clear the screen when logout or exit is typed? i'm helping maintain a network and peeps are complaining there is not enough privicy on the system...
 
Old 12-17-2003, 06:26 AM   #25
carlgulliver100
Member
 
Registered: Dec 2003
Distribution: Debian, FC5, Win2003 Server
Posts: 118

Original Poster
Rep: Reputation: 15
Hi again, I have another prob now with my modem. I try setting it up with my account and select activate and it just says activating for ages and I dont think its doing anything..Please help. Plus I put them graphic settings in my xf86Config file but my monitor still goes off ?

Thanks
Carl...
 
Old 12-17-2003, 06:32 AM   #26
ears
LQ Newbie
 
Registered: Dec 2003
Posts: 5

Rep: Reputation: 0
as 4 the monitor prob, i had this and ended up reinstalling my system several times...are you using the correct sync values in the xf86config thing? as for the modem...you should have set it up in the origional instalation when you installed the system...but i'll keep thinking of a solution...
 
Old 12-17-2003, 06:34 AM   #27
carlgulliver100
Member
 
Registered: Dec 2003
Distribution: Debian, FC5, Win2003 Server
Posts: 118

Original Poster
Rep: Reputation: 15
Hi Rich, I have re-installed it 4 times now and the same happens each time. It didnt ask me for any modem settings, but when i went into the setup it says theres a modem on, but when itry and activate it, it just says please wait... and does nothing
What problems did you have with your monitor and graphics?

Thanks
Carl.....
 
Old 12-17-2003, 06:41 AM   #28
ears
LQ Newbie
 
Registered: Dec 2003
Posts: 5

Rep: Reputation: 0
i was stuck in 640 by 480 and 16 bit colour, now i'm running it on a higher res in 24 bit... as 4 the modem when i started i had a screen that had instructions to follow, and the modem was in the kernall driver moduls...i just went down and found my modem/network card...that worked 4 me, there might also be the problem that its not plugged in correctly...had that happen when i dropped my mchine...!!!can't remember what i did to the monitor settings though...will look it up...
 
Old 12-17-2003, 06:44 AM   #29
carlgulliver100
Member
 
Registered: Dec 2003
Distribution: Debian, FC5, Win2003 Server
Posts: 118

Original Poster
Rep: Reputation: 15
cheers rich
 
Old 12-17-2003, 06:49 AM   #30
ears
LQ Newbie
 
Registered: Dec 2003
Posts: 5

Rep: Reputation: 0
no prob, hope it helps...
Found out what was wrong...when you go and use xf86config if you lie about the settings then i won't work, bu tif you find the info settings on the monitor then input them then it should work, oh don't let the comp choose the settings exceptthe one for the max size...i hope that works, but thats what i did to sort the prob...
good luck!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
640x480 HEEEEEEELP ton31 Linux - Newbie 0 01-05-2005 02:32 PM
Not going above 640x480 pal_no_1 Fedora 2 12-30-2004 11:58 PM
Slakcware @ 640x480??? tranquil.au Slackware 4 01-09-2004 02:38 AM
Stuck at 640X480 :( BigDaddy Linux - Software 1 09-28-2003 05:33 PM
Can't get above 640x480 res Culbert Linux - General 2 09-02-2003 12:47 PM


All times are GMT -5. The time now is 03:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration