LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-14-2011, 06:39 AM   #1
lapinux
LQ Newbie
 
Registered: Mar 2011
Location: France
Distribution: SuSE & openSuSE
Posts: 8

Rep: Reputation: 0
Angry win7 web client problem with apache2 web server on linux


Hello,

I've installed a web server powered by apache2 v2.2.15-3.7.x86_64 under
OpenSuSE 11.3.
On the linux machine openning konqueror/firefox with the url of
the web page (let's say www.doc.net) displays the correct page.
On the winXP machines of the network, openning IE/firefox with the url
of the web page displays the correct page.
On the win7 machines of the network, openning navigator with the url
of the web page displays the windows error message saying that
the page cannot be displayed (no error 404).
At the command line of the win7 ping url of the web page gives no answer
but ping linux name server responds immediately.

On the win7 I've
-disabled ipv6 (thought of a conflict between ipv4 and ipv6)
-dns is configured and is the linux machine with the ip of the web server
-wins is configured and is the linux machine with the ip if the web server

I'm thinking of a problem of name resolution on the win7. I just don't
see where the solution could be because win7 knows the server machine
and accesses it well with samba for example (or telnet or else) but
can't ping the url of the web server on this machine.

Does someone have an idea ?

Thanks
 
Old 03-14-2011, 08:43 AM   #2
bathory
Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 10,970

Rep: Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343Reputation: 1343
You can add the host/IP pair of your server in the hosts file. If you're like me, that I don't have a clue about win7, have a look here

Regards
 
Old 03-15-2011, 01:21 PM   #3
lapinux
LQ Newbie
 
Registered: Mar 2011
Location: France
Distribution: SuSE & openSuSE
Posts: 8

Original Poster
Rep: Reputation: 0
Thanks bathory, my problem is solved.

I've added the ip/name of the linux box and the ip/url of each web
server hosted on the linux box and now it's ok.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm trying to set up my web server with Apache2 using Debain Linux. SimRacer Linux - Server 4 11-02-2006 03:23 PM
Linux terminal Server for windows client web browsing? hawkpaul Linux - Enterprise 6 09-24-2005 07:04 PM
Configuring the tree structure of a web server with apache2?? AQG Linux - Software 7 06-30-2005 04:47 PM
Linux Client to Windows Web Server Problems anathema Linux - Networking 1 11-12-2003 10:05 AM
Can't access Linux web server web pages from LAN client jaydave Linux - Networking 4 03-16-2003 03:38 AM


All times are GMT -5. The time now is 11:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration