LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   win7 web client problem with apache2 web server on linux (http://www.linuxquestions.org/questions/linux-networking-3/win7-web-client-problem-with-apache2-web-server-on-linux-868438/)

lapinux 03-14-2011 05:39 AM

win7 web client problem with apache2 web server on linux
 
Hello,

I've installed a web server powered by apache2 v2.2.15-3.7.x86_64 under
OpenSuSE 11.3.
On the linux machine openning konqueror/firefox with the url of
the web page (let's say www.doc.net) displays the correct page.
On the winXP machines of the network, openning IE/firefox with the url
of the web page displays the correct page.
On the win7 machines of the network, openning navigator with the url
of the web page displays the windows error message saying that
the page cannot be displayed (no error 404).
At the command line of the win7 ping url of the web page gives no answer
but ping linux name server responds immediately.

On the win7 I've
-disabled ipv6 (thought of a conflict between ipv4 and ipv6)
-dns is configured and is the linux machine with the ip of the web server
-wins is configured and is the linux machine with the ip if the web server

I'm thinking of a problem of name resolution on the win7. I just don't
see where the solution could be because win7 knows the server machine
and accesses it well with samba for example (or telnet or else) but
can't ping the url of the web server on this machine.

Does someone have an idea ?

Thanks

bathory 03-14-2011 07:43 AM

You can add the host/IP pair of your server in the hosts file. If you're like me, that I don't have a clue about win7, have a look here

Regards

lapinux 03-15-2011 12:21 PM

Thanks bathory, my problem is solved.

I've added the ip/name of the linux box and the ip/url of each web
server hosted on the linux box and now it's ok.


All times are GMT -5. The time now is 05:43 AM.