LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 02-12-2005, 06:05 PM   #1
n8tgc
Member
 
Registered: Jul 2004
Location: Metro Detroit
Distribution: SUSE 10, 11.1 & DSL
Posts: 35

Rep: Reputation: 15
Question VSFTPD - Public Access - How?


In setting up VSFTP I would like to allow full public (read only) access. Public enough so that Windows users on the LAN can easier retreive files with IE without the need to type in a username or password. Security beyond that is of little concern since this sn isolated network w/o 'net access.

Here is my vsftpd.conf file. It works fine but requires a manual login with username of "anonymous". I would love to circumvent even that.


***
anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
pam_service_name=vsftpd
userlist_enable=NO
listen=YES
tcp_wrappers=YES
***


Any suggestions?

Thank you in advance for any assistance!


Chris
 
Old 02-12-2005, 10:41 PM   #2
angrybeaver
Member
 
Registered: Aug 2004
Location: .au
Distribution: debian, BSD
Posts: 104

Rep: Reputation: 16
pretty sure that you can't just allow connections in without authenticating. If its on a LAN, samba may be a better option if typing 'anonymous' and a dummy email address is too much effort for your users...
 
Old 02-13-2005, 01:44 AM   #3
Gaurav Wadhwa
LQ Newbie
 
Registered: Jan 2005
Location: London
Posts: 21

Rep: Reputation: 15
Well, To allow LAN users on Windows OS to read-only access on linux VSFTP without providing username and password. You need to make certain changes in your /etc/vsftpd.conf file, as folows :


anonymous_enable=YES

Comment out these lines:-

local_enable=YES
write_enable=YES


and that's sit. you don't have to make other changes. after it, save and exit with "wq" and restart the service and make sure that firewall service is stop or configured to allow FTP access.

You can check firewall access to use "redhat-config-securitylevel" command or try to use "setup" command and choose firewall configuration option and from there, choose customize and allow FTP access.

Alternatively, You can just stop the service with "service iptables stop" command.

Then, run "service vsftpd restart" twice.

That's sit.

Go to any windows computer on LAN and go to IE. Type
"ftp://IPaddress_of_FTPserver" and you'll be in.

Bye......

With Warm Regards
Wadhwa, Gaurav
 
Old 02-13-2005, 10:24 PM   #4
n8tgc
Member
 
Registered: Jul 2004
Location: Metro Detroit
Distribution: SUSE 10, 11.1 & DSL
Posts: 35

Original Poster
Rep: Reputation: 15
Thank you for the suggestion. However after making the edits, the results are the same. Perhaps SAMBA is the way to go. I was hoping to avoid that path for a few issues.

Nevertheless, I know that having unhindered (read-only) FTP access is possible. I just never thought it would be quite so difficult.


Chris
 
Old 02-14-2005, 11:27 PM   #5
n8tgc
Member
 
Registered: Jul 2004
Location: Metro Detroit
Distribution: SUSE 10, 11.1 & DSL
Posts: 35

Original Poster
Rep: Reputation: 15
Got it!

Ok, I found the problem. The firewall on my workstation did not have the Ethernet device selected as a trusted device. As a result, when a passive FTP connection was made, the necessary port was restricted by the firewall. Once the network device was identified as a trusted device, everything started working perfectly.

Gaurav, thanks for the suggestions in the vsftpd.conf file. They worked!



Chris
 
Old 02-15-2005, 07:19 PM   #6
LordDark
LQ Newbie
 
Registered: Feb 2005
Location: Ecuador
Distribution: Red Hat, Fedora Core
Posts: 15

Rep: Reputation: 0
Try it...

anonymous_enable=YES
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=YES
pam_service_name=vsftpd
userlist_enable=YES
listen=YES

good luck!!!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
public access help tallmtt Linux - Wireless Networking 3 06-05-2006 06:20 PM
How to Access denied in NATting to public IP? qutub110 Linux - Security 1 06-14-2005 12:22 PM
Script for accessing public access points... L1nuxR0x Linux - Wireless Networking 2 04-23-2005 01:40 PM
Connect to public access points mwademan Linux - Wireless Networking 0 03-02-2004 12:51 PM
How to access hosts from LAN through public ip? mkostrze Linux - Security 4 04-26-2002 10:34 AM


All times are GMT -5. The time now is 09:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration